summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Tortuyaux <mtortuyaux@microsoft.com>2022-07-09 16:20:09 +0200
committerSam James <sam@gentoo.org>2022-07-14 12:06:03 +0100
commitf1367051f359503107ca26cc9971f5513da9f50d (patch)
treeaa95bec6ea826da9f2d6d0468ec710395b2f312c /net-analyzer
parentx11-apps/xrectsel: EAPI 8 (diff)
downloadgentoo-f1367051f359503107ca26cc9971f5513da9f50d.tar.gz
gentoo-f1367051f359503107ca26cc9971f5513da9f50d.tar.bz2
gentoo-f1367051f359503107ca26cc9971f5513da9f50d.zip
net-analyzer/nmap: add symlink from ncat to nc
For compatiblity, it's good to have `nc` in the PATH too. [sam: keep it as an extra flag to avoid more blockers; it's useful to be able to evaluate two implementations.] Closes: https://github.com/gentoo/gentoo/pull/26287 Signed-off-by: Mathieu Tortuyaux <mtortuyaux@microsoft.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/nmap/metadata.xml1
-rw-r--r--net-analyzer/nmap/nmap-7.92-r1.ebuild (renamed from net-analyzer/nmap/nmap-7.92.ebuild)9
-rw-r--r--net-analyzer/nmap/nmap-9999.ebuild9
3 files changed, 15 insertions, 4 deletions
diff --git a/net-analyzer/nmap/metadata.xml b/net-analyzer/nmap/metadata.xml
index 21fee1f7bbb0..4ca312aa6de6 100644
--- a/net-analyzer/nmap/metadata.xml
+++ b/net-analyzer/nmap/metadata.xml
@@ -18,6 +18,7 @@
<flag name="ncat">Install the ncat utility</flag>
<flag name="nping">Install the nping utility</flag>
<flag name="nse">Include support for the Nmap Scripting Engine (NSE)</flag>
+ <flag name="symlink">Install symlink to nc</flag>
<flag name="system-lua">Use <pkg>dev-lang/lua</pkg> instead of the bundled liblua</flag>
</use>
</pkgmetadata>
diff --git a/net-analyzer/nmap/nmap-7.92.ebuild b/net-analyzer/nmap/nmap-7.92-r1.ebuild
index 8d80c56138aa..752a2273e4f7 100644
--- a/net-analyzer/nmap/nmap-7.92.ebuild
+++ b/net-analyzer/nmap/nmap-7.92-r1.ebuild
@@ -29,8 +29,11 @@ else
fi
SLOT="0"
-IUSE="ipv6 libssh2 ncat nping +nse ssl +system-lua"
-REQUIRED_USE="system-lua? ( nse ${LUA_REQUIRED_USE} )"
+IUSE="ipv6 libssh2 ncat nping +nse ssl symlink +system-lua"
+REQUIRED_USE="
+ system-lua? ( nse ${LUA_REQUIRED_USE} )
+ symlink? ( ncat )
+"
RDEPEND="
dev-libs/liblinear:=
@@ -130,4 +133,6 @@ src_install() {
install
dodoc CHANGELOG HACKING docs/README docs/*.txt
+
+ use symlink && dosym /usr/bin/ncat /usr/bin/nc
}
diff --git a/net-analyzer/nmap/nmap-9999.ebuild b/net-analyzer/nmap/nmap-9999.ebuild
index 2812d6599000..3b55f48a5dbd 100644
--- a/net-analyzer/nmap/nmap-9999.ebuild
+++ b/net-analyzer/nmap/nmap-9999.ebuild
@@ -29,8 +29,11 @@ else
fi
SLOT="0"
-IUSE="ipv6 libssh2 ncat nping +nse ssl +system-lua"
-REQUIRED_USE="system-lua? ( nse ${LUA_REQUIRED_USE} )"
+IUSE="ipv6 libssh2 ncat nping +nse ssl symlink +system-lua"
+REQUIRED_USE="
+ system-lua? ( nse ${LUA_REQUIRED_USE} )
+ symlink? ( ncat )
+"
RDEPEND="
dev-libs/liblinear:=
@@ -131,4 +134,6 @@ src_install() {
install
dodoc CHANGELOG HACKING docs/README docs/*.txt
+
+ use symlink && dosym /usr/bin/ncat /usr/bin/nc
}