summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-07-18 00:21:06 +0100
committerSam James <sam@gentoo.org>2023-07-18 00:21:06 +0100
commitea418eaedef80e80dc7e868ddd8b9130753f69c1 (patch)
tree39fc18b900bcf6df4fcd25513bd6424a18744b68 /net-analyzer
parentdev-libs/opensc: fix patch filename (diff)
downloadgentoo-ea418eaedef80e80dc7e868ddd8b9130753f69c1.tar.gz
gentoo-ea418eaedef80e80dc7e868ddd8b9130753f69c1.tar.bz2
gentoo-ea418eaedef80e80dc7e868ddd8b9130753f69c1.zip
net-analyzer/net-snmp: port live to libpcre2
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/net-snmp/net-snmp-9999.ebuild13
1 files changed, 4 insertions, 9 deletions
diff --git a/net-analyzer/net-snmp/net-snmp-9999.ebuild b/net-analyzer/net-snmp/net-snmp-9999.ebuild
index c7a25ac6302a..1c946612076d 100644
--- a/net-analyzer/net-snmp/net-snmp-9999.ebuild
+++ b/net-analyzer/net-snmp/net-snmp-9999.ebuild
@@ -6,7 +6,7 @@ EAPI=8
DISTUTILS_OPTIONAL=yes
DISTUTILS_SINGLE_IMPL=yes
GENTOO_DEPEND_ON_PERL=no
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..11} )
WANT_AUTOMAKE=none
inherit autotools distutils-r1 perl-module systemd
@@ -47,7 +47,7 @@ COMMON_DEPEND="
netlink? ( dev-libs/libnl:3 )
pcap? ( net-libs/libpcap )
pci? ( sys-apps/pciutils )
- pcre? ( dev-libs/libpcre )
+ pcre? ( dev-libs/libpcre2 )
perl? ( dev-lang/perl:= )
python? (
$(python_gen_cond_dep '
@@ -91,12 +91,6 @@ PATCHES=(
"${FILESDIR}"/${PN}-5.8-pcap.patch
"${FILESDIR}"/${PN}-5.8.1-mysqlclient.patch
"${FILESDIR}"/${PN}-5.9-MakeMaker.patch
- "${FILESDIR}"/${P}-configure-clang16.patch
- # https://github.com/net-snmp/net-snmp/pull/493
- "${FILESDIR}"/${PN}-5.9.3-0001-Fix-LDFLAGS-vs-LIBS-ordering.patch
- "${FILESDIR}"/${PN}-5.9.3-0002-Tidy-up-net-snmp-config-output.patch
- "${FILESDIR}"/${PN}-5.9.3-0003-Prune-Libs.private-entries-in-netsnmp-.pc.in.patch
- "${FILESDIR}"/${PN}-5.9.3-0004-Search-for-ltinfo-in-configure-if-needed.patch
)
pkg_setup() {
@@ -148,7 +142,8 @@ src_configure() {
$(use_with netlink nl) \
$(use_with pcap) \
$(use_with pci) \
- $(use_with pcre) \
+ $(use_with pcre pcre2-8) \
+ --without-pcre \
$(use_with perl perl-modules INSTALLDIRS=vendor) \
$(use_with python python-modules) \
$(use_with rpm) \