summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2017-09-24 19:38:34 +0000
committerPatrick Lauer <patrick@gentoo.org>2017-09-24 19:40:09 +0000
commita6fb7126f78de2fbd1cc2a3021fd82cd967a2a4d (patch)
treeeb9587f5f61b97edd236cebbe9662fb9524a3b36 /net-analyzer/tsung/tsung-1.7.0.ebuild
parentnet-analyzer/tcpflow: Fix dependencies. (diff)
downloadgentoo-a6fb7126f78de2fbd1cc2a3021fd82cd967a2a4d.tar.gz
gentoo-a6fb7126f78de2fbd1cc2a3021fd82cd967a2a4d.tar.bz2
gentoo-a6fb7126f78de2fbd1cc2a3021fd82cd967a2a4d.zip
net-analyzer/tsung: Bump
Package-Manager: Portage-2.3.10, Repoman-2.3.3
Diffstat (limited to 'net-analyzer/tsung/tsung-1.7.0.ebuild')
-rw-r--r--net-analyzer/tsung/tsung-1.7.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/net-analyzer/tsung/tsung-1.7.0.ebuild b/net-analyzer/tsung/tsung-1.7.0.ebuild
new file mode 100644
index 000000000000..d2d90fd44c21
--- /dev/null
+++ b/net-analyzer/tsung/tsung-1.7.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+# Seems to be misconfigured
+RESTRICT="test"
+
+inherit eutils
+
+DESCRIPTION="Erlang's multi-protocol distributed load testing tool"
+HOMEPAGE="http://tsung.erlang-projects.org/"
+SRC_URI="http://tsung.erlang-projects.org/dist/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gnuplot"
+
+DEPEND="dev-lang/erlang"
+RDEPEND="
+ gnuplot? (
+ sci-visualization/gnuplot
+ dev-perl/Template-Toolkit
+ )
+ ${DEPEND}
+"
+src_configure() {
+ ./configure --prefix="/usr" || die "econf failed"
+}
+
+src_compile() {
+ emake || die "Failed building"
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install || die "Failed installing"
+}