summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-12-11 04:46:38 +0000
committerSam James <sam@gentoo.org>2021-12-11 04:46:38 +0000
commit8135d7b8672e2878cefa03430a460e1d903707e6 (patch)
treeff5bb22b1cc1cacd85b58f1f21b044a969350411 /net-analyzer/dhcp_probe
parentdev-perl/txt2html: Remove old (diff)
downloadgentoo-8135d7b8672e2878cefa03430a460e1d903707e6.tar.gz
gentoo-8135d7b8672e2878cefa03430a460e1d903707e6.tar.bz2
gentoo-8135d7b8672e2878cefa03430a460e1d903707e6.zip
net-analyzer/dhcp_probe: add 1.3.1
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer/dhcp_probe')
-rw-r--r--net-analyzer/dhcp_probe/Manifest1
-rw-r--r--net-analyzer/dhcp_probe/dhcp_probe-1.3.1.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/net-analyzer/dhcp_probe/Manifest b/net-analyzer/dhcp_probe/Manifest
index daa2b61e7d68..d14483774cf0 100644
--- a/net-analyzer/dhcp_probe/Manifest
+++ b/net-analyzer/dhcp_probe/Manifest
@@ -1 +1,2 @@
DIST dhcp_probe-1.3.0.tar.gz 211613 BLAKE2B cbcc43b292fe537216ef40de9e417c1f700be4ad5f34feacd9475eb31866b68957ce66c5abc47db3b7e5a0dc8751ca6e54200b79ab2f1f8c3f308f6c1c7aef4d SHA512 d643012529ee5149adbc0c1f19f8e579c55201e86de2aec9b3313be9412db4e973162f864d1baaf79fa340b7bd9a7385f0f1406d1b616e801ced3c7bb387c854
+DIST dhcp_probe-1.3.1.tar.gz 246238 BLAKE2B 86c079c4c7951f3a70ced20dbea5d4f0d716335d2f9a18b1b9986965ca0446b5a7b673c7e652405deceeef336218016418a86be1a76d452c7802061403a66e82 SHA512 1002683e6ceb3806289fa9e4879be3d957a9ddc42656d7114942708560f8efba0db058137e04cad092e5a083900987aa1f76c5a7c20db4b57c104dd6a6fcabb6
diff --git a/net-analyzer/dhcp_probe/dhcp_probe-1.3.1.ebuild b/net-analyzer/dhcp_probe/dhcp_probe-1.3.1.ebuild
new file mode 100644
index 000000000000..33f54daa1e57
--- /dev/null
+++ b/net-analyzer/dhcp_probe/dhcp_probe-1.3.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic
+
+DESCRIPTION="Discover DHCP and BootP servers on a directly-attached Ethernet network"
+HOMEPAGE="https://www.net.princeton.edu/software/dhcp_probe/"
+SRC_URI="https://www.net.princeton.edu/software/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="net-libs/libpcap
+ >=net-libs/libnet-1.1.2.1-r2"
+RDEPEND="${DEPEND}"
+
+DOCS=(
+ AUTHORS
+ ChangeLog
+ NEWS
+ README
+ TODO
+ extras/dhcp_probe.cf.sample
+)
+
+#PATCHES=(
+# "${FILESDIR}"/${PV}/01_dhcp_probe.5.patch
+# "${FILESDIR}"/${PV}/02_dhcp_probe.8.patch
+# "${FILESDIR}"/${PV}/03_implicit_point_conv_bootp.c.patch
+# "${FILESDIR}"/${PV}/04_linux_32_or_64bits.patch
+# "${FILESDIR}"/${PV}/05-cleanup.patch
+# "${FILESDIR}"/${PV}/06-return.patch
+# "${FILESDIR}"/${PV}/07-comment.patch
+# "${FILESDIR}"/${PV}/08-man8.patch
+#)
+
+src_configure() {
+ use amd64 && append-flags -D__ARCH__=64
+ STRIP=true econf
+}
+
+src_install() {
+ default
+
+ dodoc "${FILESDIR}"/${PN}_mail
+
+ newinitd "${FILESDIR}/${PN}.initd" ${PN}
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
+}