summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Laurantin <olivier.laurantin@laposte.net>2023-05-25 22:32:13 +0200
committerJoonas Niilola <juippis@gentoo.org>2023-05-28 10:28:09 +0300
commitc7787bece4cc07cf494635d5121da02fb9838d3f (patch)
treec7a4c10f0f1d1efff317611007da271501302be3 /media-video/ffdiaporama
parentapp-emulation/firecracker-bin: add 1.3.3 (diff)
downloadgentoo-c7787bece4cc07cf494635d5121da02fb9838d3f.tar.gz
gentoo-c7787bece4cc07cf494635d5121da02fb9838d3f.tar.bz2
gentoo-c7787bece4cc07cf494635d5121da02fb9838d3f.zip
media-video/ffdiaporama: add 2.2_pre20230525
Closes: https://bugs.gentoo.org/906496 Signed-off-by: Olivier Laurantin <olivier.laurantin@laposte.net> Closes: https://github.com/gentoo/gentoo/pull/31162 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'media-video/ffdiaporama')
-rw-r--r--media-video/ffdiaporama/Manifest1
-rw-r--r--media-video/ffdiaporama/ffdiaporama-2.2_pre20230525.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/media-video/ffdiaporama/Manifest b/media-video/ffdiaporama/Manifest
index 57455548f43c..93bff6f4e0f3 100644
--- a/media-video/ffdiaporama/Manifest
+++ b/media-video/ffdiaporama/Manifest
@@ -1 +1,2 @@
DIST ffdiaporama-2.2_pre20221007.tar.gz 63271591 BLAKE2B 0fbd20e571329bc294554c50a04920b837af4b62cf4cc7ef356dd9372a8f1f3f01c7b2736fba71c52d468261ad778107e332929ab90d2cf768698102d269a00c SHA512 a37966bb31853de42e7c03a9a1e913332e417278fe663f088d9d9ee763db163549993fa7271b53ad2d495cef5e05d11e3f13ab3343cace3cb4c202aadb461beb
+DIST ffdiaporama-2.2_pre20230525.tar.gz 63270147 BLAKE2B 26cc3ecd7966a945808481c18b2f9a239132cae5016f33e83ef5588c55b1f2a0d7609cd1bdfaf51ada75e1df5274733b7985f6eb3b3814260102f6c9e406ed68 SHA512 777d110b0948bc3c3bdb14e13b4ce09ec819bfac2759c715a1e247b1d6cf8c8461c1ec28a0315f034e4e5a19b4732ce583d71b2edd9c6375b7dae14868cc8dfe
diff --git a/media-video/ffdiaporama/ffdiaporama-2.2_pre20230525.ebuild b/media-video/ffdiaporama/ffdiaporama-2.2_pre20230525.ebuild
new file mode 100644
index 000000000000..efbc9b5a2c90
--- /dev/null
+++ b/media-video/ffdiaporama/ffdiaporama-2.2_pre20230525.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+COMMIT="6b2587064d705de42a3e88468d4922bc27b97e2a"
+
+inherit qmake-utils xdg-utils
+
+DESCRIPTION="Movie creator from photos and video clips"
+HOMEPAGE="https://ffdiaporama.tuxfamily.org"
+SRC_URI="https://github.com/laurantino/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3 CC-BY-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="openclipart"
+
+RDEPEND="
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qthelp:5
+ dev-qt/qtmultimedia:5
+ dev-qt/qtsql:5[sqlite]
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ media-gfx/exiv2:=
+ >=media-video/ffmpeg-4:0=[encode]
+ openclipart? ( media-gfx/openclipart[svg,-gzip] )"
+DEPEND="${RDEPEND}"
+
+DOCS=( authors.txt )
+
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+src_configure() {
+ eqmake5 QMAKE_CFLAGS_ISYSTEM=
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+ if use openclipart; then
+ dosym ../../clipart/openclipart /usr/share/ffDiaporama/clipart/openclipart
+ fi
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+ xdg_icon_cache_update
+}