summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2023-12-14 00:50:41 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2023-12-14 00:50:53 +0100
commit8e836852f35fb00f107a79b3975b6c55f6c4577f (patch)
tree7d9f70cfc16b9b42999b3ac44c15606f9a22b38c /media-sound
parentnet-wireless/unifi: add 8.0.24 (diff)
downloadgentoo-8e836852f35fb00f107a79b3975b6c55f6c4577f.tar.gz
gentoo-8e836852f35fb00f107a79b3975b6c55f6c4577f.tar.bz2
gentoo-8e836852f35fb00f107a79b3975b6c55f6c4577f.zip
media-sound/mpdscribble: bump to 0.25
Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/mpdscribble/Manifest1
-rw-r--r--media-sound/mpdscribble/mpdscribble-0.25.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/media-sound/mpdscribble/Manifest b/media-sound/mpdscribble/Manifest
index 69cedcded4d0..b12bdb87f815 100644
--- a/media-sound/mpdscribble/Manifest
+++ b/media-sound/mpdscribble/Manifest
@@ -1 +1,2 @@
DIST mpdscribble-0.24.tar.xz 69856 BLAKE2B 84143ed7f6978aff32fa759bbe90c934ba5c58df294d375921ffb1cd45de13ecd867fb832940088228fdad4c09948cd82c8dfe9b7fe77d6652743d522bfde8b7 SHA512 cca57f54f69ec1c870805cc58057e6325b6f5897370c315dcd6a64c5dd28ac07fdbddaa8b56f8c1fd88e71d27505f1a87decd68fbdff1f3fe1eaadec8ae80dae
+DIST mpdscribble-0.25.tar.xz 68732 BLAKE2B 292addab1b84831f5b987976dea21938ead9888de828919a32e5c9be725b90d86b65be57bfc6637d3b5121902d646002890381d75bba385e982e9387088b38a2 SHA512 d22c334865794ca45142b2d8edbaffa69cd79b11de33406d1588ea157941973862d3841145a5fe3d530cb8253af944eb9ecc2b6be4fd57c07600e53b63161e47
diff --git a/media-sound/mpdscribble/mpdscribble-0.25.ebuild b/media-sound/mpdscribble/mpdscribble-0.25.ebuild
new file mode 100644
index 000000000000..e21eff2664cf
--- /dev/null
+++ b/media-sound/mpdscribble/mpdscribble-0.25.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson systemd
+
+DESCRIPTION="An MPD client that submits information to Audioscrobbler"
+HOMEPAGE="
+ https://www.musicpd.org/clients/mpdscribble/
+ https://github.com/MusicPlayerDaemon/mpdscribble
+"
+SRC_URI="https://www.musicpd.org/download/${PN}/${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="test"
+# Test program is just an interactive check.
+RESTRICT="!test? ( test ) test"
+
+RDEPEND="
+ dev-libs/boost
+ dev-libs/libgcrypt:=
+ media-libs/libmpdclient
+ net-misc/curl
+"
+
+DEPEND="${RDEPEND}"
+
+DOCS=( AUTHORS COPYING NEWS README.rst )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.23-Unconditionally-generate-systemd-unit-files.patch
+ "${FILESDIR}"/${PN}-0.23-Don-t-install-AUTHORS-COPYING-NEWS-README.rst.patch
+)
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use test)
+ )
+
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ newinitd "${FILESDIR}/mpdscribble.rc" mpdscribble
+ keepdir /var/cache/mpdscribble
+
+ systemd_dounit "${BUILD_DIR}"/systemd/system/"${PN}".service
+ systemd_douserunit "${BUILD_DIR}"/systemd/user/"${PN}".service
+}