summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-08-15 11:25:44 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-08-15 11:25:44 +0200
commit96df86f25ab177ac19ac81cca55c8c6bd1df8bf7 (patch)
tree0f38db19fdbe99a65492e9a2a8b29af18c8d5589 /media-sound/mp3splt/mp3splt-2.6.2.ebuild
parentmedia-libs/libmp3splt: Bump to 0.9.2 (diff)
downloadgentoo-96df86f25ab177ac19ac81cca55c8c6bd1df8bf7.tar.gz
gentoo-96df86f25ab177ac19ac81cca55c8c6bd1df8bf7.tar.bz2
gentoo-96df86f25ab177ac19ac81cca55c8c6bd1df8bf7.zip
media-sound/mp3splt: Bump to 2.6.2
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'media-sound/mp3splt/mp3splt-2.6.2.ebuild')
-rw-r--r--media-sound/mp3splt/mp3splt-2.6.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/media-sound/mp3splt/mp3splt-2.6.2.ebuild b/media-sound/mp3splt/mp3splt-2.6.2.ebuild
new file mode 100644
index 000000000000..23f9a38bec07
--- /dev/null
+++ b/media-sound/mp3splt/mp3splt-2.6.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit multilib
+
+DESCRIPTION="a command line utility to split mp3 and ogg files without decoding"
+HOMEPAGE="http://mp3splt.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="flac"
+
+RDEPEND="~media-libs/libmp3splt-0.9.2[flac?]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ sys-devel/gettext"
+
+src_configure() {
+ econf \
+ --enable-oggsplt_symlink \
+ $(use_enable flac flacsplt_symlink) \
+ --disable-dependency-tracking
+}
+
+src_install() {
+ default
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}