summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/din
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/din')
-rw-r--r--media-sound/din/Manifest1
-rw-r--r--media-sound/din/din-5.2.1.ebuild37
-rw-r--r--media-sound/din/files/din-5.2.1-desktop.patch8
-rw-r--r--media-sound/din/files/din-5.2.1-makefile.patch10
-rw-r--r--media-sound/din/files/din-5.2.1-tcl.patch11
-rw-r--r--media-sound/din/metadata.xml5
6 files changed, 72 insertions, 0 deletions
diff --git a/media-sound/din/Manifest b/media-sound/din/Manifest
new file mode 100644
index 000000000000..0f490022fb39
--- /dev/null
+++ b/media-sound/din/Manifest
@@ -0,0 +1 @@
+DIST din-5.2.1.tar.gz 321269 SHA256 ef2485963a2435256dcb099364918c2cb0560701bf4f374738f9c54a2c316447 SHA512 0fa7de383c869f9f55ee055f821f3b541ca7df83d61f9bdb6b9e0227a724abe098073985cb4f3eb381199d4baa84d9ee2b86b74614e11cb8b58b119230ca3c09 WHIRLPOOL 762fb7b5e7908da31737929d607c16a538071137fc9f50fd1be7d2c81bb190f68b82f7321b2cfa8c8e1232dddb7178ed263fd5c4ce0f90c98bbf6107e5d91466
diff --git a/media-sound/din/din-5.2.1.ebuild b/media-sound/din/din-5.2.1.ebuild
new file mode 100644
index 000000000000..9772a3d8869a
--- /dev/null
+++ b/media-sound/din/din-5.2.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils autotools
+
+DESCRIPTION="a software musical instrument and audio synthesizer"
+HOMEPAGE="http://dinisnoise.org/"
+SRC_URI="http://din.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-lang/tcl:0=
+ media-libs/liblo
+ media-sound/jack-audio-connection-kit
+ net-libs/libircclient
+ sci-libs/fftw:3.0
+ virtual/opengl
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-makefile.patch
+ epatch "${FILESDIR}"/${P}-tcl.patch
+ epatch "${FILESDIR}"/${P}-desktop.patch
+
+ # force script to be regenerated so it uses the right data path
+ rm data/checkdotdin || die
+
+ eautoreconf
+}
diff --git a/media-sound/din/files/din-5.2.1-desktop.patch b/media-sound/din/files/din-5.2.1-desktop.patch
new file mode 100644
index 000000000000..e9bd7a62bc56
--- /dev/null
+++ b/media-sound/din/files/din-5.2.1-desktop.patch
@@ -0,0 +1,8 @@
+--- din-5.2.1/data/din.desktop
++++ din-5.2.1/data/din.desktop
+@@ -8,4 +8,4 @@
+ StartupNotify=true
+ Terminal=false
+ Type=Application
+-Categories=Application;AudioVideo;Audio;Midi;Music;
++Categories=AudioVideo;Audio;Midi;Music;
diff --git a/media-sound/din/files/din-5.2.1-makefile.patch b/media-sound/din/files/din-5.2.1-makefile.patch
new file mode 100644
index 000000000000..1f79f82ce495
--- /dev/null
+++ b/media-sound/din/files/din-5.2.1-makefile.patch
@@ -0,0 +1,10 @@
+--- din-5.2.1/src/Makefile.am
++++ din-5.2.1/src/Makefile.am
+@@ -1,5 +1,5 @@
+-AM_CXXFLAGS = $(liblo_CFLAGS) $(jack_CFLAGS) $(fftw3f_CFLAGS) -I /usr/include -I /usr/local/include -I /opt/include -I/usr/include/tcl8.5 -I/usr/local/include/tcl8.5 -I /opt/include/tcl8.5 -I ../include -Wall -O3
+-LIBS += $(liblo_LIBS) $(jack_LIBS) $(fftw3f_LIBS) -L/usr/lib/tcl8.5 -L/usr/local/lib/tcl8.5 -L /opt/lib/tcl8.5 -L /usr/lib -L /opt/lib -L /usr/local/lib -ltcl8.5 -lGL -lircclient -lrt -lX11
++AM_CXXFLAGS = $(liblo_CFLAGS) $(jack_CFLAGS) $(fftw3f_CFLAGS) -I /usr/include -I ../include -Wall
++LIBS += $(liblo_LIBS) $(jack_LIBS) $(fftw3f_LIBS) -ltcl -lGL -lircclient -lrt -lX11
+
+ bin_PROGRAMS = din
+
diff --git a/media-sound/din/files/din-5.2.1-tcl.patch b/media-sound/din/files/din-5.2.1-tcl.patch
new file mode 100644
index 000000000000..a5582f1bba15
--- /dev/null
+++ b/media-sound/din/files/din-5.2.1-tcl.patch
@@ -0,0 +1,11 @@
+--- din-5.2.1/configure.ac
++++ din-5.2.1/configure.ac
+@@ -3,7 +3,7 @@
+ AC_CONFIG_SRCDIR([configure.ac])
+ AC_PROG_CXX
+ AC_CHECK_HEADERS([GL/gl.h],AC_MSG_NOTICE([+++ Found OpenGL +++]),[AC_MSG_ERROR([!!! Please install OpenGL !!!])])
+-AC_CHECK_HEADERS([tcl.h] [tcl8.5/tcl.h],AC_MSG_NOTICE([+++ Found Tcl 8.5 +++]),[AC_MSG_WARN([!!! Is Tcl 8.5 installed? !!!])])
++AC_CHECK_HEADERS([tcl.h], AC_MSG_NOTICE([+++ Found Tcl +++]),[AC_MSG_ERROR([!!! Please install Tcl !!!])])
+ AC_CHECK_HEADERS([libircclient/libircclient.h],,[AC_MSG_ERROR([!!! Please install libircclient !!!])])
+ PKG_CHECK_MODULES([liblo], [liblo])
+ PKG_CHECK_MODULES([jack], [jack])
diff --git a/media-sound/din/metadata.xml b/media-sound/din/metadata.xml
new file mode 100644
index 000000000000..0dc3775f83d7
--- /dev/null
+++ b/media-sound/din/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>proaudio</herd>
+</pkgmetadata>