summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/aumix
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/aumix')
-rw-r--r--media-sound/aumix/Manifest1
-rw-r--r--media-sound/aumix/aumix-2.9.1.ebuild47
-rw-r--r--media-sound/aumix/files/aumix.rc642
-rw-r--r--media-sound/aumix/metadata.xml5
4 files changed, 95 insertions, 0 deletions
diff --git a/media-sound/aumix/Manifest b/media-sound/aumix/Manifest
new file mode 100644
index 000000000000..fa9f0aa12c2f
--- /dev/null
+++ b/media-sound/aumix/Manifest
@@ -0,0 +1 @@
+DIST aumix-2.9.1.tar.bz2 231622 RMD160 a68d2e1da251edad721e997099d8149075f07449 SHA1 1b84054cfb74d3513b254d05c2fb08f6a6a3edc7 SHA256 d2ce43d532ef75072c8d4e7922e3bc06be6d97765a508d9ceb0d1766bbe70e29
diff --git a/media-sound/aumix/aumix-2.9.1.ebuild b/media-sound/aumix/aumix-2.9.1.ebuild
new file mode 100644
index 000000000000..92efcda416f7
--- /dev/null
+++ b/media-sound/aumix/aumix-2.9.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+inherit eutils
+
+DESCRIPTION="Aumix volume/mixer control program"
+HOMEPAGE="http://jpj.net/~trevor/aumix.html"
+SRC_URI="http://jpj.net/~trevor/aumix/releases/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sh sparc x86"
+IUSE="gpm gtk nls"
+
+RDEPEND="sys-libs/ncurses
+ gpm? ( sys-libs/gpm )
+ gtk? ( x11-libs/gtk+:2 )
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_configure() {
+ local myconf
+
+ use gtk || myconf="${myconf} --without-gtk"
+ use gpm || myconf="${myconf} --without-gpm"
+
+ econf \
+ $(use_enable nls) \
+ --disable-dependency-tracking \
+ ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS BUGS ChangeLog NEWS README TODO
+
+ newinitd "${FILESDIR}"/aumix.rc6 aumix
+
+ if use gtk; then
+ doicon data/aumix.xpm
+ make_desktop_entry aumix Aumix
+ fi
+}
diff --git a/media-sound/aumix/files/aumix.rc6 b/media-sound/aumix/files/aumix.rc6
new file mode 100644
index 000000000000..f3f3d23645be
--- /dev/null
+++ b/media-sound/aumix/files/aumix.rc6
@@ -0,0 +1,42 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ use modules hotplug coldplug alsasound
+}
+
+checkconfig() {
+ if ! grep -q -E 'sound|OSS|sparcaudio' /proc/devices && [ ! -d /proc/asound ] ; then
+ eerror "Sound support has not been compiled into the kernel,"
+ eerror "or is disabled. Please check that the correct modules"
+ eerror "is loaded."
+ return 1
+ fi
+ # /dev/mixer can be a symlink
+ if [ ! -e /dev/mixer ] ; then
+ eerror "/dev/mixer does not exist, please create it, or load the"
+ eerror "correct modules to enable your card's mixer"
+ return 1
+ fi
+}
+
+start() {
+ checkconfig || return 1
+ if [ -f /etc/aumixrc ] ; then
+ ebegin "Loading Mixer settings"
+ /usr/bin/aumix -f /etc/aumixrc -L >/dev/null 2>&1
+ else
+ ebegin "Setting Mixer settings"
+ /usr/bin/aumix -v75 -c75 -w75 >/dev/null 2>&1
+ fi
+ eend $?
+}
+
+stop() {
+ checkconfig || return 1
+ ebegin "Saving Mixer settings"
+ /usr/bin/aumix -f /etc/aumixrc -S >/dev/null 2>&1
+ eend $?
+}
diff --git a/media-sound/aumix/metadata.xml b/media-sound/aumix/metadata.xml
new file mode 100644
index 000000000000..e1774e3d9ad7
--- /dev/null
+++ b/media-sound/aumix/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sound</herd>
+</pkgmetadata>