summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2023-09-19 13:52:01 +0100
committerMarek Szuba <marecki@gentoo.org>2023-09-19 13:52:25 +0100
commita5f44bc33bbf180846ad4e8b73c0240a26af03e8 (patch)
tree4f8e1323d832cdd8cc488062a724697065580a88 /media-radio
parentnet-misc/linuxptp: drop 3.1.1-r1, add 4.1 (diff)
downloadgentoo-a5f44bc33bbf180846ad4e8b73c0240a26af03e8.tar.gz
gentoo-a5f44bc33bbf180846ad4e8b73c0240a26af03e8.tar.bz2
gentoo-a5f44bc33bbf180846ad4e8b73c0240a26af03e8.zip
media-radio/chirp: add 20230917
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'media-radio')
-rw-r--r--media-radio/chirp/Manifest1
-rw-r--r--media-radio/chirp/chirp-20230917.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/media-radio/chirp/Manifest b/media-radio/chirp/Manifest
index 6b2337d98e75..8d2980d45004 100644
--- a/media-radio/chirp/Manifest
+++ b/media-radio/chirp/Manifest
@@ -1,2 +1,3 @@
DIST chirp-20230818.tar.gz 1750957 BLAKE2B 765a3cdffc51372c7012fd59112c00dbe58374e68434ec127e3d7b6702dc80371564244972457cebc44c1e51d5d50f05f413b263a63bbc94c88c0db1f437c380 SHA512 dcc8eadc75ea1e74c32dfc9c73f1857c1745cfbf1272934425a022fa663d1471cc8e79d63da9628369b833f7fc25ce86960924545ad5bfe2fe4d34509e7308eb
DIST chirp-20230823.tar.gz 1752116 BLAKE2B 86ecef11a38f187c70257bede6557df1eb9772868fa1c64cf5c9c51dd4ff3e2dad1d575a829d251711828e4f536b8f3da25b0d8a4ca2fe38cf49a4b27c467053 SHA512 029846d4ec64894681ff6e1edda80d4b964623e88b95d59b362cc66b11f6d04cc636725c1ee2ffa6701b5537173a51b6bb2c0d4012a2d46c56b07a0c75655154
+DIST chirp-20230917.tar.gz 1754068 BLAKE2B 462f047310ac8ca15098365062109716ccd0a695ab86910f6c6bd6ef11b094b5cdb59949238e49e6baf3a08cc12e41766a9306d9fe685e35a2040eb9d7602ad5 SHA512 50ce4036d5ebeebbc2c4badb8c4f23ce13fcb66a3b016564655c25b30a032cbb8c0b62857ffbe5dac28967d2d70bb721ac45209eb6405a9c87263b225bd8d049
diff --git a/media-radio/chirp/chirp-20230917.ebuild b/media-radio/chirp/chirp-20230917.ebuild
new file mode 100644
index 000000000000..5b1a95d408b4
--- /dev/null
+++ b/media-radio/chirp/chirp-20230917.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# py3.12 blocked by wxpython
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+DESCRIPTION="A free, open-source tool for programming your radio"
+HOMEPAGE="https://chirp.danplanet.com/"
+SRC_URI="https://trac.chirp.danplanet.com/${PN}_next/next-${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+gui radioreference"
+
+RDEPEND="$(python_gen_cond_dep '
+ dev-python/pyserial[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ gui? (
+ dev-python/wxpython:4.0[${PYTHON_USEDEP}]
+ dev-python/yattag[${PYTHON_USEDEP}]
+ )
+ radioreference? ( dev-python/suds-community[${PYTHON_USEDEP}] )
+')"
+BDEPEND="test? ( $(python_gen_cond_dep '
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+') )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-20230818_no-future.patch
+)
+
+distutils_enable_tests pytest
+
+# The alias map is an internal developer file not included in release tarballs.
+# Other disabled tests require Internet access.
+EPYTEST_DESELECT=(
+ tests/unit/test_directory.py::TestAliasMap
+ tests/unit/test_network_sources.py
+ tests/unit/test_repeaterbook.py
+)
+
+python_test() {
+ # From the contents of tests/ upstream currently only runs unit and driver
+ # tests, and the latter can take so long that they have even got a special
+ # script for only running them on drivers whose code has changed
+ # with respect to origin/master.
+ epytest tests/unit/
+}
+
+src_install() {
+ distutils-r1_src_install
+ if ! use gui; then
+ rm "${ED}"/usr/bin/${PN} || die
+ fi
+}