summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-plugins/audacious-plugins/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-plugins/audacious-plugins/files')
-rw-r--r--media-plugins/audacious-plugins/files/audacious-plugins-2.x-fix-skins-build-glib-2.32.patch13
-rw-r--r--media-plugins/audacious-plugins/files/audacious-plugins-3.2.2-fix-build-gmodule.patch31
-rw-r--r--media-plugins/audacious-plugins/files/audacious-plugins-3.2.2-fix-build-sdl.patch19
-rw-r--r--media-plugins/audacious-plugins/files/audacious-plugins-3.3.3-libcdio.patch111
-rw-r--r--media-plugins/audacious-plugins/files/audacious-plugins_ldflags.patch11
5 files changed, 185 insertions, 0 deletions
diff --git a/media-plugins/audacious-plugins/files/audacious-plugins-2.x-fix-skins-build-glib-2.32.patch b/media-plugins/audacious-plugins/files/audacious-plugins-2.x-fix-skins-build-glib-2.32.patch
new file mode 100644
index 000000000000..f5fb42cf53d1
--- /dev/null
+++ b/media-plugins/audacious-plugins/files/audacious-plugins-2.x-fix-skins-build-glib-2.32.patch
@@ -0,0 +1,13 @@
+diff --git a/src/skins/ui_skinned_window.c b/src/skins/ui_skinned_window.c
+index 9b178a2..b90e943 100644
+--- a/src/skins/ui_skinned_window.c
++++ b/src/skins/ui_skinned_window.c
+@@ -20,7 +20,7 @@
+
+ #include <gtk/gtkmain.h>
+ #include <glib-object.h>
+-#include <glib/gmacros.h>
++#include <glib.h>
+ #include <gtk/gtkmarshal.h>
+ #include <gtk/gtkwindow.h>
+ #include <string.h>
diff --git a/media-plugins/audacious-plugins/files/audacious-plugins-3.2.2-fix-build-gmodule.patch b/media-plugins/audacious-plugins/files/audacious-plugins-3.2.2-fix-build-gmodule.patch
new file mode 100644
index 000000000000..2f06396e8d1a
--- /dev/null
+++ b/media-plugins/audacious-plugins/files/audacious-plugins-3.2.2-fix-build-gmodule.patch
@@ -0,0 +1,31 @@
+commit a29df1ab4ba9f3964ca475c0c727136357ddfb86
+Author: John Lindgren <john.lindgren@aol.com>
+Date: Mon Apr 2 02:10:32 2012 -0400
+
+ Make check for GMODULE_{CFLAGS,LIBS} unconditional; LADSPA plugin needs it also.
+
+diff --git a/acinclude.m4 b/acinclude.m4
+index 6f6f293..5acb6b7 100644
+--- a/acinclude.m4
++++ b/acinclude.m4
+@@ -194,6 +194,7 @@ AC_PATH_PROG([WINDRES], [windres])
+ dnl Check for Gtk+/GLib and pals
+ dnl ============================
+ AUD_CHECK_MODULE([GLIB], [glib-2.0], [>= 2.16], [Glib2])
++AUD_CHECK_MODULE([GMODULE], [gmodule-2.0], [>= 2.16], [GModule])
+ AUD_CHECK_MODULE([GTHREAD], [gthread-2.0], [>= 2.16], [GThread])
+ AUD_CHECK_MODULE([PANGO], [pango], [>= 1.20], [Pango])
+ AUD_CHECK_MODULE([CAIRO], [cairo], [>= 1.6], [Cairo])
+diff --git a/configure.ac b/configure.ac
+index d976576..358f841 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -757,8 +757,6 @@ fi
+
+ if test "x$enable_amidiplug" = "xyes"; then
+ INPUT_PLUGINS="$INPUT_PLUGINS amidi-plug"
+- PKG_CHECK_MODULES(GLIB, [glib-2.0 >= 2.6.0],,)
+- PKG_CHECK_MODULES(GMODULE, [gmodule-2.0 >= 2.6.0],,)
+ AMIDIPLUG_BACKEND_DIR=amidi-plug
+ AC_SUBST(AMIDIPLUG_BACKEND_DIR)
+ if test "x$enable_amidiplug_alsa" = "xauto" -o "x$enable_amidiplug_alsa" = "xyes"; then
diff --git a/media-plugins/audacious-plugins/files/audacious-plugins-3.2.2-fix-build-sdl.patch b/media-plugins/audacious-plugins/files/audacious-plugins-3.2.2-fix-build-sdl.patch
new file mode 100644
index 000000000000..8f6fda0ba1b2
--- /dev/null
+++ b/media-plugins/audacious-plugins/files/audacious-plugins-3.2.2-fix-build-sdl.patch
@@ -0,0 +1,19 @@
+commit b6df18997dabe37f4357d977d2dfae07899be5e7
+Author: Michał Lipski <tallica@o2.pl>
+Date: Mon May 7 12:48:23 2012 +0200
+
+ Use pkg-config for libsdl detection. (Gentoo #414999)
+
+diff --git a/configure.ac b/configure.ac
+index 358f841..cbba0ce 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -693,7 +693,7 @@ AC_ARG_ENABLE(sdlout,
+ [enable_sdlout=$enableval], [enable_sdlout=yes])
+
+ if test $enable_sdlout = yes ; then
+- AM_PATH_SDL(1.2.5, [enable_sdlout=yes], [enable_sdlout=no])
++ PKG_CHECK_MODULES([SDL], [sdl >= 1.2.11], [enable_sdlout=yes], [enable_sdlout=no])
+ fi
+
+ if test $enable_sdlout = yes ; then
diff --git a/media-plugins/audacious-plugins/files/audacious-plugins-3.3.3-libcdio.patch b/media-plugins/audacious-plugins/files/audacious-plugins-3.3.3-libcdio.patch
new file mode 100644
index 000000000000..e0943e6471f3
--- /dev/null
+++ b/media-plugins/audacious-plugins/files/audacious-plugins-3.3.3-libcdio.patch
@@ -0,0 +1,111 @@
+diff --git a/src/cdaudio-ng/cdaudio-ng.c b/src/cdaudio-ng/cdaudio-ng.c
+index 925b847..e986839 100644
+--- a/src/cdaudio-ng/cdaudio-ng.c
++++ b/src/cdaudio-ng/cdaudio-ng.c
+@@ -26,11 +26,16 @@
+ #include <cdio/cdio.h>
+ #include <cdio/cdtext.h>
+ #include <cdio/track.h>
+-#include <cdio/cdda.h>
+ #include <cdio/audio.h>
+ #include <cdio/sector.h>
+ #include <cdio/cd_types.h>
+
++#if LIBCDIO_VERSION_NUM >= 90
++#include <cdio/paranoia/cdda.h>
++#else
++#include <cdio/cdda.h>
++#endif
++
+ /* libcdio's header files #define these */
+ #undef PACKAGE
+ #undef PACKAGE_BUGREPORT
+@@ -269,9 +274,9 @@ static void cdaudio_set_strinfo (trackinfo_t * t,
+ const char * performer, const char * name,
+ const char * genre)
+ {
+- g_strlcpy (t->performer, performer, DEF_STRING_LEN);
+- g_strlcpy (t->name, name, DEF_STRING_LEN);
+- g_strlcpy (t->genre, genre, DEF_STRING_LEN);
++ g_strlcpy (t->performer, performer ? performer : "", DEF_STRING_LEN);
++ g_strlcpy (t->name, name ? name : "", DEF_STRING_LEN);
++ g_strlcpy (t->genre, genre ? genre : "", DEF_STRING_LEN);
+ }
+
+ /* thread safe (mutex may be locked) */
+@@ -622,23 +627,32 @@ static void scan_cd (void)
+ }
+
+ /* get trackinfo[0] cdtext information (the disc) */
++ cdtext_t *pcdtext = NULL;
+ if (aud_get_bool ("CDDA", "use_cdtext"))
+ {
+ AUDDBG ("getting cd-text information for disc\n");
+- cdtext_t *pcdtext = cdio_get_cdtext (pcdrom_drive->p_cdio, 0);
++#if LIBCDIO_VERSION_NUM >= 90
++ pcdtext = cdio_get_cdtext (pcdrom_drive->p_cdio);
++ if (pcdtext == NULL)
++#else
++ pcdtext = cdio_get_cdtext (pcdrom_drive->p_cdio, 0);
+ if (pcdtext == NULL || pcdtext->field[CDTEXT_TITLE] == NULL)
++#endif
+ {
+ AUDDBG ("no cd-text available for disc\n");
+ }
+ else
+ {
+ cdaudio_set_strinfo (&trackinfo[0],
+- pcdtext->field[CDTEXT_PERFORMER] ? pcdtext->
+- field[CDTEXT_PERFORMER] : "",
+- pcdtext->field[CDTEXT_TITLE] ? pcdtext->
+- field[CDTEXT_TITLE] : "",
+- pcdtext->field[CDTEXT_GENRE] ? pcdtext->
+- field[CDTEXT_GENRE] : "");
++#if LIBCDIO_VERSION_NUM >= 90
++ cdtext_get(pcdtext, CDTEXT_FIELD_PERFORMER, 0),
++ cdtext_get(pcdtext, CDTEXT_FIELD_TITLE, 0),
++ cdtext_get(pcdtext, CDTEXT_FIELD_GENRE, 0));
++#else
++ pcdtext->field[CDTEXT_PERFORMER],
++ pcdtext->field[CDTEXT_TITLE],
++ pcdtext->field[CDTEXT_GENRE]);
++#endif
+ }
+ }
+
+@@ -646,7 +660,7 @@ static void scan_cd (void)
+ bool_t cdtext_was_available = FALSE;
+ for (trackno = firsttrackno; trackno <= lasttrackno; trackno++)
+ {
+- cdtext_t *pcdtext = NULL;
++#if LIBCDIO_VERSION_NUM < 90
+ if (aud_get_bool ("CDDA", "use_cdtext"))
+ {
+ AUDDBG ("getting cd-text information for track %d\n", trackno);
+@@ -657,16 +671,20 @@ static void scan_cd (void)
+ pcdtext = NULL;
+ }
+ }
++#endif
+
+ if (pcdtext != NULL)
+ {
+ cdaudio_set_strinfo (&trackinfo[trackno],
+- pcdtext->field[CDTEXT_PERFORMER] ? pcdtext->
+- field[CDTEXT_PERFORMER] : "",
+- pcdtext->field[CDTEXT_TITLE] ? pcdtext->
+- field[CDTEXT_TITLE] : "",
+- pcdtext->field[CDTEXT_GENRE] ? pcdtext->
+- field[CDTEXT_GENRE] : "");
++#if LIBCDIO_VERSION_NUM >= 90
++ cdtext_get(pcdtext, CDTEXT_FIELD_PERFORMER, trackno),
++ cdtext_get(pcdtext, CDTEXT_FIELD_TITLE, trackno),
++ cdtext_get(pcdtext, CDTEXT_FIELD_GENRE, trackno));
++#else
++ pcdtext->field[CDTEXT_PERFORMER],
++ pcdtext->field[CDTEXT_TITLE],
++ pcdtext->field[CDTEXT_GENRE]);
++#endif
+ cdtext_was_available = TRUE;
+ }
+ else
diff --git a/media-plugins/audacious-plugins/files/audacious-plugins_ldflags.patch b/media-plugins/audacious-plugins/files/audacious-plugins_ldflags.patch
new file mode 100644
index 000000000000..359964ecd943
--- /dev/null
+++ b/media-plugins/audacious-plugins/files/audacious-plugins_ldflags.patch
@@ -0,0 +1,11 @@
+--- configure.old 2012-01-17 13:00:17.000000000 +0000
++++ configure 2012-01-17 13:00:33.000000000 +0000
+@@ -5223,7 +5223,7 @@
+ *linux*)
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
+ $as_echo "yes" >&6; }
+- LDFLAGS="$LDFLAGS -z defs"
++ LDFLAGS="$LDFLAGS -Wl,-z,defs"
+ ;;
+ *)
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5