summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Zander <negril.nx+gentoo@gmail.com>2025-01-06 01:53:03 +0100
committerSam James <sam@gentoo.org>2025-01-06 00:59:02 +0000
commitcbe5bdc64cab3d5958fb16256fb73004bf6cbdbc (patch)
tree461f7cd5ee5b97802c0fe1b2e3c1a437e776ce63 /media-libs
parentmedia-gfx/netgen: #947567 (diff)
downloadgentoo-cbe5bdc64cab3d5958fb16256fb73004bf6cbdbc.tar.gz
gentoo-cbe5bdc64cab3d5958fb16256fb73004bf6cbdbc.tar.bz2
gentoo-cbe5bdc64cab3d5958fb16256fb73004bf6cbdbc.zip
media-libs/lib3mf: #947568
Closes: https://bugs.gentoo.org/947568 Signed-off-by: Paul Zander <negril.nx+gentoo@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/lib3mf/files/lib3mf-2.3.2-Gentoo-specific-remove-add_dependencies.patch29
-rw-r--r--media-libs/lib3mf/files/lib3mf-2.3.2-include-cstdint.patch13
-rw-r--r--media-libs/lib3mf/files/lib3mf-2.3.2-remove-std-and-opt-flags.patch30
-rw-r--r--media-libs/lib3mf/lib3mf-2.3.2.ebuild17
4 files changed, 78 insertions, 11 deletions
diff --git a/media-libs/lib3mf/files/lib3mf-2.3.2-Gentoo-specific-remove-add_dependencies.patch b/media-libs/lib3mf/files/lib3mf-2.3.2-Gentoo-specific-remove-add_dependencies.patch
new file mode 100644
index 000000000000..c922fd577644
--- /dev/null
+++ b/media-libs/lib3mf/files/lib3mf-2.3.2-Gentoo-specific-remove-add_dependencies.patch
@@ -0,0 +1,29 @@
+From 03bebf3282b317c68c2b8991021d02c1572f97b2 Mon Sep 17 00:00:00 2001
+From: Paul Zander <negril.nx+gentoo@gmail.com>
+Date: Mon, 6 Jan 2025 01:00:13 +0100
+Subject: [PATCH] [PATCH] [Gentoo specific] remove add_dependencies
+
+Remove the add_dependencies commands on ssl and crypto.
+We use global openssl support instead of package libressl.
+
+Signed-off-by: Paul Zander <negril.nx+gentoo@gmail.com>
+---
+ Tests/CPP_Bindings/CMakeLists.txt | 2 --
+ 1 file changed, 2 deletions(-)
+
+diff --git a/Tests/CPP_Bindings/CMakeLists.txt b/Tests/CPP_Bindings/CMakeLists.txt
+index 89aa33a..5f27d03 100644
+--- a/Tests/CPP_Bindings/CMakeLists.txt
++++ b/Tests/CPP_Bindings/CMakeLists.txt
+@@ -58,7 +58,7 @@ find_package(Threads REQUIRED)
+ target_link_libraries(${TESTNAME} PRIVATE Threads::Threads)
+ endif()
+
+-target_link_libraries(${TESTNAME} PRIVATE ${PROJECT_NAME} ssl crypto)
++target_link_libraries(${TESTNAME} PRIVATE ${PROJECT_NAME} ssl crypto)
+
+ if (WIN32)
+ target_link_libraries(${TESTNAME} PRIVATE ws2_32)
+--
+2.47.1
+
diff --git a/media-libs/lib3mf/files/lib3mf-2.3.2-include-cstdint.patch b/media-libs/lib3mf/files/lib3mf-2.3.2-include-cstdint.patch
new file mode 100644
index 000000000000..13df032b71fc
--- /dev/null
+++ b/media-libs/lib3mf/files/lib3mf-2.3.2-include-cstdint.patch
@@ -0,0 +1,13 @@
+--- a/Source/Common/Platform/NMR_EncryptionHeader.cpp
++++ b/Source/Common/Platform/NMR_EncryptionHeader.cpp
+@@ -8,6 +8,7 @@
+ #include "Common/Platform/NMR_ExportStream.h"
+
+ #include "Common/NMR_Architecture_Utils.h"
++#include <cstdint>
+ #include <cstring>
+
+ #define LIB3MF_MAXENCRYPTIONHEADERSIZE (1UL << 31)
+--
+2.47.1
+
diff --git a/media-libs/lib3mf/files/lib3mf-2.3.2-remove-std-and-opt-flags.patch b/media-libs/lib3mf/files/lib3mf-2.3.2-remove-std-and-opt-flags.patch
new file mode 100644
index 000000000000..0230335b87ec
--- /dev/null
+++ b/media-libs/lib3mf/files/lib3mf-2.3.2-remove-std-and-opt-flags.patch
@@ -0,0 +1,30 @@
+From 057ae273bf223573b7cdb6ec978e051220ffe401 Mon Sep 17 00:00:00 2001
+From: Peter Levine <plevine457@gmail.com>
+Date: Sat, 18 Feb 2023 13:21:29 -0500
+Subject: [PATCH] [Gentoo specific] remove optimization flags and C++ standard
+ flags
+
+Remove the lines in CMakeLists.txt that emit -std=c++11 (as wall as
+emitting -O2) to enable the compiler default, which builds against
+the latest GTest with both clang-16.0.0_pre20230107 and
+gcc-12.2.1_p20230121-r1.
+
+Signed-off-by: Peter Levine <plevine457@gmail.com>
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -32,12 +32,10 @@ if ("${CMAKE_CXX_COMPILER_ID}" STREQUAL "GNU")
+ # using GCC
+ add_definitions(-DBUILD_DLL)
+ add_compile_options(-Wall)
+- SET(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++14 -O2")
+ elseif ("${CMAKE_SYSTEM_NAME}" MATCHES "Darwin")
+ # using GCC
+ add_definitions(-DBUILD_DLL)
+ add_compile_options(-Wall)
+- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++14 -O2")
+ set(CMAKE_MACOSX_RPATH ON)
+ endif()
+
+--
+2.39.1
+
diff --git a/media-libs/lib3mf/lib3mf-2.3.2.ebuild b/media-libs/lib3mf/lib3mf-2.3.2.ebuild
index 2bd7621d2d20..c13736d8833e 100644
--- a/media-libs/lib3mf/lib3mf-2.3.2.ebuild
+++ b/media-libs/lib3mf/lib3mf-2.3.2.ebuild
@@ -23,7 +23,6 @@ RDEPEND="
DEPEND="${RDEPEND}"
BDEPEND="
virtual/pkgconfig
- system-act? ( dev-go/act )
test? (
dev-cpp/gtest
dev-libs/openssl
@@ -32,19 +31,16 @@ BDEPEND="
"
PATCHES=(
- "${FILESDIR}"/${PN}-2.1.0-0001-Gentoo-specific-avoid-pre-stripping-library.patch
- "${FILESDIR}"/${P}-0001-use-system-provided-act-binary.patch
- "${FILESDIR}"/${P}-0002-Gentoo-specific-remove-add_dependencies.patch
- "${FILESDIR}"/${P}-0001-remove-std-and-opt-flags.patch
- "${FILESDIR}"/${P}-include-cstdint.patch
+ "${FILESDIR}"/${PN}-2.3.2-remove-std-and-opt-flags.patch
+ "${FILESDIR}"/${PN}-2.2.0-include-cstdint.patch
+ "${FILESDIR}"/${PN}-2.3.2-include-cstdint.patch
)
src_prepare() {
cmake_src_prepare
- rm -r Include/Libraries/{libzip,zlib} || die
- ln -s "${EPREFIX}/usr/include" Include/Libraries/zlib || die
- ln -s "${EPREFIX}/usr/include" Include/Libraries/libzip || die
+ # DO NOT WANT!
+ rm -r Libraries/libressl || die
}
src_configure() {
@@ -53,12 +49,11 @@ src_configure() {
-DLIB3MF_TESTS=$(usex test)
-DUSE_INCLUDED_LIBZIP=OFF
-DUSE_INCLUDED_ZLIB=OFF
- -DUSE_SYSTEM_ACT=$(usex system-act)
+ -DSTRIP_BINARIES=OFF
)
if use test; then
mycmakeargs+=(
- -DUSE_INCLUDED_GTEST=OFF
# code says it uses libressl, but works with openssl too
-DUSE_INCLUDED_SSL=OFF
)