summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-09-24 22:33:53 +0100
committerSam James <sam@gentoo.org>2023-09-24 22:59:31 +0100
commit9259d5a1c2c839e0e9db10dd50e11d6cfd13c57b (patch)
tree6fd2f00ca33c037938531c500dda68b57f08742e /media-libs
parentkde-plasma/discover: Fix "too many open files" w/ flatpak backend (diff)
downloadgentoo-9259d5a1c2c839e0e9db10dd50e11d6cfd13c57b.tar.gz
gentoo-9259d5a1c2c839e0e9db10dd50e11d6cfd13c57b.tar.bz2
gentoo-9259d5a1c2c839e0e9db10dd50e11d6cfd13c57b.zip
media-libs/libaom: add 3.7.0
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libaom/Manifest2
-rw-r--r--media-libs/libaom/libaom-3.7.0.ebuild126
-rw-r--r--media-libs/libaom/libaom-9999.ebuild6
3 files changed, 131 insertions, 3 deletions
diff --git a/media-libs/libaom/Manifest b/media-libs/libaom/Manifest
index c0ac00f3a50f..6a902c906b99 100644
--- a/media-libs/libaom/Manifest
+++ b/media-libs/libaom/Manifest
@@ -4,3 +4,5 @@ DIST libaom-3.6.0-testdata.tar.gz 498554450 BLAKE2B bbc84e9d3fd91272fa6e30a19f62
DIST libaom-3.6.0.tar.gz 5258526 BLAKE2B bf97c74f3e59e3cc2431e7b7e3494beffde1b659d1a8f8775b4b47da0c7314b8bf5b9bdf14a9d1d47a8378271f49c9e26676e73509f9e910f1d5a01e79b575bc SHA512 28df178f43f26a064474f7d9c79882b4c04b66fed16f904ac9b37386912660e2af88c90672ec04eed99aef104156cf1e72040fa975895522dca7b88760b138bc
DIST libaom-3.6.1-testdata.tar.xz 374912432 BLAKE2B 81fb51eed6576a4ef5d5aaa93e9adda344e547404f6532d31f4ef6489a88cf6cce99b1ac0ad67ef9592cad80f13b015d4960c45e29ff2b0746a8de1583a5be90 SHA512 de0b1394080389d892d1493ca48b351bbc409baa81ab6937292df09e52947a65266f08557a1d3c2cb636a8d4b9f3ae0730a7a824c907abb3557e22cc0fc3034b
DIST libaom-3.6.1.tar.gz 5260460 BLAKE2B c47b748e3dc43e39ecb55c4d61ea3d2d4a889bb8c6c399e29e14269757d271cd759a553f5da765bcdf7cd19546b408fce060d5ed3fb13e3aba4f8d22d612bf29 SHA512 25afbc7911570973fa33410e9298eb31501b6f979fd4c60326081c9451c2cac8d692592d6fff19aac485da37da9c14e12ab4f95992e129ba7814b278b515d9bb
+DIST libaom-3.7.0-testdata.tar.xz 374076136 BLAKE2B 17036f37fbb04d59b50e13e5e2258215e99cab4b6f64ac558213009477bc22f43267b60bcbb30ec10325de2aed48b22237b12cd6220f4330e300b62bafedac0b SHA512 c08ef4c9c45f1a27e6c31b8cc9799d8e65d895663a79d7be51da1733be6d8013adaad3a8f1d7491f555a2eea58aead44b9ce935c3e9bb957cb8bbb93f6f4fd98
+DIST libaom-3.7.0.tar.gz 5347924 BLAKE2B 2693d60f5afa810e00ab6aadcf8ca763e328bc64e47b3678eeba9993db89b25cfa0380beeff5a5938f19da74410ce83068c318cff2aea30e5fe39680ac67e937 SHA512 b763a877db26dcaddea5513825900917e55bc131bf78a83f941f1e74b534a514cb599fb64c3ac18a8202ac0a72c511dfef6eeff21dfbe59ed9816887ca3ec5f3
diff --git a/media-libs/libaom/libaom-3.7.0.ebuild b/media-libs/libaom/libaom-3.7.0.ebuild
new file mode 100644
index 000000000000..76a2b4d37365
--- /dev/null
+++ b/media-libs/libaom/libaom-3.7.0.ebuild
@@ -0,0 +1,126 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+inherit cmake-multilib python-any-r1
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://aomedia.googlesource.com/aom"
+else
+ # To update test data tarball, follow these steps:
+ # 1. Clone the upstream repo and check out the relevant tag,
+ # or download the release tarball
+ # 2. Regular cmake configure (options don't matter here):
+ # cd build && cmake ..
+ # 3. Set LIBAOM_TEST_DATA_PATH to the directory you want and
+ # run the "make testdata" target:
+ # LIBAOM_TEST_DATA_PATH=../libaom-3.7.0-testdata make testdata
+ # This will download the test data from the internet.
+ # 4. Create a tarball out of that directory.
+ # cd .. && tar cvaf libaom-3.7.0-testdata.tar.xz libaom-3.7.0-testdata
+ SRC_URI="
+ https://storage.googleapis.com/aom-releases/${P}.tar.gz
+ test? ( https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}-testdata.tar.xz )
+ "
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+fi
+
+DESCRIPTION="Alliance for Open Media AV1 Codec SDK"
+HOMEPAGE="https://aomedia.org https://aomedia.googlesource.com/aom/"
+
+LICENSE="BSD-2"
+SLOT="0/3"
+IUSE="doc +examples test"
+IUSE="${IUSE} cpu_flags_x86_mmx cpu_flags_x86_sse cpu_flags_x86_sse2 cpu_flags_x86_sse3 cpu_flags_x86_ssse3"
+IUSE="${IUSE} cpu_flags_x86_sse4_1 cpu_flags_x86_sse4_2 cpu_flags_x86_avx cpu_flags_x86_avx2"
+IUSE="${IUSE} cpu_flags_arm_neon"
+RESTRICT="!test? ( test )"
+
+REQUIRED_USE="
+ cpu_flags_x86_sse2? ( cpu_flags_x86_mmx )
+ cpu_flags_x86_ssse3? ( cpu_flags_x86_sse2 )
+"
+
+BDEPEND="${PYTHON_DEPS}
+ dev-lang/perl
+ abi_x86_32? ( dev-lang/yasm )
+ abi_x86_64? ( dev-lang/yasm )
+ abi_x86_x32? ( dev-lang/yasm )
+ doc? ( app-doc/doxygen )
+"
+
+# The PATENTS file is required to be distributed with this package, bug #682214
+DOCS=( PATENTS )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.4.0-posix-c-source-ftello.patch
+)
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DENABLE_CCACHE=OFF
+ -DENABLE_DOCS=$(multilib_native_usex doc ON OFF)
+ -DENABLE_EXAMPLES=$(multilib_native_usex examples ON OFF)
+ -DENABLE_NASM=OFF
+ -DENABLE_TESTS=$(usex test)
+ -DENABLE_TOOLS=ON
+ -DENABLE_WERROR=OFF
+
+ # Needs libjxl, currently unpackaged.
+ -DCONFIG_TUNE_BUTTERAUGLI=0
+
+ # neon support is assumed to be always enabled on arm64
+ -DENABLE_NEON=$(usex cpu_flags_arm_neon ON $(usex arm64 ON OFF))
+ # ENABLE_DSPR2 / ENABLE_MSA for mips
+ -DENABLE_MMX=$(usex cpu_flags_x86_mmx ON OFF)
+ -DENABLE_SSE=$(usex cpu_flags_x86_sse ON OFF)
+ -DENABLE_SSE2=$(usex cpu_flags_x86_sse2 ON OFF)
+ -DENABLE_SSE3=$(usex cpu_flags_x86_sse3 ON OFF)
+ -DENABLE_SSSE3=$(usex cpu_flags_x86_ssse3 ON OFF)
+ -DENABLE_SSE4_1=$(usex cpu_flags_x86_sse4_1 ON OFF)
+ -DENABLE_SSE4_2=$(usex cpu_flags_x86_sse4_2 ON OFF)
+ -DENABLE_AVX=$(usex cpu_flags_x86_avx ON OFF)
+ -DENABLE_AVX2=$(usex cpu_flags_x86_avx2 ON OFF)
+ )
+
+ # For 32-bit multilib builds, force some intrinsics on to work around
+ # bug #816027. libaom seems to do runtime detection for some targets
+ # at least, so this isn't an issue.
+ if ! multilib_is_native_abi && use amd64 ; then
+ mycmakeargs+=(
+ -DENABLE_SSE3=ON
+ -DENABLE_SSSE3=ON
+ )
+ fi
+
+ # On ARM32-on-ARM64, things end up failing if NEON is off, bug #835456
+ # Just force generic, given it's a niche situation.
+ # TODO: could try forcing armv7 or similar?
+ if use arm && ! use cpu_flags_arm_neon && [[ $(uname -p) == "aarch64" ]] ; then
+ ewarn "Forcing generic for arm32-on-arm64 build (bug #835456)"
+ mycmakeargs+=(
+ -DAOM_TARGET_CPU=generic
+ )
+ fi
+
+ cmake_src_configure
+}
+
+multilib_src_test() {
+ LIBAOM_TEST_DATA_PATH="${WORKDIR}/${P}-testdata" "${BUILD_DIR}"/test_libaom || die
+}
+
+multilib_src_install() {
+ if multilib_is_native_abi && use doc ; then
+ local HTML_DOCS=( "${BUILD_DIR}"/docs/html/. )
+ fi
+
+ cmake_src_install
+}
+
+multilib_src_install_all() {
+ find "${ED}" -type f \( -name "*.a" -o -name "*.la" \) -delete || die
+}
diff --git a/media-libs/libaom/libaom-9999.ebuild b/media-libs/libaom/libaom-9999.ebuild
index 47299c68b404..76a2b4d37365 100644
--- a/media-libs/libaom/libaom-9999.ebuild
+++ b/media-libs/libaom/libaom-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..11} )
inherit cmake-multilib python-any-r1
if [[ ${PV} == *9999* ]]; then
@@ -17,10 +17,10 @@ else
# cd build && cmake ..
# 3. Set LIBAOM_TEST_DATA_PATH to the directory you want and
# run the "make testdata" target:
- # LIBAOM_TEST_DATA_PATH=../libaom-1.2.3-testdata make testdata
+ # LIBAOM_TEST_DATA_PATH=../libaom-3.7.0-testdata make testdata
# This will download the test data from the internet.
# 4. Create a tarball out of that directory.
- # cd .. && tar cvaf libaom-1.2.3-testdata.tar.xz libaom-1.2.3-testdata
+ # cd .. && tar cvaf libaom-3.7.0-testdata.tar.xz libaom-3.7.0-testdata
SRC_URI="
https://storage.googleapis.com/aom-releases/${P}.tar.gz
test? ( https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}-testdata.tar.xz )