summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2025-01-07 02:10:11 +0000
committerSam James <sam@gentoo.org>2025-01-07 02:22:01 +0000
commit32e471dd80d07979fa6bc20b9cfdf0ce64b813f2 (patch)
tree406f902b5c279702b0fc5d0c0357229e6c2ed807 /media-libs
parentmedia-libs/gstreamer: add 1.24.11 (diff)
downloadgentoo-32e471dd80d07979fa6bc20b9cfdf0ce64b813f2.tar.gz
gentoo-32e471dd80d07979fa6bc20b9cfdf0ce64b813f2.tar.bz2
gentoo-32e471dd80d07979fa6bc20b9cfdf0ce64b813f2.zip
media-libs/gst-plugins-bad: add 1.24.11
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/gst-plugins-bad/Manifest1
-rw-r--r--media-libs/gst-plugins-bad/gst-plugins-bad-1.24.11.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/media-libs/gst-plugins-bad/Manifest b/media-libs/gst-plugins-bad/Manifest
index 06ebf87982b5..df086fb7aacd 100644
--- a/media-libs/gst-plugins-bad/Manifest
+++ b/media-libs/gst-plugins-bad/Manifest
@@ -1,3 +1,4 @@
DIST gst-plugins-bad-1.22.11.tar.xz 5552716 BLAKE2B 2b1106f22114c6133d27c4cf8ea00af7efb60a21239b9a7655e35550ffa8401e5c04f9b4894d3ad74126ca67c3eb840b2257c86ad4f78ada208606f679e70fb4 SHA512 cf1901b4d4459be253d00bb65fdf6c86920ad4f034d91bd278509dfcb4e1729fdbedc127aebcd4470cc24c841d94e4199ef60747576b881ded6afc6d41985c70
DIST gst-plugins-bad-1.22.12.tar.xz 5555004 BLAKE2B d15aa65ffef15e691f84882ee76ce9d3f6e2ec31a95f1c18f56ebcda93043faa11fcd0f0d4d5783fc5aaeac020fe139449651c2008b9ff56a6853d9c55bfd2f7 SHA512 3de9decfce7f16308b077ef687cebc665f9cad7ed327fc0cc816e93c0c842dfbabf673e42cf8915c83d2f80d8ba9496508bc3b94dd587c4ae39798f67682f0bb
DIST gst-plugins-bad-1.24.10.tar.xz 7078644 BLAKE2B 928a79f10e93cad4bddfa1a8ce31ea2ea61e7e0424ed83789ed08c52d44665ce9da44a8b79c5f1b29cb69371ad220daafc741cf1c3bb3eababe0636dbd1b994d SHA512 b4f0ca2899052ba48aca2b4364479cfe580f6150e2b2b043e2a0e687409f5529f548fa06dedd73733d857c1243871426668664228d74bbdfcbd7ed35aea24189
+DIST gst-plugins-bad-1.24.11.tar.xz 7081520 BLAKE2B 5f1114eb20ff7426cd1edc568b535fcf93c5c819a04cc9d86e729ae0b5bd5984d79cd8cbf674fa0ed01c07d1faf3551b8415745b681b4941ad848869db256974 SHA512 12925f006a4a4b848fc4daf772688c8c1c0efe14aceb823954b4c05fcc2305bde1e8d9b7183a833299162de1e6ab5667d9865dee54851cc02d17cb61e72ae066
diff --git a/media-libs/gst-plugins-bad/gst-plugins-bad-1.24.11.ebuild b/media-libs/gst-plugins-bad/gst-plugins-bad-1.24.11.ebuild
new file mode 100644
index 000000000000..36a30b5c51c4
--- /dev/null
+++ b/media-libs/gst-plugins-bad/gst-plugins-bad-1.24.11.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+GST_ORG_MODULE="gst-plugins-bad"
+inherit gstreamer-meson
+
+DESCRIPTION="Less plugins for GStreamer"
+HOMEPAGE="https://gstreamer.freedesktop.org/"
+
+LICENSE="LGPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+IUSE="X bzip2 +introspection +orc udev vaapi vnc wayland"
+
+# X11 is automagic for now, upstream #709530 - only used by librfb USE=vnc plugin
+# Baseline requirement for libva is 1.6, but 1.15 gets more features
+RDEPEND="
+ !media-plugins/gst-plugins-va
+ !media-plugins/gst-transcoder
+
+ >=media-libs/gstreamer-${PV}:${SLOT}[${MULTILIB_USEDEP},introspection?]
+ >=media-libs/gst-plugins-base-${PV}:${SLOT}[${MULTILIB_USEDEP},introspection?]
+ introspection? ( >=dev-libs/gobject-introspection-1.31.1:= )
+
+ bzip2? ( >=app-arch/bzip2-1.0.6-r4[${MULTILIB_USEDEP}] )
+ vnc? ( X? ( x11-libs/libX11[${MULTILIB_USEDEP}] ) )
+ wayland? (
+ >=dev-libs/wayland-1.4.0[${MULTILIB_USEDEP}]
+ >=x11-libs/libdrm-2.4.98[${MULTILIB_USEDEP}]
+ >=dev-libs/wayland-protocols-1.26
+ )
+
+ orc? ( >=dev-lang/orc-0.4.33[${MULTILIB_USEDEP}] )
+
+ vaapi? (
+ >=media-libs/libva-1.15:=[${MULTILIB_USEDEP}]
+ udev? ( dev-libs/libgudev[${MULTILIB_USEDEP}] )
+ )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-util/glib-utils"
+
+DOCS=( AUTHORS ChangeLog NEWS README.md RELEASE )
+
+PATCHES=(
+ "${FILESDIR}"/0001-analyticsoverlay-move-option-to-right-section.patch
+ "${FILESDIR}"/0002-codec2json-move-option-to-right-section.patch
+)
+
+src_prepare() {
+ default
+ addpredict /dev # Prevent sandbox violations bug #570624
+}
+
+multilib_src_configure() {
+ GST_PLUGINS_NOAUTO="bz2 hls ipcpipeline librfb shm va wayland"
+
+ local emesonargs=(
+ -Dshm=enabled
+ -Dipcpipeline=enabled
+ -Dhls=disabled
+ $(meson_feature bzip2 bz2)
+ $(meson_feature vaapi va)
+ -Dudev=$(usex udev $(usex vaapi enabled disabled) disabled)
+ $(meson_feature vnc librfb)
+ -Dx11=$(usex X $(usex vnc enabled disabled) disabled)
+ $(meson_feature wayland)
+ )
+
+ gstreamer_multilib_src_configure
+}
+
+multilib_src_test() {
+ # Tests are slower than upstream expects
+ CK_DEFAULT_TIMEOUT=300 gstreamer_multilib_src_test
+}