summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNowa Ammerlaan <nowa@gentoo.org>2024-12-26 13:10:28 +0100
committerNowa Ammerlaan <nowa@gentoo.org>2024-12-26 13:10:28 +0100
commitd531ee0304166ac197cc0f8c1c4d3eafadb42349 (patch)
treec0fabb40d513d24424f712c33ba2fbf0c3db2111 /media-libs/vpl-gpu-rt
parentapp-text/zotero-bin: drop 7.0.5, 7.0.7 (diff)
downloadgentoo-d531ee0304166ac197cc0f8c1c4d3eafadb42349.tar.gz
gentoo-d531ee0304166ac197cc0f8c1c4d3eafadb42349.tar.bz2
gentoo-d531ee0304166ac197cc0f8c1c4d3eafadb42349.zip
media-libs/vpl-gpu-rt: add 24.4.4
Signed-off-by: Nowa Ammerlaan <nowa@gentoo.org>
Diffstat (limited to 'media-libs/vpl-gpu-rt')
-rw-r--r--media-libs/vpl-gpu-rt/Manifest1
-rw-r--r--media-libs/vpl-gpu-rt/vpl-gpu-rt-24.4.4.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/media-libs/vpl-gpu-rt/Manifest b/media-libs/vpl-gpu-rt/Manifest
index 435902cce164..27e13a723167 100644
--- a/media-libs/vpl-gpu-rt/Manifest
+++ b/media-libs/vpl-gpu-rt/Manifest
@@ -1,3 +1,4 @@
DIST vpl-gpu-rt-24.2.5.tar.gz 9063523 BLAKE2B 1d993c5f8fc460323b3630af4068e49c8222c685288f32a3500d9bc646ef99ef1273854422d34831739bbe13750993a9f23b1a8e4ed827b28e0712422b06786f SHA512 a7aa37d27e4f2429634382d55074a014d96fa15ff2c5c40539f753888152f42dd46c9e5b0899021099091167f7a611016e79792ed8808935276adf34199113bf
DIST vpl-gpu-rt-24.3.4.tar.gz 9193620 BLAKE2B 9a1804bdf4ce8624bf57d38a7f0f349770ac743b50dc513fa2569bf233aabf3972d8bbd0081e00dbf2dc6e5127cdc4372b68b3b65c9b44f0dce67b4f29f1991e SHA512 586094dc531ff4ca952f6682a7a6148d77bca0beaaff7a8411d942ca23bd1c4e70969d4354b3afe65af92fdb42816cd93fe757c4dc21b52bafde14346ac6296a
DIST vpl-gpu-rt-24.4.2.tar.gz 9181545 BLAKE2B fb71d94710b4414a6f7c5eac9e194fdc24687f3250546dad91cb901f2e02322aa09d6b899b7e43038fbf199a46174a687f2f278184651db734933280d22e015a SHA512 800081e87a4d4d4fa161007ab2ea3031c096e82bb70d4e0aa784e9c4b9713a35bbb6343af3782525f702131f15063b757110f23a9e65adea67524fe776e6c05b
+DIST vpl-gpu-rt-24.4.4.tar.gz 9185059 BLAKE2B 25438360274d456fd8fafe95a3bafe9fd2637a8a02422cb42acfd6948fafe8826d438fd1a431d7a0e95f035bd46b20f23a71585c6e3ca4d9faa0e07c02aae02b SHA512 bb5fa4213b5e142c798324e55aec6c4e3faf1d20afda3c35c4cf1d0050263b493df442961b55ff035430002dd180fc51f22b774d525a5b0c80e10e5fddb622da
diff --git a/media-libs/vpl-gpu-rt/vpl-gpu-rt-24.4.4.ebuild b/media-libs/vpl-gpu-rt/vpl-gpu-rt-24.4.4.ebuild
new file mode 100644
index 000000000000..861810f2ef94
--- /dev/null
+++ b/media-libs/vpl-gpu-rt/vpl-gpu-rt-24.4.4.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# NOTE: please bump with the other parts of intel's media stack, listed below
+# https://github.com/intel/vpl-gpu-rt/releases
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Intel Video Processing Library GPU Runtime"
+HOMEPAGE="https://github.com/intel/vpl-gpu-rt/"
+SRC_URI="https://github.com/intel/${PN}/archive/refs/tags/intel-onevpl-${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-intel-onevpl-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ media-libs/libva
+ x11-libs/libdrm[video_cards_intel]
+"
+# At runtime we need a dispatcher, libvpl is preferred but mediasdk also works
+RDEPEND="${DEPEND}
+ >=media-libs/libva-intel-media-driver-${PV}
+ || (
+ media-libs/libvpl
+ media-libs/intel-mediasdk
+ )
+"
+BDEPEND="virtual/pkgconfig"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_RUNTIME=ON
+ # To build the kernels we need to package the cm-compiler, use pre-built instead
+ -DBUILD_KERNELS=OFF
+ -DBUILD_TESTS="$(usex test)"
+ # This only seems to do something if we BUILD_KERNELS=ON
+ #-DBUILD_TOOLS="$(usex tools)"
+ # OpenCL only has an effect if we build kernels
+ -DENABLE_OPENCL=OFF
+ )
+ cmake_src_configure
+}