summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/vips
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/vips')
-rw-r--r--media-libs/vips/Manifest2
-rw-r--r--media-libs/vips/files/vips-7.20.7-build.patch57
-rw-r--r--media-libs/vips/metadata.xml8
-rw-r--r--media-libs/vips/vips-7.26.3.ebuild75
-rw-r--r--media-libs/vips/vips-7.26.7.ebuild75
5 files changed, 217 insertions, 0 deletions
diff --git a/media-libs/vips/Manifest b/media-libs/vips/Manifest
new file mode 100644
index 000000000000..9000a1b53e24
--- /dev/null
+++ b/media-libs/vips/Manifest
@@ -0,0 +1,2 @@
+DIST vips-7.26.3.tar.gz 3163591 SHA256 9acbe13f391bde2e1748e62a3f2e07a4319ad07c2502cc1ee4422f0a6cbd12a0
+DIST vips-7.26.7.tar.gz 3180445 SHA256 efb1c21413f7b5c4d8c5f25bd81f3097805d989559aa0abe1615dbb0f6bb80e7
diff --git a/media-libs/vips/files/vips-7.20.7-build.patch b/media-libs/vips/files/vips-7.20.7-build.patch
new file mode 100644
index 000000000000..7e1fe93fa1e4
--- /dev/null
+++ b/media-libs/vips/files/vips-7.20.7-build.patch
@@ -0,0 +1,57 @@
+http://bugs.gentoo.org/show_bug.cgi?id=298671
+
+--- libvips/colour/im_icc_transform.c
++++ libvips/colour/im_icc_transform.c
+@@ -63,7 +63,7 @@
+ im_icc_transform( IMAGE *in, IMAGE *out,
+ const char *input_profile_filename,
+ const char *output_profile_filename,
+- int intent )
++ VipsIntent intent )
+ {
+ im_error( "im_icc_transform", "%s",
+ _( "lcms library not linked to this VIPS" ) );
+@@ -73,7 +73,7 @@
+
+ int
+ im_icc_import( IMAGE *in, IMAGE *out,
+- const char *input_profile_filename, int intent )
++ const char *input_profile_filename, VipsIntent intent )
+ {
+ im_error( "im_icc_import", "%s",
+ _( "lmcs library not linked to this VIPS" ) );
+@@ -82,7 +82,7 @@
+ }
+
+ int
+-im_icc_import_embedded( IMAGE *in, IMAGE *out, int intent )
++im_icc_import_embedded( IMAGE *in, IMAGE *out, VipsIntent intent )
+ {
+ im_error( "im_icc_import", "%s",
+ _( "lmcs library not linked to this VIPS" ) );
+@@ -92,7 +92,7 @@
+
+ int
+ im_icc_export_depth( IMAGE *in, IMAGE *out, int depth,
+- const char *output_profile_filename, int intent )
++ const char *output_profile_filename, VipsIntent intent )
+ {
+ im_error( "im_icc_export_depth", "%s",
+ _( "lmcs library not linked to this VIPS" ) );
+@@ -101,16 +101,6 @@
+ }
+
+ int
+-im_icc_export( IMAGE *in, IMAGE *out,
+- const char *output_profile_filename, int intent )
+-{
+- im_error( "im_icc_export", "%s",
+- _( "lmcs library not linked to this VIPS" ) );
+-
+- return( -1 );
+-}
+-
+-int
+ im_icc_ac2rc( IMAGE *in, IMAGE *out, const char *profile_filename )
+ {
+ im_error( "im_icc_ac2rc", "%s",
diff --git a/media-libs/vips/metadata.xml b/media-libs/vips/metadata.xml
new file mode 100644
index 000000000000..0dbbee13de7f
--- /dev/null
+++ b/media-libs/vips/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>graphics</herd>
+ <use>
+ <flag name='fits'>Enable support for the FITS image format through <pkg>sci-libs/cfitsio</pkg></flag>
+ </use>
+</pkgmetadata>
diff --git a/media-libs/vips/vips-7.26.3.ebuild b/media-libs/vips/vips-7.26.3.ebuild
new file mode 100644
index 000000000000..0ab369802d05
--- /dev/null
+++ b/media-libs/vips/vips-7.26.3.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+PYTHON_DEPEND="python? 2"
+inherit eutils versionator python
+
+# TODO:
+# matio? ( sci-libs/matio ) - in science overlay #269598 (wait for new release
+# after 1.3.4) or until somebody adds it to the tree.
+
+DESCRIPTION="VIPS Image Processing Library"
+SRC_URI="http://www.vips.ecs.soton.ac.uk/supported/$(get_version_component_range 1-2)/${P}.tar.gz"
+HOMEPAGE="http://vips.sourceforge.net"
+
+LICENSE="LGPL-2.1"
+SLOT="1"
+KEYWORDS="amd64 x86"
+IUSE="debug exif fits fftw imagemagick jpeg lcms openexr +orc png python static-libs tiff"
+
+RDEPEND=">=dev-libs/glib-2.6:2
+ >=dev-libs/liboil-0.3
+ dev-libs/libxml2
+ sys-libs/zlib
+ >=x11-libs/pango-1.8
+ fftw? ( sci-libs/fftw:3.0 )
+ imagemagick? ( || ( >=media-gfx/imagemagick-5.0.0
+ media-gfx/graphicsmagick[imagemagick] ) )
+ lcms? ( media-libs/lcms )
+ openexr? ( >=media-libs/openexr-1.2.2 )
+ exif? ( >=media-libs/libexif-0.6 )
+ tiff? ( media-libs/tiff )
+ jpeg? ( virtual/jpeg )
+ fits? ( sci-libs/cfitsio )
+ png? ( >=media-libs/libpng-1.2.9 )
+ orc? ( >=dev-lang/orc-0.4.11 )"
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am"
+
+pkg_setup() {
+ if use python; then
+ python_set_active_version 2
+ python_pkg_setup
+ fi
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ $(use_with fftw fftw3) \
+ $(use_with lcms) \
+ $(use_with openexr OpenEXR) \
+ $(use_with exif libexif) \
+ $(use_with imagemagick magick) \
+ $(use_with png) \
+ $(use_with tiff) \
+ $(use_with fits cfitsio) \
+ $(use_with jpeg) \
+ $(use_with orc) \
+ $(use_with python) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO || die
+
+ # 314101
+ mv "${ED}"/usr/share/doc/${PN}/* "${ED}"/usr/share/doc/${PF} || die
+ rmdir "${ED}"/usr/share/doc/${PN}/ || die
+ dosym /usr/share/doc/${PF} /usr/share/doc/${PN}
+
+ find "${ED}" -name '*.la' -exec rm -f {} +
+}
diff --git a/media-libs/vips/vips-7.26.7.ebuild b/media-libs/vips/vips-7.26.7.ebuild
new file mode 100644
index 000000000000..08f102715ee0
--- /dev/null
+++ b/media-libs/vips/vips-7.26.7.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+PYTHON_DEPEND="python? 2"
+inherit eutils versionator python
+
+# TODO:
+# matio? ( sci-libs/matio ) - in science overlay #269598 (wait for new release
+# after 1.3.4) or until somebody adds it to the tree.
+
+DESCRIPTION="VIPS Image Processing Library"
+SRC_URI="http://www.vips.ecs.soton.ac.uk/supported/$(get_version_component_range 1-2)/${P}.tar.gz"
+HOMEPAGE="http://vips.sourceforge.net"
+
+LICENSE="LGPL-2.1"
+SLOT="1"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug exif fits fftw imagemagick jpeg lcms openexr +orc png python static-libs tiff"
+
+RDEPEND=">=dev-libs/glib-2.6:2
+ >=dev-libs/liboil-0.3
+ dev-libs/libxml2
+ sys-libs/zlib
+ >=x11-libs/pango-1.8
+ fftw? ( sci-libs/fftw:3.0 )
+ imagemagick? ( || ( >=media-gfx/imagemagick-5.0.0
+ media-gfx/graphicsmagick[imagemagick] ) )
+ lcms? ( media-libs/lcms )
+ openexr? ( >=media-libs/openexr-1.2.2 )
+ exif? ( >=media-libs/libexif-0.6 )
+ tiff? ( media-libs/tiff )
+ jpeg? ( virtual/jpeg )
+ fits? ( sci-libs/cfitsio )
+ png? ( >=media-libs/libpng-1.2.9 )
+ orc? ( >=dev-lang/orc-0.4.11 )"
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am"
+
+pkg_setup() {
+ if use python; then
+ python_set_active_version 2
+ python_pkg_setup
+ fi
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ $(use_with fftw fftw3) \
+ $(use_with lcms) \
+ $(use_with openexr OpenEXR) \
+ $(use_with exif libexif) \
+ $(use_with imagemagick magick) \
+ $(use_with png) \
+ $(use_with tiff) \
+ $(use_with fits cfitsio) \
+ $(use_with jpeg) \
+ $(use_with orc) \
+ $(use_with python) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO || die
+
+ # 314101
+ mv "${ED}"/usr/share/doc/${PN}/* "${ED}"/usr/share/doc/${PF} || die
+ rmdir "${ED}"/usr/share/doc/${PN}/ || die
+ dosym /usr/share/doc/${PF} /usr/share/doc/${PN}
+
+ find "${ED}" -name '*.la' -exec rm -f {} +
+}