summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2016-04-22 02:49:28 +1000
committerMichael Palimaka <kensington@gentoo.org>2016-04-22 03:14:53 +1000
commit1f9e444f7273c0af6d677b2dd3bb7a762dde1529 (patch)
treef7df23b335e9ce128d6333f2c0876fae98567ee2 /media-libs/phonon
parentmedia-libs/phonon: stop passing QT_QMAKE_EXECUTABLE (diff)
downloadgentoo-1f9e444f7273c0af6d677b2dd3bb7a762dde1529.tar.gz
gentoo-1f9e444f7273c0af6d677b2dd3bb7a762dde1529.tar.bz2
gentoo-1f9e444f7273c0af6d677b2dd3bb7a762dde1529.zip
media-libs/phonon: port to EAPI 6
Package-Manager: portage-2.2.28
Diffstat (limited to 'media-libs/phonon')
-rw-r--r--media-libs/phonon/phonon-9999.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/media-libs/phonon/phonon-9999.ebuild b/media-libs/phonon/phonon-9999.ebuild
index 650a95d13653..c2c02144b120 100644
--- a/media-libs/phonon/phonon-9999.ebuild
+++ b/media-libs/phonon/phonon-9999.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
if [[ ${PV} != *9999* ]]; then
SRC_URI="mirror://kde/stable/phonon/${PV}/${P}.tar.xz"
@@ -64,11 +64,11 @@ pkg_setup() {
multilib_src_configure() {
local mycmakeargs=(
+ -DPHONON_BUILD_DESIGNER_PLUGIN=$(usex designer)
-DPHONON_INSTALL_QT_EXTENSIONS_INTO_SYSTEM_QT=TRUE
- $(cmake-utils_use designer PHONON_BUILD_DESIGNER_PLUGIN)
- $(cmake-utils_use_with pulseaudio GLIB2)
- $(cmake-utils_use_with pulseaudio PulseAudio)
- $(multilib_is_native_abi && cmake-utils_use_with zeitgeist QZeitgeist)
+ -DWITH_GLIB2=$(usex pulseaudio)
+ -DWITH_PulseAudio=$(usex pulseaudio)
+ $(multilib_is_native_abi && echo -DWITH_QZeitgeist=$(usex zeitgeist))
)
if [[ ${QT_MULTIBUILD_VARIANT} = qt4 ]]; then