summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilson Michaels <thebitpit@earthlink.net>2020-06-22 10:54:57 -0500
committerJoonas Niilola <juippis@gentoo.org>2020-06-23 16:18:57 +0300
commit36edf2200abcd7713604ece57b0d07bf558f53ba (patch)
treed44455369b7a2f7ccd508d9b9065cb8378a99f59 /media-libs/libhdhomerun/libhdhomerun-20200521.ebuild
parentnet-analyzer/wireshark: Provide correct ctest argument (diff)
downloadgentoo-36edf2200abcd7713604ece57b0d07bf558f53ba.tar.gz
gentoo-36edf2200abcd7713604ece57b0d07bf558f53ba.tar.bz2
gentoo-36edf2200abcd7713604ece57b0d07bf558f53ba.zip
media-libs/libhdhomerun: Bump to 20200521
Closes: https://bugs.gentoo.org/729158 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Wilson Michaels <thebitpit@earthlink.net> Closes: https://github.com/gentoo/gentoo/pull/16373 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'media-libs/libhdhomerun/libhdhomerun-20200521.ebuild')
-rw-r--r--media-libs/libhdhomerun/libhdhomerun-20200521.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/media-libs/libhdhomerun/libhdhomerun-20200521.ebuild b/media-libs/libhdhomerun/libhdhomerun-20200521.ebuild
new file mode 100644
index 000000000000..5e91bd25dfdf
--- /dev/null
+++ b/media-libs/libhdhomerun/libhdhomerun-20200521.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="SiliconDust HDHomeRun Utilties"
+HOMEPAGE="https://www.silicondust.com/support/linux/"
+SRC_URI="https://download.silicondust.com/hdhomerun/${PN}_${PV}.tgz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+PATCHES=(
+ "${FILESDIR}/20190621-use_shared_library.patch"
+)
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ default
+ #Remove forced optimization from Makefile
+ sed -i 's:-O2::' Makefile || die "Was the Makefile changed?"
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) STRIP=:
+}
+
+src_install() {
+ dobin hdhomerun_config
+ dolib.so libhdhomerun.so
+
+ insinto /usr/include/hdhomerun
+ doins *.h
+}