summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/libaacs
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/libaacs')
-rw-r--r--media-libs/libaacs/Manifest3
-rw-r--r--media-libs/libaacs/libaacs-0.7.1.ebuild33
-rw-r--r--media-libs/libaacs/libaacs-0.8.0.ebuild33
-rw-r--r--media-libs/libaacs/libaacs-0.8.1.ebuild33
-rw-r--r--media-libs/libaacs/metadata.xml5
5 files changed, 107 insertions, 0 deletions
diff --git a/media-libs/libaacs/Manifest b/media-libs/libaacs/Manifest
new file mode 100644
index 000000000000..a1ef18491ab2
--- /dev/null
+++ b/media-libs/libaacs/Manifest
@@ -0,0 +1,3 @@
+DIST libaacs-0.7.1.tar.bz2 318472 SHA256 ecc49a22ae2a645cfb5b8e732b51fe0e2684e6488a68debc5edd6e07edadb2b0 SHA512 0fc603854380d51c0d517d64fad54047c726de4c8ad510b035f1d8fe50e6febb41bea9ef00f38356be8c3588b531e687fae7655a56ad93bf48c40bd7cf90bff7 WHIRLPOOL 8d350d6137faf630d09cbcd0b1b9b3472037a00887d4d46af8395bc646203a0fd316660c9fb8815b4955d27a42e279ea7fd404b57907f740e74f5e0913c857d4
+DIST libaacs-0.8.0.tar.bz2 311904 SHA256 5e44545c7c4cb48bea49ff6b19d148416663593d6125ac8734776df21154ba94 SHA512 038ce28ca6c13f1ba6f77ed73bcdbdd4cca7e760a68d65b4c24f9b3480c527ac0cef7301e379fc29b71527a1953b17adb8f0d955926aa4691fb892aa8a09c3f4 WHIRLPOOL 1838e558221f3dd7aa72d0fd8099c96f7dac290927c410f592720f0a5e0c3929df840b273baab4bd4a381fb330a19f8cc9d34ad98f0b9764cde9fb23eeaef3d8
+DIST libaacs-0.8.1.tar.bz2 315231 SHA256 95c344a02c47c9753c50a5386fdfb8313f9e4e95949a5c523a452f0bcb01bbe8 SHA512 dd677627f073460b719b9f836b026acc3e23b166c7b16bd205cf2ca97c376095980532fb15087c0d77b30c712cd5a5dd90b2cc2ae3128da717621ebd825afcc4 WHIRLPOOL e85d7978cb2b46cb5897c9b2c5f3af0512725d8bdb1e2a2e09758c87dc1da1ac7146841234e1c07c52919531573a4686548ef1699f029d76bb6a66cc335b0f19
diff --git a/media-libs/libaacs/libaacs-0.7.1.ebuild b/media-libs/libaacs/libaacs-0.7.1.ebuild
new file mode 100644
index 000000000000..88ea41694320
--- /dev/null
+++ b/media-libs/libaacs/libaacs-0.7.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-multilib
+
+DESCRIPTION="Open implementation of the Advanced Access Content System (AACS) specification"
+HOMEPAGE="http://www.videolan.org/developers/libaacs.html"
+SRC_URI="ftp://ftp.videolan.org/pub/videolan/libaacs/${PV}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ~arm ppc ppc64 sparc x86 ~amd64-fbsd"
+IUSE="static-libs"
+
+RDEPEND=">=dev-libs/libgcrypt-1.5.3:0[${MULTILIB_USEDEP}]
+ >=dev-libs/libgpg-error-1.12[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ virtual/yacc"
+
+DOCS=( ChangeLog KEYDB.cfg README.txt )
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+src_configure() {
+ local myeconfargs=(
+ --disable-optimizations
+ )
+ autotools-multilib_src_configure
+}
diff --git a/media-libs/libaacs/libaacs-0.8.0.ebuild b/media-libs/libaacs/libaacs-0.8.0.ebuild
new file mode 100644
index 000000000000..d4e426385856
--- /dev/null
+++ b/media-libs/libaacs/libaacs-0.8.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-multilib
+
+DESCRIPTION="Open implementation of the Advanced Access Content System (AACS) specification"
+HOMEPAGE="http://www.videolan.org/developers/libaacs.html"
+SRC_URI="ftp://ftp.videolan.org/pub/videolan/libaacs/${PV}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd"
+IUSE="static-libs"
+
+RDEPEND=">=dev-libs/libgcrypt-1.5.3:0=[${MULTILIB_USEDEP}]
+ >=dev-libs/libgpg-error-1.12[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ virtual/yacc"
+
+DOCS=( ChangeLog KEYDB.cfg README.txt )
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+src_configure() {
+ local myeconfargs=(
+ --disable-optimizations
+ )
+ autotools-multilib_src_configure
+}
diff --git a/media-libs/libaacs/libaacs-0.8.1.ebuild b/media-libs/libaacs/libaacs-0.8.1.ebuild
new file mode 100644
index 000000000000..d4e426385856
--- /dev/null
+++ b/media-libs/libaacs/libaacs-0.8.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-multilib
+
+DESCRIPTION="Open implementation of the Advanced Access Content System (AACS) specification"
+HOMEPAGE="http://www.videolan.org/developers/libaacs.html"
+SRC_URI="ftp://ftp.videolan.org/pub/videolan/libaacs/${PV}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd"
+IUSE="static-libs"
+
+RDEPEND=">=dev-libs/libgcrypt-1.5.3:0=[${MULTILIB_USEDEP}]
+ >=dev-libs/libgpg-error-1.12[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ virtual/yacc"
+
+DOCS=( ChangeLog KEYDB.cfg README.txt )
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+src_configure() {
+ local myeconfargs=(
+ --disable-optimizations
+ )
+ autotools-multilib_src_configure
+}
diff --git a/media-libs/libaacs/metadata.xml b/media-libs/libaacs/metadata.xml
new file mode 100644
index 000000000000..d9df1878d8e2
--- /dev/null
+++ b/media-libs/libaacs/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>video</herd>
+</pkgmetadata>