summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeonardo Hernández Hernández <leohdz172@proton.me>2023-12-16 11:11:23 -0600
committerArsen Arsenović <arsen@gentoo.org>2023-12-18 01:01:53 +0100
commit2821ded2324b26a75798484e14a7207872262a9d (patch)
tree4db7112573c23bd97a14cddea333b513c57b495f /media-libs/fcft
parentlxqt-base/lxqt-meta: Keyword 1.4.0 loong, #917093 (diff)
downloadgentoo-2821ded2324b26a75798484e14a7207872262a9d.tar.gz
gentoo-2821ded2324b26a75798484e14a7207872262a9d.tar.bz2
gentoo-2821ded2324b26a75798484e14a7207872262a9d.zip
media-libs/fcft: add 3.1.7
Signed-off-by: Leonardo Hernández Hernández <leohdz172@proton.me> Closes: https://github.com/gentoo/gentoo/pull/34313 Signed-off-by: Arsen Arsenović <arsen@gentoo.org>
Diffstat (limited to 'media-libs/fcft')
-rw-r--r--media-libs/fcft/Manifest1
-rw-r--r--media-libs/fcft/fcft-3.1.7.ebuild94
2 files changed, 95 insertions, 0 deletions
diff --git a/media-libs/fcft/Manifest b/media-libs/fcft/Manifest
index 67ae4cb07401..42eade29bed1 100644
--- a/media-libs/fcft/Manifest
+++ b/media-libs/fcft/Manifest
@@ -2,3 +2,4 @@ DIST fcft-3.1.2.tar.gz 741659 BLAKE2B d4c3b9ef444771f255b7b19e9645d53558caed2022
DIST fcft-3.1.3.tar.gz 741726 BLAKE2B 00792d3bb3848e271b28be7d9afe81e917f547558663b7cc3ce08a3b36cc2d56f3e69b1e06bf16cf73f1a08c8b20696906d6eaa07b59e113846820dd57e22419 SHA512 7275f4807b72b5125242dfba9499647d6c1e80ac9a7df8adde4e8ad082744472d3efa6b8c608c07a2107a7df3005ccad69d574cfb06f35991ccf676df6f1b407
DIST fcft-3.1.5.tar.gz 742014 BLAKE2B 39266ab2a7ea422671414d97c21a90b0eeabe9ed7480c54e44e33ff6d39ab903ac3df154b6733bb4de1e69401480d313f067e6f73f13748bf7fd54aa617cd5e6 SHA512 e223d7e825d8f81f05d2f7ec1b945b28311386dc6ccf55eefaeff2231d64483fdf18a2468f942586ecc0bb4ef75ed9ef0a8a490162b0f8bf7a8619e46742c564
DIST fcft-3.1.6.tar.gz 699121 BLAKE2B 597ce1a701db29d3a8b913d831f1847c9526c450352b565436c843388447d8203b54b3d24ab668690986488c102f281c46685a2072bf4afee2bf58465ab9d6c3 SHA512 4fe4e318561706bd446e79b0df8df4fa5b542b9d546aa7361a1523593c26040d827ce059658c0eac89a77b83c771fd43bc74e2fe29cd16b2846a2db7ec733f49
+DIST fcft-3.1.7.tar.gz 697694 BLAKE2B 2afdd26c631d365ae450691a2073fc61d361c759886e77781b6438e0d8e0db6626230bcc70b99ef2d5a5a05006280bca93d2433157a6974093f1af932952b4c2 SHA512 e862856dfb85c5df85f9f32dce8ed9e7fed8b3dc8435876994f53d276a2c597d0cee0b4fbcbb62362a3771e9ca82c49db95da989404d0c8aa5f604dd50c79075
diff --git a/media-libs/fcft/fcft-3.1.7.ebuild b/media-libs/fcft/fcft-3.1.7.ebuild
new file mode 100644
index 000000000000..fead22b49493
--- /dev/null
+++ b/media-libs/fcft/fcft-3.1.7.ebuild
@@ -0,0 +1,94 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+inherit meson python-any-r1
+
+DESCRIPTION="Simple library for font loading and glyph rasterization"
+HOMEPAGE="https://codeberg.org/dnkl/fcft"
+SRC_URI="https://codeberg.org/dnkl/fcft/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}"
+
+# MIT for fcft
+# ZLIB for nanosvg
+LICENSE="MIT ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="examples +harfbuzz +libutf8proc test"
+REQUIRED_USE="
+ libutf8proc? ( harfbuzz )
+ examples? ( libutf8proc )
+"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ media-libs/fontconfig
+ media-libs/freetype
+ x11-libs/pixman
+ examples? (
+ dev-libs/libutf8proc:=
+ dev-libs/wayland
+ )
+ harfbuzz? (
+ media-libs/harfbuzz:=[truetype]
+ )
+ libutf8proc? (
+ dev-libs/libutf8proc:=
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ app-i18n/unicode-data
+ dev-libs/tllist
+ examples? (
+ dev-libs/wayland-protocols
+ )
+ test? (
+ dev-libs/check
+ harfbuzz? ( media-fonts/noto-emoji )
+ )
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+ app-text/scdoc
+ virtual/pkgconfig
+ examples? (
+ dev-util/wayland-scanner
+ )
+"
+
+src_prepare() {
+ default
+
+ rm -r unicode || die "Failed removing vendored unicode-data"
+
+ sed -i "s;unicode/UnicodeData.txt;${EPREFIX}/usr/share/unicode-data/UnicodeData.txt;" \
+ meson.build || die "Failed changing UnicodeData.txt to system's copy"
+ sed -i "s;unicode/emoji-data.txt;${EPREFIX}/usr/share/unicode-data/emoji/emoji-data.txt;" \
+ meson.build || die "Failed changing emoji-data.txt to system's copy"
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature harfbuzz grapheme-shaping)
+ $(meson_feature libutf8proc run-shaping)
+ $(meson_use examples)
+ $(use test && meson_use harfbuzz test-text-shaping)
+ # bundled, tiny, I believe this means we should always include it
+ -Dsvg-backend=nanosvg
+ -Ddocs=enabled
+ )
+
+ meson_src_configure
+}
+
+src_install() {
+ local DOCS=( CHANGELOG.md README.md )
+ meson_src_install
+
+ rm -r "${ED}"/usr/share/doc/${PN} || die
+
+ use examples && newbin "${BUILD_DIR}/example/example" fcft-example
+}