summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2016-02-19 16:46:50 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2016-02-19 16:47:14 +0100
commit4f74a03e5eab0f11d5802a525e65f22e310faf5a (patch)
tree66ef4c8f459968f83e832df05b12db66005c9c78 /media-gfx/valentina
parentapp-text/agrep: add ~arm keyword (diff)
downloadgentoo-4f74a03e5eab0f11d5802a525e65f22e310faf5a.tar.gz
gentoo-4f74a03e5eab0f11d5802a525e65f22e310faf5a.tar.bz2
gentoo-4f74a03e5eab0f11d5802a525e65f22e310faf5a.zip
media-gfx/valentina: fixed qa warning about insecure runpaths
Package-Manager: portage-2.2.27
Diffstat (limited to 'media-gfx/valentina')
-rw-r--r--media-gfx/valentina/files/fix-insecure-runpaths.patch56
-rw-r--r--media-gfx/valentina/valentina-0.4.2-r3.ebuild (renamed from media-gfx/valentina/valentina-0.4.2-r2.ebuild)5
-rw-r--r--media-gfx/valentina/valentina-9999.ebuild2
3 files changed, 60 insertions, 3 deletions
diff --git a/media-gfx/valentina/files/fix-insecure-runpaths.patch b/media-gfx/valentina/files/fix-insecure-runpaths.patch
new file mode 100644
index 000000000000..a98a069dfb5a
--- /dev/null
+++ b/media-gfx/valentina/files/fix-insecure-runpaths.patch
@@ -0,0 +1,56 @@
+# HG changeset patch
+# User Roman Telezhynskyi <kroluku@gmail.com>
+# Date 1455895311 -7200
+# Branch develop
+# Node ID ebb8c53b8fdc09d2542ec6b8a63585be63c02725
+# Parent a29fbab1f3ac59fda0e81bf1e99d153b5f47bd7c
+CONFIG key to disable setting custom rpath option.
+
+diff --git a/src/app/tape/tape.pro b/src/app/tape/tape.pro
+--- a/src/app/tape/tape.pro
++++ b/src/app/tape/tape.pro
+@@ -348,10 +348,16 @@
+ # Path to recource file.
+ win32:RC_FILE = share/resources/tape.rc
+
+-unix:!macx{
+- # suppress the default RPATH
+- QMAKE_LFLAGS_RPATH =
+- QMAKE_LFLAGS += "-Wl,-rpath,\'\$$ORIGIN\' -Wl,-rpath,$${OUT_PWD}/../../libs/qmuparser/$${DESTDIR} -Wl,-rpath,$${OUT_PWD}/../../libs/vpropertyexplorer/$${DESTDIR}"
++noRunPath{ # For enable run qmake with CONFIG+=noRunPath
++ # do nothing
++} else {
++ unix:!macx{
++ # suppress the default RPATH
++ # helps to run the program without Qt Creator
++ # see problem with path to libqmuparser and libpropertybrowser
++ QMAKE_LFLAGS_RPATH =
++ QMAKE_LFLAGS += "-Wl,-rpath,\'\$$ORIGIN\' -Wl,-rpath,$${OUT_PWD}/../../libs/qmuparser/$${DESTDIR} -Wl,-rpath,$${OUT_PWD}/../../libs/vpropertyexplorer/$${DESTDIR}"
++ }
+ }
+
+ # When the GNU linker sees a library, it discards all symbols that it doesn't need.
+diff --git a/src/app/valentina/valentina.pro b/src/app/valentina/valentina.pro
+--- a/src/app/valentina/valentina.pro
++++ b/src/app/valentina/valentina.pro
+@@ -476,10 +476,16 @@
+ copyToDestdir($$pdftops_path, $$shell_path($${OUT_PWD}/$$DESTDIR))
+ }
+
+-unix:!macx{
+- # suppress the default RPATH
+- QMAKE_LFLAGS_RPATH =
+- QMAKE_LFLAGS += "-Wl,-rpath,\'\$$ORIGIN\' -Wl,-rpath,$${OUT_PWD}/../../libs/qmuparser/$${DESTDIR} -Wl,-rpath,$${OUT_PWD}/../../libs/vpropertyexplorer/$${DESTDIR}"
++noRunPath{ # For enable run qmake with CONFIG+=noRunPath
++ # do nothing
++} else {
++ unix:!macx{
++ # suppress the default RPATH
++ # helps to run the program without Qt Creator
++ # see problem with path to libqmuparser and libpropertybrowser
++ QMAKE_LFLAGS_RPATH =
++ QMAKE_LFLAGS += "-Wl,-rpath,\'\$$ORIGIN\' -Wl,-rpath,$${OUT_PWD}/../../libs/qmuparser/$${DESTDIR} -Wl,-rpath,$${OUT_PWD}/../../libs/vpropertyexplorer/$${DESTDIR}"
++ }
+ }
+
+ # When the GNU linker sees a library, it discards all symbols that it doesn't need.
diff --git a/media-gfx/valentina/valentina-0.4.2-r2.ebuild b/media-gfx/valentina/valentina-0.4.2-r3.ebuild
index 76ac3590c0a8..30affd184b50 100644
--- a/media-gfx/valentina/valentina-0.4.2-r2.ebuild
+++ b/media-gfx/valentina/valentina-0.4.2-r3.ebuild
@@ -39,7 +39,8 @@ DEPEND="${CDEPEND}
S=${WORKDIR}/dismine-${PN}-44d43351cb59
src_prepare() {
- epatch "${FILESDIR}/locales.patch"
+ epatch "${FILESDIR}/locales.patch" \
+ "${FILESDIR}/fix-insecure-runpaths.patch"
}
src_configure() {
@@ -51,7 +52,7 @@ src_configure() {
fi
done
- eqmake5 LOCALES="${locales}" CONFIG+=noStripDebugSymbols CONFIG+=no_ccache Valentina.pro -r
+ eqmake5 LOCALES="${locales}" CONFIG+=noStripDebugSymbols CONFIG+=no_ccache CONFIG+=noRunPath Valentina.pro -r
}
src_install() {
diff --git a/media-gfx/valentina/valentina-9999.ebuild b/media-gfx/valentina/valentina-9999.ebuild
index 7ddd9faf3caa..70fd441642b7 100644
--- a/media-gfx/valentina/valentina-9999.ebuild
+++ b/media-gfx/valentina/valentina-9999.ebuild
@@ -46,7 +46,7 @@ src_configure() {
fi
done
- eqmake5 LOCALES="${locales}" CONFIG+=noStripDebugSymbols CONFIG+=no_ccache Valentina.pro -r
+ eqmake5 LOCALES="${locales}" CONFIG+=noStripDebugSymbols CONFIG+=no_ccache CONFIG+=noRunPath Valentina.pro -r
}
src_install() {