summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-02-21 12:06:01 +0100
committerMichał Górny <mgorny@gentoo.org>2016-02-21 12:09:02 +0100
commit3ab3d5331e3a9b5006264636db8df11c714c9232 (patch)
tree94da2781d32e9be3d94564945b80ab08135874f8 /media-gfx/splash-themes-livecd
parentwww-apps/jekyll: Remove old (diff)
parentmedia-gfx/splash-themes-livecd: Use functions.sh from gentoo-functions (diff)
downloadgentoo-3ab3d5331e3a9b5006264636db8df11c714c9232.tar.gz
gentoo-3ab3d5331e3a9b5006264636db8df11c714c9232.tar.bz2
gentoo-3ab3d5331e3a9b5006264636db8df11c714c9232.zip
media-gfx/splash-themes-livecd: Merge gentoo-functions use fix
Pull-Request: https://github.com/gentoo/gentoo/pull/874
Diffstat (limited to 'media-gfx/splash-themes-livecd')
-rw-r--r--media-gfx/splash-themes-livecd/files/use-new-path-for-functions.sh.patch11
-rw-r--r--media-gfx/splash-themes-livecd/splash-themes-livecd-2007.0-r3.ebuild42
2 files changed, 53 insertions, 0 deletions
diff --git a/media-gfx/splash-themes-livecd/files/use-new-path-for-functions.sh.patch b/media-gfx/splash-themes-livecd/files/use-new-path-for-functions.sh.patch
new file mode 100644
index 000000000000..67128fbe5393
--- /dev/null
+++ b/media-gfx/splash-themes-livecd/files/use-new-path-for-functions.sh.patch
@@ -0,0 +1,11 @@
+--- scripts/rc_init-pre.orig 2016-02-18 13:31:23.610276701 -0200
++++ scripts/rc_init-pre 2016-02-18 13:31:57.405275206 -0200
+@@ -77,7 +77,7 @@
+ return 0
+ }
+
+-[ -r /etc/init.d/functions.sh ] && . /etc/init.d/functions.sh
++[ -r /lib/gentoo/functions.sh ] && . /lib/gentoo/functions.sh
+
+ if [ -z "${1}" ]; then
+ log err "no internal runlevel provided"
diff --git a/media-gfx/splash-themes-livecd/splash-themes-livecd-2007.0-r3.ebuild b/media-gfx/splash-themes-livecd/splash-themes-livecd-2007.0-r3.ebuild
new file mode 100644
index 000000000000..ee8fface6a76
--- /dev/null
+++ b/media-gfx/splash-themes-livecd/splash-themes-livecd-2007.0-r3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils
+
+MY_P="gentoo-livecd-${PV}"
+MY_REV="0.9.6"
+DESCRIPTION="Gentoo theme for gensplash consoles"
+HOMEPAGE="https://www.gentoo.org/"
+SRC_URI="mirror://gentoo/${PN}/${MY_P}-${MY_REV}.tar.bz2"
+
+SLOT=${PV}
+LICENSE="Artistic GPL-2 BitstreamVera"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+RESTRICT="binchecks strip"
+
+RDEPEND=">=media-gfx/splashutils-1.5.4[png]
+ sys-apps/gentoo-functions"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ if ! built_with_use media-gfx/splashutils mng
+ then
+ ewarn "MNG support is missing from splashutils. You will not see the"
+ ewarn "service icons as services are starting."
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/use-new-path-for-functions.sh.patch
+}
+
+src_install() {
+ dodir /etc/splash/livecd-${PV}
+ cp -r "${S}"/* "${D}"/etc/splash/livecd-${PV} || die
+}