summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/scrot
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/scrot')
-rw-r--r--media-gfx/scrot/Manifest3
-rw-r--r--media-gfx/scrot/files/scrot.bash-completion40
-rw-r--r--media-gfx/scrot/metadata.xml5
-rw-r--r--media-gfx/scrot/scrot-0.8-r1.ebuild28
-rw-r--r--media-gfx/scrot/scrot-0.8_p13.ebuild38
5 files changed, 114 insertions, 0 deletions
diff --git a/media-gfx/scrot/Manifest b/media-gfx/scrot/Manifest
new file mode 100644
index 000000000000..c22426baa848
--- /dev/null
+++ b/media-gfx/scrot/Manifest
@@ -0,0 +1,3 @@
+DIST scrot-0.8.tar.gz 74324 SHA256 613d1cf524c2b62ce3c65f1232ea4f05c7daf248d5e82ff2a6892c98093994f2 SHA512 cba8f589e45758ddbfe4e276399a1ecb0dbe29569be5d85d97733e7f64de2911bd2d03e62700ad0c718a1fc886c2e3def9dee1de5cac884f9e65e772cebe838c WHIRLPOOL 713e21755b7252d8bb32ec499674249ab29015e1896e67e98be02c403f7b20973389617698195f93ebc7f77249e14122e402f9fb4a110ac7bdbdb62c57863cab
+DIST scrot_0.8-13.debian.tar.gz 7943 SHA256 508bb60c9f476d593a49ca0f1bbe0b3d5a742289146c5b33033435fc286e2376 SHA512 3f6d0a8e592088af38a3d90394b6b7246430479f5b0c8451af5eae383725d1896dc4bbf595495f9f2b546f00ef38780123c4ee0e3f06971c55a6ac2dfa5b7d53 WHIRLPOOL d60a42425ea541a18879207d0b5d1b0936a733adc1168aed13793258c2812556e0e6ccf69f834fff59ea326ff9d990c72475f8a2115a609dbdf618a076c10501
+DIST scrot_0.8.orig.tar.gz 74324 SHA256 613d1cf524c2b62ce3c65f1232ea4f05c7daf248d5e82ff2a6892c98093994f2 SHA512 cba8f589e45758ddbfe4e276399a1ecb0dbe29569be5d85d97733e7f64de2911bd2d03e62700ad0c718a1fc886c2e3def9dee1de5cac884f9e65e772cebe838c WHIRLPOOL 713e21755b7252d8bb32ec499674249ab29015e1896e67e98be02c403f7b20973389617698195f93ebc7f77249e14122e402f9fb4a110ac7bdbdb62c57863cab
diff --git a/media-gfx/scrot/files/scrot.bash-completion b/media-gfx/scrot/files/scrot.bash-completion
new file mode 100644
index 000000000000..d7e5729cd849
--- /dev/null
+++ b/media-gfx/scrot/files/scrot.bash-completion
@@ -0,0 +1,40 @@
+# bash-completion script for scrot
+# place this in /etc/bash_completion.d
+
+_scrot() {
+ local cur prev opts
+ COMPREPLY=()
+ cur=${COMP_WORDS[COMP_CWORD]}
+ prev=${COMP_WORDS[COMP_CWORD-1]}
+ opts="-h --help -v --version -b --border -c --count -d --delay -e --exec \
+ -q --quality -m --multidisp -s --select -t --thumb"
+
+ if [[ "${cur}" == -* ]] || [[ ${COMP_CWORD} -eq 1 ]]; then
+ COMPREPLY=($(compgen -W "${opts}" -- "${cur}"))
+ fi
+
+ case "${prev}" in
+ -e|--exec)
+ COMPREPLY=($(compgen -A command -- "${cur}"))
+ ;;
+ -h|--help)
+ COMPREPLY=($(compgen -W "${opts/-h --help}" -- "${cur}"))
+ ;;
+ -v|--version)
+ COMPREPLY=($(compgen -W "${opts/-v --version}" -- "${cur}"))
+ ;;
+ -b|--border)
+ COMPREPLY=($(compgen -W "${opts/-b --border}" -- "${cur}"))
+ ;;
+ -c|--count)
+ COMPREPLY=($(compgen -W "${opts/-c --count}" -- "${cur}"))
+ ;;
+ -m|--multidisp)
+ COMPREPLY=($(compgen -W "${opts/-m --multidisp}" -- "${cur}"))
+ ;;
+ -s|--select)
+ COMPREPLY=($(compgen -W "${opts/-s --select}" -- "${cur}"))
+ ;;
+ esac
+}
+complete -F _scrot scrot
diff --git a/media-gfx/scrot/metadata.xml b/media-gfx/scrot/metadata.xml
new file mode 100644
index 000000000000..e770d1bc9a96
--- /dev/null
+++ b/media-gfx/scrot/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>graphics</herd>
+</pkgmetadata>
diff --git a/media-gfx/scrot/scrot-0.8-r1.ebuild b/media-gfx/scrot/scrot-0.8-r1.ebuild
new file mode 100644
index 000000000000..564d145d8319
--- /dev/null
+++ b/media-gfx/scrot/scrot-0.8-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit bash-completion-r1
+
+DESCRIPTION="Screen capture utility using imlib2 library"
+HOMEPAGE="http://www.linuxbrit.co.uk/"
+SRC_URI="http://www.linuxbrit.co.uk/downloads/${P}.tar.gz"
+
+LICENSE="feh LGPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=media-libs/imlib2-1.0.3
+ >=media-libs/giblib-1.2.3"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ emake DESTDIR="${D}" install
+ rm -r "${D}"/usr/doc
+ dodoc AUTHORS ChangeLog
+
+ newbashcomp "${FILESDIR}/${PN}.bash-completion" ${PN}
+}
diff --git a/media-gfx/scrot/scrot-0.8_p13.ebuild b/media-gfx/scrot/scrot-0.8_p13.ebuild
new file mode 100644
index 000000000000..179ea5f5724c
--- /dev/null
+++ b/media-gfx/scrot/scrot-0.8_p13.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MY_PV=${PV/_p/-}
+
+inherit bash-completion-r1 eutils
+
+DESCRIPTION="Screen capture utility using imlib2 library"
+HOMEPAGE="http://scrot.sourcearchive.com/"
+SRC_URI="http://${PN}.sourcearchive.com/downloads/${MY_PV}/${PN}_0.8.orig.tar.gz
+ http://${PN}.sourcearchive.com/downloads/${MY_PV}/${PN}_${MY_PV}.debian.tar.gz"
+
+LICENSE="feh LGPL-2+"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ppc ppc64 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=media-libs/imlib2-1.0.3
+ >=media-libs/giblib-1.2.3"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${PN}-0.8
+
+src_prepare() {
+ local d=${WORKDIR}/debian/patches
+ EPATCH_SOURCE=${d} epatch $(<"${d}"/series)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ rm -r "${D}"/usr/doc
+ dodoc AUTHORS ChangeLog
+
+ newbashcomp "${FILESDIR}"/${PN}.bash-completion ${PN}
+}