summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNRK <nrk@disroot.org>2023-06-13 20:13:48 +0600
committerJoonas Niilola <juippis@gentoo.org>2023-06-18 15:16:39 +0300
commit1a9762db97844b948ec51183e6d99fff7ac16f14 (patch)
treece37902e7df905cd5585e95a30febd4726c8207c /media-gfx/scrot
parentmedia-radio/tlf: Fix inclomplete prototypes (diff)
downloadgentoo-1a9762db97844b948ec51183e6d99fff7ac16f14.tar.gz
gentoo-1a9762db97844b948ec51183e6d99fff7ac16f14.tar.bz2
gentoo-1a9762db97844b948ec51183e6d99fff7ac16f14.zip
media-gfx/scrot: add v1.10
Signed-off-by: NRK <nrk@disroot.org> Closes: https://github.com/gentoo/gentoo/pull/31414 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'media-gfx/scrot')
-rw-r--r--media-gfx/scrot/Manifest1
-rw-r--r--media-gfx/scrot/scrot-1.10.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/media-gfx/scrot/Manifest b/media-gfx/scrot/Manifest
index 6bb19cf051da..62b926c21a11 100644
--- a/media-gfx/scrot/Manifest
+++ b/media-gfx/scrot/Manifest
@@ -1 +1,2 @@
+DIST scrot-1.10.tar.bz2 156519 BLAKE2B ca1441823521d14559afe49ed36853bb5448cc5c2ee345ddb617324b63e8f599678cbdc94b862938017a62d2f5ceea3cae03f80e473e86cafc76dd34144d41bb SHA512 7a72b6d7ae350b0ec27b949934ff67cb8800f731f3dfc783bfdf66c4316b318118b8b46d98aca05543144b757c659791f4a9aeae43364277501238a405eda57d
DIST scrot-1.9.tar.bz2 158710 BLAKE2B d823c0875a260ee9741e1c9038fe743e69d0afa83220448857d109dd3ebad9977f07871b25c6a4a979efdf2abd246a2facec91c5b0af01c47307dc6266c801d3 SHA512 ace3bcb26ecebc5bb139a6e011a562287be8f676f21211b540dd937ab2d4487047d3565d0aec84e099bd2c5c9b037d9044924b031f930dc45a3040df399a3312
diff --git a/media-gfx/scrot/scrot-1.10.ebuild b/media-gfx/scrot/scrot-1.10.ebuild
new file mode 100644
index 000000000000..f03c9dc8cd96
--- /dev/null
+++ b/media-gfx/scrot/scrot-1.10.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1
+
+DESCRIPTION="Screen capture utility using imlib2 library"
+HOMEPAGE="https://github.com/resurrecting-open-source-projects/scrot"
+if [[ ${PV} == *9999* ]] ; then
+ EGIT_REPO_URI="https://github.com/resurrecting-open-source-projects/${PN}"
+ inherit autotools git-r3
+else
+ SRC_URI="https://github.com/resurrecting-open-source-projects/${PN}/releases/download/${PV}/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+fi
+
+LICENSE="feh"
+SLOT="0"
+
+# imlib2[X] needed for imlib_create_image_from_drawable, bug #835582
+# imlib2[png] not technically requried, but it's the default format used by
+# scrot, so unconditionally depend on it to avoid breaking basic commands which
+# don't specify an output format.
+RDEPEND="
+ media-libs/imlib2[X,filters(+),text(+)]
+ x11-libs/libXext
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXfixes
+ x11-libs/libXinerama
+ media-libs/imlib2[png]
+"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto
+ elibc_musl? ( sys-libs/queue-standalone )
+"
+BDEPEND="
+ sys-devel/autoconf-archive
+ virtual/pkgconfig
+"
+
+DOCS=(
+ AUTHORS ChangeLog README.md
+)
+
+src_prepare() {
+ default
+
+ [[ ${PV} == *9999* ]] && eautoreconf
+}
+
+src_install() {
+ default
+
+ newbashcomp "${FILESDIR}"/${PN}-1.7.bash-completion ${PN}
+}