summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNRK <nrk@disroot.org>2024-06-22 13:30:56 +0000
committerJoonas Niilola <juippis@gentoo.org>2024-07-18 10:39:30 +0300
commitc778983c71957a36f9cb9f30fe99fc9e97dbc795 (patch)
tree5e34226ab7aea1206fa7ad69a196f7f638c1d1b7 /media-gfx/scrot/scrot-9999.ebuild
parentnet-analyzer/goaccess: remove autotools eclass (diff)
downloadgentoo-c778983c71957a36f9cb9f30fe99fc9e97dbc795.tar.gz
gentoo-c778983c71957a36f9cb9f30fe99fc9e97dbc795.tar.bz2
gentoo-c778983c71957a36f9cb9f30fe99fc9e97dbc795.zip
media-gfx/scrot: update 9999
- sys-libs/queue-standalone no longer needed - use upstream bash and zsh completion files - add FAQ.md to DOCS - add autoconf-archive to BDEPEND only on live ebuild Signed-off-by: NRK <nrk@disroot.org> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'media-gfx/scrot/scrot-9999.ebuild')
-rw-r--r--media-gfx/scrot/scrot-9999.ebuild11
1 files changed, 6 insertions, 5 deletions
diff --git a/media-gfx/scrot/scrot-9999.ebuild b/media-gfx/scrot/scrot-9999.ebuild
index 092a65896df9..d383d2bfa6bc 100644
--- a/media-gfx/scrot/scrot-9999.ebuild
+++ b/media-gfx/scrot/scrot-9999.ebuild
@@ -3,13 +3,14 @@
EAPI=8
-inherit bash-completion-r1
+inherit shell-completion
DESCRIPTION="Screen capture utility using imlib2 library"
HOMEPAGE="https://github.com/resurrecting-open-source-projects/scrot"
if [[ ${PV} == *9999* ]] ; then
EGIT_REPO_URI="https://github.com/resurrecting-open-source-projects/${PN}"
inherit autotools git-r3
+ LIVE_BDEPEND="dev-build/autoconf-archive"
else
SRC_URI="https://github.com/resurrecting-open-source-projects/${PN}/releases/download/${PV}/${P}.tar.bz2"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
@@ -34,15 +35,14 @@ RDEPEND="
DEPEND="
${RDEPEND}
x11-base/xorg-proto
- elibc_musl? ( sys-libs/queue-standalone )
"
BDEPEND="
- dev-build/autoconf-archive
+ ${LIVE_BDEPEND}
virtual/pkgconfig
"
DOCS=(
- AUTHORS ChangeLog README.md
+ AUTHORS ChangeLog README.md FAQ.md
)
src_prepare() {
@@ -54,5 +54,6 @@ src_prepare() {
src_install() {
default
- newbashcomp "${FILESDIR}"/${PN}-1.7.bash-completion ${PN}
+ dozshcomp etc/zsh-completion/_scrot
+ dobashcomp etc/bash-completion/scrot
}