summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authororbea <orbea@riseup.net>2021-05-26 18:08:47 -0700
committerSam James <sam@gentoo.org>2021-06-03 21:10:58 +0000
commit3d369c261af7d3961d396701baae3f8a63f37f4f (patch)
tree34ac29d429dc06970020df58c2dd931e809d4643 /media-gfx/flam3
parentwww-client/opera-beta: bump to 77.0.4054.38 (diff)
downloadgentoo-3d369c261af7d3961d396701baae3f8a63f37f4f.tar.gz
gentoo-3d369c261af7d3961d396701baae3f8a63f37f4f.tar.bz2
gentoo-3d369c261af7d3961d396701baae3f8a63f37f4f.zip
media-gfx/flam3: Fix for slibtool
Upstream-PR: https://github.com/scottdraves/flam3/pull/33 Closes: https://bugs.gentoo.org/779001 Signed-off-by: orbea <orbea@riseup.net> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-gfx/flam3')
-rw-r--r--media-gfx/flam3/files/flam3-3.1.1-slibtool.patch53
-rw-r--r--media-gfx/flam3/flam3-3.1.1.ebuild6
2 files changed, 57 insertions, 2 deletions
diff --git a/media-gfx/flam3/files/flam3-3.1.1-slibtool.patch b/media-gfx/flam3/files/flam3-3.1.1-slibtool.patch
new file mode 100644
index 000000000000..084c1ba77827
--- /dev/null
+++ b/media-gfx/flam3/files/flam3-3.1.1-slibtool.patch
@@ -0,0 +1,53 @@
+From 78ea170715b57bbde0275447dbcc8b20a926b05d Mon Sep 17 00:00:00 2001
+From: orbea <orbea@riseup.net>
+Date: Sun, 28 Mar 2021 13:15:53 -0700
+Subject: [PATCH] build: Fix undefined libm references.
+
+---
+ Makefile.am | 11 ++++++-----
+ configure.ac | 2 ++
+ 2 files changed, 8 insertions(+), 5 deletions(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index c3d0f42..78954e8 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -11,19 +11,20 @@ lib_LTLIBRARIES = libflam3.la
+ include_HEADERS = flam3.h isaac.h isaacs.h rect.c
+
+ libflam3_la_SOURCES = flam3.c filters.c parser.c variations.c interpolation.c palettes.c jpeg.c png.c isaac.c
+-libflam3_la_LDFLAGS = -no-undefined -ljpeg -lpng -lz -lpthread
++libflam3_la_LDFLAGS = -no-undefined
++libflam3_la_LIBADD = -ljpeg -lpng -lz -lpthread $(LIBM)
+
+ flam3_genome_SOURCES = flam3-genome.c docstring.c
+-flam3_genome_LDADD = libflam3.la -lm
++flam3_genome_LDADD = libflam3.la
+
+ flam3_animate_SOURCES = flam3-animate.c docstring.c
+-flam3_animate_LDADD = libflam3.la -lm
++flam3_animate_LDADD = libflam3.la
+
+ flam3_render_SOURCES = flam3-render.c docstring.c
+-flam3_render_LDADD = libflam3.la -lm
++flam3_render_LDADD = libflam3.la
+
+ flam3_convert_SOURCES = flam3-convert.c docstring.c
+-flam3_convert_LDADD = libflam3.la -lm
++flam3_convert_LDADD = libflam3.la
+
+ pkgdata_DATA = flam3-palettes.xml
+
+diff --git a/configure.ac b/configure.ac
+index c427bb5..f7f4839 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -28,6 +28,8 @@ AC_CHECK_LIB([z],[deflateInit_],,[AC_MSG_ERROR([zlib is required.])])
+ AC_CHECK_LIB([png],[png_write_image],,[AC_MSG_ERROR([The png library is required.])])
+ AC_CHECK_LIB([xml2],[xmlParseFile],,[AC_MSG_ERROR([The xml2 library is required.])])
+
++AC_CHECK_LIBM
++AC_SUBST([LIBM])
+
+ if test "${enable_atomic_ops}" = "" ; then
+ enable_atomic_ops=yes
diff --git a/media-gfx/flam3/flam3-3.1.1.ebuild b/media-gfx/flam3/flam3-3.1.1.ebuild
index 6a111b72cfe3..98af333a4faf 100644
--- a/media-gfx/flam3/flam3-3.1.1.ebuild
+++ b/media-gfx/flam3/flam3-3.1.1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit autotools
DESCRIPTION="Tools and a library for creating flame fractal images"
@@ -21,9 +21,11 @@ DEPEND="${RDEPEND}"
DOCS=( README.txt )
+PATCHES=( "${FILESDIR}"/${P}-slibtool.patch )
+
src_prepare() {
+ default
eautoreconf
- eapply_user
}
src_configure() {