summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz@gentoo.org>2024-11-03 14:00:39 -0500
committerEli Schwartz <eschwartz@gentoo.org>2024-11-03 14:07:11 -0500
commit73c5f2eaa9f83705bf6e160d34133cb20d881977 (patch)
tree4d6f4c154792a761cae96ea593d0c537abbc10e4 /media-gfx/chafa
parentmedia-gfx/chafa: mark FP for implicit function decls in configure (diff)
downloadgentoo-73c5f2eaa9f83705bf6e160d34133cb20d881977.tar.gz
gentoo-73c5f2eaa9f83705bf6e160d34133cb20d881977.tar.bz2
gentoo-73c5f2eaa9f83705bf6e160d34133cb20d881977.zip
media-gfx/chafa: make sure elibtoolize is applied
Needed to e.g. pass LTO warning flags through to the linker. Signed-off-by: Eli Schwartz <eschwartz@gentoo.org>
Diffstat (limited to 'media-gfx/chafa')
-rw-r--r--media-gfx/chafa/chafa-1.12.5-r1.ebuild7
-rw-r--r--media-gfx/chafa/chafa-1.14.1.ebuild5
2 files changed, 11 insertions, 1 deletions
diff --git a/media-gfx/chafa/chafa-1.12.5-r1.ebuild b/media-gfx/chafa/chafa-1.12.5-r1.ebuild
index 4c8a4adfa06b..06c118fd88ee 100644
--- a/media-gfx/chafa/chafa-1.12.5-r1.ebuild
+++ b/media-gfx/chafa/chafa-1.12.5-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit flag-o-matic
+inherit flag-o-matic libtool
DESCRIPTION="versatile and fast Unicode/ASCII/ANSI graphics renderer"
HOMEPAGE="https://hpjansson.org/chafa/ https://github.com/hpjansson/chafa"
@@ -28,6 +28,11 @@ QA_CONFIG_IMPL_DECL_SKIP=(
_mm_popcnt_u64
)
+src_prepare() {
+ default
+ elibtoolize
+}
+
src_configure() {
# bug 909429
use webp && append-ldflags -lwebp
diff --git a/media-gfx/chafa/chafa-1.14.1.ebuild b/media-gfx/chafa/chafa-1.14.1.ebuild
index 819bed597ca8..4414459ae1ca 100644
--- a/media-gfx/chafa/chafa-1.14.1.ebuild
+++ b/media-gfx/chafa/chafa-1.14.1.ebuild
@@ -27,6 +27,11 @@ QA_CONFIG_IMPL_DECL_SKIP=(
_mm_popcnt_u64
)
+src_prepare() {
+ default
+ elibtoolize
+}
+
src_configure() {
# bug 909429
use webp && append-ldflags -lwebp