summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/apngasm
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/apngasm')
-rw-r--r--media-gfx/apngasm/Manifest3
-rw-r--r--media-gfx/apngasm/apngasm-2.5.ebuild33
-rw-r--r--media-gfx/apngasm/apngasm-2.6.ebuild33
-rw-r--r--media-gfx/apngasm/apngasm-2.7.ebuild37
-rw-r--r--media-gfx/apngasm/files/apngasm-2.7-string_h.patch16
-rw-r--r--media-gfx/apngasm/metadata.xml8
6 files changed, 130 insertions, 0 deletions
diff --git a/media-gfx/apngasm/Manifest b/media-gfx/apngasm/Manifest
new file mode 100644
index 000000000000..6a948c3dc2df
--- /dev/null
+++ b/media-gfx/apngasm/Manifest
@@ -0,0 +1,3 @@
+DIST apngasm-2.5-src.zip 11333 SHA256 e5346948f2a51328161b3ef0d2c8111cd7289c7b4ac48e72db3a617cfb4f24c5
+DIST apngasm-2.6-src.zip 11350 SHA256 1d4b63e55c241c0db4a812e6cddea48586e4275b041a1e600154c2840f4ebb06 SHA512 b603bb91ad2c803abd18894ff95212f9cbed37a61fdefec60f06284e03bf274721b291f63ac8cf7d6c0cad516cb05f2ae7382f4aeb42ec87ebb07eaf29b27050 WHIRLPOOL 0e1c2684e3b36a062fb832077b29395a2198dca94c784c80d9e9c7de7542db3208a9e80e7529d6e28b2e46b32ff98534b96b62e683eba3a1b2d4515898446b95
+DIST apngasm-2.7-src.zip 11448 SHA256 af42569666cab268a20a0754191396c9d48f4e01d6e8f93c3ae1164c3c821cc3 SHA512 28ec70a4ac02021ff85390ad6863aaca5451937209345128ecd5baf76bef9495168c3c4ee5d823afbeb569ca673328673a81b807e7985c3d5d1843c056af7810 WHIRLPOOL e2cd3c937af8010672cb3866903df084c52e37e7c05c0933f0e7bf2be69ee74a78c5367c463a07d2314e5d416c3616e6e218060298f349be0eab944d4e6af2eb
diff --git a/media-gfx/apngasm/apngasm-2.5.ebuild b/media-gfx/apngasm/apngasm-2.5.ebuild
new file mode 100644
index 000000000000..d8a89394cf0c
--- /dev/null
+++ b/media-gfx/apngasm/apngasm-2.5.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit toolchain-funcs
+
+DESCRIPTION="create an APNG from multiple PNG files"
+HOMEPAGE="http://sourceforge.net/projects/apngasm/"
+SRC_URI="mirror://sourceforge/${PN}/${PV}/${P}-src.zip"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="media-libs/libpng[apng]
+ sys-libs/zlib"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ app-arch/unzip"
+
+S=${WORKDIR}
+
+src_compile() {
+ emake CC="$(tc-getCC)" LDLIBS="$($(tc-getPKG_CONFIG) --libs libpng --libs zlib)" ${PN}
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc readme.txt
+}
diff --git a/media-gfx/apngasm/apngasm-2.6.ebuild b/media-gfx/apngasm/apngasm-2.6.ebuild
new file mode 100644
index 000000000000..d8a89394cf0c
--- /dev/null
+++ b/media-gfx/apngasm/apngasm-2.6.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit toolchain-funcs
+
+DESCRIPTION="create an APNG from multiple PNG files"
+HOMEPAGE="http://sourceforge.net/projects/apngasm/"
+SRC_URI="mirror://sourceforge/${PN}/${PV}/${P}-src.zip"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="media-libs/libpng[apng]
+ sys-libs/zlib"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ app-arch/unzip"
+
+S=${WORKDIR}
+
+src_compile() {
+ emake CC="$(tc-getCC)" LDLIBS="$($(tc-getPKG_CONFIG) --libs libpng --libs zlib)" ${PN}
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc readme.txt
+}
diff --git a/media-gfx/apngasm/apngasm-2.7.ebuild b/media-gfx/apngasm/apngasm-2.7.ebuild
new file mode 100644
index 000000000000..5c12c8caa3d7
--- /dev/null
+++ b/media-gfx/apngasm/apngasm-2.7.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="create an APNG from multiple PNG files"
+HOMEPAGE="http://sourceforge.net/projects/apngasm/"
+SRC_URI="mirror://sourceforge/${PN}/${PV}/${P}-src.zip"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="media-libs/libpng:0=[apng]
+ sys-libs/zlib:="
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ virtual/pkgconfig"
+
+S=${WORKDIR}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-string_h.patch #465780
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" LDLIBS="$($(tc-getPKG_CONFIG) --libs libpng --libs zlib)" ${PN}
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc readme.txt
+}
diff --git a/media-gfx/apngasm/files/apngasm-2.7-string_h.patch b/media-gfx/apngasm/files/apngasm-2.7-string_h.patch
new file mode 100644
index 000000000000..303e832b37c5
--- /dev/null
+++ b/media-gfx/apngasm/files/apngasm-2.7-string_h.patch
@@ -0,0 +1,16 @@
+http://bugs.gentoo.org/465780
+
+Same for all of memcpy(), memset(), strlen() and strcpy():
+
+apngasm.c:141:11: warning: incompatible implicit declaration of built-in function ‘memcpy’ [enabled by default]
+
+--- apngasm.c
++++ apngasm.c
+@@ -29,6 +29,7 @@
+ */
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <string.h>
+ #include "png.h" /* original (unpatched) libpng is ok */
+ #include "zlib.h"
+
diff --git a/media-gfx/apngasm/metadata.xml b/media-gfx/apngasm/metadata.xml
new file mode 100644
index 000000000000..e61abad77a70
--- /dev/null
+++ b/media-gfx/apngasm/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>graphics</herd>
+ <upstream>
+ <remote-id type="sourceforge">apngasm</remote-id>
+ </upstream>
+</pkgmetadata>