summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jordan <immoloism@gmail.com>2024-11-10 20:12:29 +0000
committerSam James <sam@gentoo.org>2024-11-26 03:14:35 +0000
commit87f0a89764201565de2b2e7a676f322456911cd3 (patch)
tree803ca8cd1647214849243a68d8e6036d20043472 /mate-base
parentapp-arch/engrampa: add 1.28.2 (diff)
downloadgentoo-87f0a89764201565de2b2e7a676f322456911cd3.tar.gz
gentoo-87f0a89764201565de2b2e7a676f322456911cd3.tar.bz2
gentoo-87f0a89764201565de2b2e7a676f322456911cd3.zip
mate-base/mate-panel: add 1.28.4
Signed-off-by: Ian Jordan <immoloism@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'mate-base')
-rw-r--r--mate-base/mate-panel/Manifest1
-rw-r--r--mate-base/mate-panel/mate-panel-1.28.4.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/mate-base/mate-panel/Manifest b/mate-base/mate-panel/Manifest
index 145579f2fbb2..6454f99f9c33 100644
--- a/mate-base/mate-panel/Manifest
+++ b/mate-base/mate-panel/Manifest
@@ -1 +1,2 @@
DIST mate-panel-1.28.1.tar.xz 3282404 BLAKE2B 54a60c8fdf319ebe8678963faaeb6f93a1e60cb9ee43ed32896a04f1bdbcfc89d1b0696500948d334827d4d73d5373c748e53349c47559389ba2e4f51d31270a SHA512 50ecb7a3006e989c7e51ece72ef0f2ce0e1fec84844b97281e07f9f4b1005e3b81870d7bca882a453225e69db109a344e6fe80a12d2c4cdc54ef5d87fee68a7c
+DIST mate-panel-1.28.4.tar.xz 3240648 BLAKE2B 2db3962071eca43e29b4687988819de5777d753abea3b6087d3ff588c7db6f0305986943abebd700bdc3d0d6ddc6c8531debbbafdad92fad8ece48e8d906e1a9 SHA512 2a58c39c9b8b736e8c0e4623cdc7b84eaeb44bcd79299b18d20f69f4c06606ca07b502626c6502b5edf0586794977dba6757eb800ddc7e9bb532a5ec2a4b237a
diff --git a/mate-base/mate-panel/mate-panel-1.28.4.ebuild b/mate-base/mate-panel/mate-panel-1.28.4.ebuild
new file mode 100644
index 000000000000..82c9b5429129
--- /dev/null
+++ b/mate-base/mate-panel/mate-panel-1.28.4.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MATE_LA_PUNT="yes"
+
+inherit mate
+
+MINOR=$(($(ver_cut 2) % 2))
+if [[ ${MINOR} -eq 0 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+fi
+
+DESCRIPTION="The MATE panel"
+LICENSE="FDL-1.1+ GPL-2+ LGPL-2+"
+SLOT="0"
+
+IUSE="+X +introspection wayland"
+
+REQUIRED_USE="|| ( X wayland )"
+
+COMMON_DEPEND="
+ >=app-accessibility/at-spi2-core-2.46.0:2
+ >=dev-libs/glib-2.50:2
+ >=dev-libs/libmateweather-1.28.0
+ dev-libs/libxml2:2
+ >=gnome-base/dconf-0.13.4
+ >=gnome-base/dconf-editor-43.0
+ >=mate-base/mate-desktop-$(ver_cut 1-2)
+ >=mate-base/mate-menus-1.28.0
+ >=sys-apps/dbus-1.1.2
+ >=x11-libs/cairo-1.0.0[X?]
+ >=x11-libs/gdk-pixbuf-2.26.0:2
+ >=x11-libs/gtk+-3.22:3[introspection?]
+ x11-libs/libICE
+ x11-libs/libSM
+ >=x11-libs/libwnck-3.4.6:3[introspection?]
+ >=x11-libs/pango-1.15.4:0[introspection?]
+ X? (
+ x11-libs/libX11
+ x11-libs/libXau
+ >=x11-libs/libXrandr-1.3
+ )
+ introspection? ( >=dev-libs/gobject-introspection-0.6.7:= )
+ wayland? ( gui-libs/gtk-layer-shell )
+"
+
+RDEPEND="${COMMON_DEPEND}
+ virtual/libintl
+"
+
+DEPEND="${COMMON_DEPEND}"
+
+BDEPEND="
+ app-text/docbook-xml-dtd:4.1.2
+ app-text/yelp-tools
+ >=dev-lang/perl-5:=
+ dev-util/glib-utils
+ dev-util/gdbus-codegen
+ dev-util/gtk-doc
+ dev-build/gtk-doc-am
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_configure() {
+ mate_src_configure \
+ --libexecdir="${EPREFIX}"/usr/libexec/mate-applets \
+ --disable-deprecation-flags \
+ $(use_enable X x11) \
+ $(use_enable introspection) \
+ $(use_enable wayland)
+}