summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2025-01-01 20:34:00 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2025-01-01 22:04:07 +0100
commit50cf34baaaf0c73026124a9d595d258b6c3c410d (patch)
tree02c74c9b2cba386b7d7d6ee9fa8a8a9fa65d9517 /kde-plasma
parentkde-plasma/powerdevil: 6.2.5 version bump (diff)
downloadgentoo-50cf34baaaf0c73026124a9d595d258b6c3c410d.tar.gz
gentoo-50cf34baaaf0c73026124a9d595d258b6c3c410d.tar.bz2
gentoo-50cf34baaaf0c73026124a9d595d258b6c3c410d.zip
kde-plasma/print-manager: 6.2.5 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma')
-rw-r--r--kde-plasma/print-manager/Manifest1
-rw-r--r--kde-plasma/print-manager/print-manager-6.2.5.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/kde-plasma/print-manager/Manifest b/kde-plasma/print-manager/Manifest
index 16f2bba122d7..fbde4f40a521 100644
--- a/kde-plasma/print-manager/Manifest
+++ b/kde-plasma/print-manager/Manifest
@@ -1 +1,2 @@
DIST print-manager-6.2.4.tar.xz 375024 BLAKE2B 26327fb7bd6c6477b2d0f03c34002c6573ec326e6208c9ee321a3943a4fde66a7999761840a4a25fecf5dd61fadf3fba2c05f1375f6776beddcae64c210307eb SHA512 fb7192cb7ddfb15969d71176552642b1e067467a0e39e5a4f87f43523a78049e63cd721aa0beff47721eb395b35a8de406966d77dfab89b69951d45c6c11a1f4
+DIST print-manager-6.2.5.tar.xz 374932 BLAKE2B 1a0f88ec4744700396edd03c0877eef9b6d0f8a52d998d4df9a38f9752c93000b6c04e74c0edd389269d5bdb043faeea032a31ab877039d0e70811989dff5128 SHA512 da261c7659d85d67c04eb6b8839bc48d36be41b536312706b3356aa8e85c13832b64741dfa57656778ea6b093fbbb27f268361bf007585050e8bf63113475a9b
diff --git a/kde-plasma/print-manager/print-manager-6.2.5.ebuild b/kde-plasma/print-manager/print-manager-6.2.5.ebuild
new file mode 100644
index 000000000000..c32219660b1a
--- /dev/null
+++ b/kde-plasma/print-manager/print-manager-6.2.5.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=6.6.0
+QTMIN=6.7.2
+inherit ecm plasma.kde.org
+
+DESCRIPTION="Manage CUPS print jobs and printers in Plasma"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="6"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="+gtk"
+
+DEPEND="
+ >=dev-qt/qt5compat-${QTMIN}:6
+ >=dev-qt/qtbase-${QTMIN}:6[dbus,gui,network,widgets]
+ >=dev-qt/qtdeclarative-${QTMIN}:6
+ >=kde-frameworks/kcmutils-${KFMIN}:6
+ >=kde-frameworks/kconfig-${KFMIN}:6
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:6
+ >=kde-frameworks/kcoreaddons-${KFMIN}:6
+ >=kde-frameworks/kdbusaddons-${KFMIN}:6
+ >=kde-frameworks/ki18n-${KFMIN}:6
+ >=kde-frameworks/kiconthemes-${KFMIN}:6
+ >=kde-frameworks/kio-${KFMIN}:6
+ >=kde-frameworks/kirigami-${KFMIN}:6
+ >=kde-frameworks/knotifications-${KFMIN}:6
+ >=kde-frameworks/kservice-${KFMIN}:6
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:6
+ >=kde-frameworks/kwindowsystem-${KFMIN}:6
+ >=kde-plasma/libplasma-${KDE_CATV}:6
+ >=net-print/cups-2.4
+"
+RDEPEND="${DEPEND}
+ !<kde-plasma/print-manager-23.08.5-r100:5
+ >=kde-frameworks/kdeclarative-${KFMIN}:6
+ gtk? ( app-admin/system-config-printer )
+"
+BDEPEND=">=kde-frameworks/kcmutils-${KFMIN}:6"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_PackageKitQt6=ON # not packaged
+ )
+
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ ecm_pkg_postinst
+
+ if [[ -z "${REPLACING_VERSIONS}" ]] && ! use gtk ; then
+ ewarn "By switching off \"gtk\" USE flag, you have chosen to do without"
+ ewarn "an important, though optional, runtime dependency:"
+ ewarn
+ ewarn "app-admin/system-config-printer"
+ ewarn
+ ewarn "${PN} will work nevertheless, but is going to be less comfortable"
+ ewarn "and will show the following error status during runtime:"
+ ewarn
+ ewarn "\"Failed to group devices: 'The name org.fedoraproject.Config.Printing"
+ ewarn "was not provided by any .service files'\""
+ fi
+}