summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-05-09 16:07:17 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2023-05-09 16:33:55 +0200
commit024dd10672d90801ba9c8949680e57c821edc4f9 (patch)
tree5047212a7a0313ce3351aa67f35cc9a74b6bdc58 /kde-plasma
parentkde-plasma/plasma-meta: 5.27.5 version bump (diff)
downloadgentoo-024dd10672d90801ba9c8949680e57c821edc4f9.tar.gz
gentoo-024dd10672d90801ba9c8949680e57c821edc4f9.tar.bz2
gentoo-024dd10672d90801ba9c8949680e57c821edc4f9.zip
kde-plasma/plasma-nm: 5.27.5 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma')
-rw-r--r--kde-plasma/plasma-nm/Manifest1
-rw-r--r--kde-plasma/plasma-nm/plasma-nm-5.27.5.ebuild82
2 files changed, 83 insertions, 0 deletions
diff --git a/kde-plasma/plasma-nm/Manifest b/kde-plasma/plasma-nm/Manifest
index db77c36a9e89..138876f7e789 100644
--- a/kde-plasma/plasma-nm/Manifest
+++ b/kde-plasma/plasma-nm/Manifest
@@ -1 +1,2 @@
DIST plasma-nm-5.27.4.tar.xz 1151372 BLAKE2B b6a2c30c17b7fe5e19bba032ad0d4822c5f4ff931530cc4718d17c976317f782a3a318c1c2204ef84c2d247bb828cf7638e26283ecbb5246515c4648ce6592d2 SHA512 4077c63af9da002a8c6fc18a6fa1ccbadd84c9786a7e922209756b4ce4fc8a6780a092b5a412d79caf38872831035a3659c84fb73857d58ab0088dc73fc64c36
+DIST plasma-nm-5.27.5.tar.xz 1155948 BLAKE2B e74da009a035b6bd46823c94fd5f798c7dfc794cf5e80af2e2a655ee9939269dd6fa222412e1c4fa1d249f657010206b1871c9ae0f6998ecf7d9f46ed549e7d4 SHA512 a7b66bb44cecf489a83c62aee29ebd5fa697ebccabd0c384adbbf0e5facc209b6d202b85ce0a490be26f0830d4b936c3442d6077200d4f08a1faeef42d7266bc
diff --git a/kde-plasma/plasma-nm/plasma-nm-5.27.5.ebuild b/kde-plasma/plasma-nm/plasma-nm-5.27.5.ebuild
new file mode 100644
index 000000000000..5ceda4f33f7b
--- /dev/null
+++ b/kde-plasma/plasma-nm/plasma-nm-5.27.5.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_TEST="true"
+KFMIN=5.102.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=5.15.7
+inherit ecm plasma.kde.org
+
+DESCRIPTION="KDE Plasma applet for NetworkManager"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="openconnect teamd"
+
+DEPEND="
+ >=app-crypt/qca-2.3.0:2[qt5(+)]
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5[widgets]
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtxml-${QTMIN}:5
+ >=kde-frameworks/kcompletion-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kdbusaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kitemviews-${KFMIN}:5
+ >=kde-frameworks/knotifications-${KFMIN}:5
+ >=kde-frameworks/kservice-${KFMIN}:5
+ >=kde-frameworks/kwallet-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/kwindowsystem-${KFMIN}:5
+ >=kde-frameworks/kxmlgui-${KFMIN}:5
+ >=kde-frameworks/modemmanager-qt-${KFMIN}:5
+ >=kde-frameworks/networkmanager-qt-${KFMIN}:5[teamd=]
+ >=kde-frameworks/plasma-${KFMIN}:5
+ >=kde-frameworks/solid-${KFMIN}:5
+ net-misc/mobile-broadband-provider-info
+ net-misc/networkmanager[teamd=]
+ openconnect? (
+ net-vpn/networkmanager-openconnect
+ net-vpn/openconnect:=
+ )
+"
+RDEPEND="${DEPEND}
+ >=dev-qt/qtquickcontrols-${QTMIN}:5
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+ >=kde-frameworks/kdeclarative-${KFMIN}:5
+ >=kde-frameworks/kirigami-${KFMIN}:5
+ >=kde-frameworks/kquickcharts-${KFMIN}:5
+ >=kde-plasma/kde-cli-tools-${PVCUT}:5
+"
+BDEPEND="
+ >=kde-frameworks/kcmutils-${KFMIN}:5
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ ecm_src_prepare
+
+ # TODO: try to get a build switch upstreamed
+ if ! use openconnect; then
+ sed -e "s/^pkg_check_modules.*openconnect/#&/" -i CMakeLists.txt || die
+ fi
+}
+
+pkg_postinst() {
+ ecm_pkg_postinst
+
+ if ! has_version "kde-plasma/plasma-workspace:5"; then
+ elog "${PN} is not terribly useful without kde-plasma/plasma-workspace:5."
+ elog "However, the networkmanagement KCM can be called from either systemsettings"
+ elog "or manually: $ kcmshell5 kcm_networkmanagement"
+ fi
+}