summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoao Carreira <jfmcarreira@gmail.com>2016-10-29 11:36:00 +0200
committerJohannes Huber <johu@gentoo.org>2016-10-29 11:37:32 +0200
commit4696e33c530a35929a9bb662eb00019dd9669fd6 (patch)
tree2f576144105ab4e68a27cf3b5e0b83cd1e1ec2f2 /kde-misc/ktoshiba/ktoshiba-5.3.1.ebuild
parentapp-backup/duply: Version Bump (diff)
downloadgentoo-4696e33c530a35929a9bb662eb00019dd9669fd6.tar.gz
gentoo-4696e33c530a35929a9bb662eb00019dd9669fd6.tar.bz2
gentoo-4696e33c530a35929a9bb662eb00019dd9669fd6.zip
kde-misc/ktoshiba: Version bump 5.3.1
Package-Manager: portage-2.3.2
Diffstat (limited to 'kde-misc/ktoshiba/ktoshiba-5.3.1.ebuild')
-rw-r--r--kde-misc/ktoshiba/ktoshiba-5.3.1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/kde-misc/ktoshiba/ktoshiba-5.3.1.ebuild b/kde-misc/ktoshiba/ktoshiba-5.3.1.ebuild
new file mode 100644
index 000000000000..b9226a147640
--- /dev/null
+++ b/kde-misc/ktoshiba/ktoshiba-5.3.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit kde5
+
+DESCRIPTION="Function key (FN) monitoring for Toshiba laptops"
+HOMEPAGE="http://ktoshiba.sourceforge.net/"
+SRC_URI="http://prdownloads.sourceforge.net/${PN}/${P}.tar.xz"
+LICENSE="GPL-2"
+
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ $(add_frameworks_dep kauth)
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ net-libs/libmnl
+"
+
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DLIBMNL_INCLUDE_DIRS=/usr/include/libmnl
+ )
+ kde5_src_configure
+}