summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /kde-misc/homerun
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'kde-misc/homerun')
-rw-r--r--kde-misc/homerun/Manifest2
-rw-r--r--kde-misc/homerun/homerun-1.2.4.ebuild35
-rw-r--r--kde-misc/homerun/homerun-1.2.5.ebuild35
-rw-r--r--kde-misc/homerun/metadata.xml5
4 files changed, 77 insertions, 0 deletions
diff --git a/kde-misc/homerun/Manifest b/kde-misc/homerun/Manifest
new file mode 100644
index 000000000000..3f3db3938c7f
--- /dev/null
+++ b/kde-misc/homerun/Manifest
@@ -0,0 +1,2 @@
+DIST homerun-1.2.4.tar.xz 206108 SHA256 be277e7b7358a828ee86b1e121faf23ad35d0fe0677c370ba0760db5b64ac7da SHA512 6f7121b5acce140c9ed3084b529ecfca8a3a4bb0a21dc7fb53ac64a374453ffc52f894db79851057622568d8f084b9adb307a94b2c543e71485d4afbf90da80d WHIRLPOOL 46168877d1fd2fb11b0ced60898f189a8621e88dc5f56a5500894851c32f950ee61f6619e3d5992c7f28eaf307359773f92e64bd1204a015f75e7734cf0de970
+DIST homerun-1.2.5.tar.xz 206912 SHA256 23f56511b3d64ed3ce979bd6a233aa3d864e9babd333524451d119ec6026c79e SHA512 66fd4db1acaf318002da1127cce0415b92b60bb8343934e6c0f9a93167fa3583f136f6d838c1890ebb2e99a1f4ee6c9374cad0da79b33e3f607130b7f7d42b89 WHIRLPOOL 8f14b4d37426c604b71451a79d686f5859ab206670221b674004b0c667cad807d0a5c1b25010a2dc45a34cd04e15dc71dfc79d5b45bd39cadff9b2c6115b9fd7
diff --git a/kde-misc/homerun/homerun-1.2.4.ebuild b/kde-misc/homerun/homerun-1.2.4.ebuild
new file mode 100644
index 000000000000..4ec161cdd57a
--- /dev/null
+++ b/kde-misc/homerun/homerun-1.2.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DECLARATIVE_REQUIRED="always"
+VIRTUALX_REQUIRED="test"
+VIRTUALDBUS_TEST="true"
+KDE_LINGUAS="ca ca@valencia cs da de el es fi fr gl it nl pl pt pt_BR ro sk sl
+sv tr uk zh_CN"
+KDE_MINIMAL="4.10"
+inherit kde4-base
+
+DESCRIPTION="Application launcher for KDE Plasma desktop"
+HOMEPAGE="https://projects.kde.org/projects/playground/base/homerun"
+[[ ${PV} == *9999 ]] || SRC_URI="mirror://kde/stable/${PN}/src/${P}.tar.xz"
+
+LICENSE="GPL-2 LGPL-2.1 BSD"
+KEYWORDS="~amd64 ~x86"
+SLOT="4"
+IUSE="debug"
+
+DEPEND="
+ $(add_kdeapps_dep libkonq)
+ $(add_kdebase_dep libkworkspace)
+"
+RDEPEND="
+ ${DEPEND}
+ $(add_kdebase_dep plasma-workspace)
+"
+
+# Fails 2 out of 6, check later again.
+# With virtualx/virtualdbus it hangs
+RESTRICT="test"
diff --git a/kde-misc/homerun/homerun-1.2.5.ebuild b/kde-misc/homerun/homerun-1.2.5.ebuild
new file mode 100644
index 000000000000..6208921e0cdc
--- /dev/null
+++ b/kde-misc/homerun/homerun-1.2.5.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DECLARATIVE_REQUIRED="always"
+VIRTUALX_REQUIRED="test"
+VIRTUALDBUS_TEST="true"
+KDE_LINGUAS="ca ca@valencia cs da de el es fi fr gl hu it nl pl pt pt_BR ro sk
+sl sv tr uk zh_CN"
+KDE_MINIMAL="4.10"
+inherit kde4-base
+
+DESCRIPTION="Application launcher for KDE Plasma desktop"
+HOMEPAGE="https://projects.kde.org/projects/playground/base/homerun"
+[[ ${PV} == *9999 ]] || SRC_URI="mirror://kde/stable/${PN}/src/${P}.tar.xz"
+
+LICENSE="GPL-2 LGPL-2.1 BSD"
+KEYWORDS="~amd64 ~x86"
+SLOT="4"
+IUSE="debug"
+
+DEPEND="
+ $(add_kdeapps_dep libkonq)
+ $(add_kdebase_dep libkworkspace)
+"
+RDEPEND="
+ ${DEPEND}
+ $(add_kdebase_dep plasma-workspace)
+"
+
+# Fails 2 out of 6, check later again.
+# With virtualx/virtualdbus it hangs
+RESTRICT="test"
diff --git a/kde-misc/homerun/metadata.xml b/kde-misc/homerun/metadata.xml
new file mode 100644
index 000000000000..8d1e86a9cefb
--- /dev/null
+++ b/kde-misc/homerun/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>kde</herd>
+</pkgmetadata>