summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-01-24 10:23:19 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-01-24 13:57:38 +0100
commitbeabe660dec13ac95cf9c5d06a43a2a10065836b (patch)
tree55463273c13b9b06b40c87431a861d84b2859fc7 /kde-frameworks
parentmedia-video/smplayer: Drop 20.4.2 (diff)
downloadgentoo-beabe660dec13ac95cf9c5d06a43a2a10065836b.tar.gz
gentoo-beabe660dec13ac95cf9c5d06a43a2a10065836b.tar.bz2
gentoo-beabe660dec13ac95cf9c5d06a43a2a10065836b.zip
kde-frameworks/kio: Fix build with GCC-11
Upstream commit 9965ec1b9e6f6db192a2355e4e3eb80bc27fc092 Thanks-to: Geoff Leach <gl@cs.rmit.edu.au> Closes: https://bugs.gentoo.org/766480 Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks')
-rw-r--r--kde-frameworks/kio/files/kio-5.77.0-gcc11.patch32
-rw-r--r--kde-frameworks/kio/kio-5.77.0-r1.ebuild11
-rw-r--r--kde-frameworks/kio/kio-5.78.0.ebuild6
3 files changed, 43 insertions, 6 deletions
diff --git a/kde-frameworks/kio/files/kio-5.77.0-gcc11.patch b/kde-frameworks/kio/files/kio-5.77.0-gcc11.patch
new file mode 100644
index 000000000000..7432364a9864
--- /dev/null
+++ b/kde-frameworks/kio/files/kio-5.77.0-gcc11.patch
@@ -0,0 +1,32 @@
+From 9965ec1b9e6f6db192a2355e4e3eb80bc27fc092 Mon Sep 17 00:00:00 2001
+From: Ahmad Samir <a.samirh78@gmail.com>
+Date: Sun, 24 Jan 2021 11:10:27 +0200
+Subject: [PATCH] Fix build with gcc11
+
+Apparently now we need to #include <limit>.
+
+Patch by Geoff Leach:
+https://bugs.gentoo.org/766480
+https://invent.kde.org/frameworks/kio/-/issues/3
+
+NO_CHANGELOG
+---
+ src/kntlm/des.cpp | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/src/kntlm/des.cpp b/src/kntlm/des.cpp
+index 18d85bfd..65c86f06 100644
+--- a/src/kntlm/des.cpp
++++ b/src/kntlm/des.cpp
+@@ -29,6 +29,8 @@
+ #include <string.h>
+ #include <qendian.h>
+
++#include <limits>
++
+ static void permute_ip(unsigned char *inblock, DES_KEY *key, unsigned char *outblock);
+ static void permute_fp(unsigned char *inblock, DES_KEY *key, unsigned char *outblock);
+ static void perminit_ip(DES_KEY *key);
+--
+GitLab
+
diff --git a/kde-frameworks/kio/kio-5.77.0-r1.ebuild b/kde-frameworks/kio/kio-5.77.0-r1.ebuild
index 6b8abe7e5b5e..7219074c6230 100644
--- a/kde-frameworks/kio/kio-5.77.0-r1.ebuild
+++ b/kde-frameworks/kio/kio-5.77.0-r1.ebuild
@@ -16,6 +16,9 @@ LICENSE="LGPL-2+"
KEYWORDS="amd64 ~arm arm64 ~ppc64 x86"
IUSE="acl +handbook kerberos +kwallet X"
+# tests hang
+RESTRICT+=" test"
+
RDEPEND="
dev-libs/libxml2
dev-libs/libxslt
@@ -68,10 +71,10 @@ PDEPEND="
>=kde-frameworks/kded-${PVCUT}:5
"
-# tests hang
-RESTRICT+=" test"
-
-PATCHES=( "${FILESDIR}/${P}-crashfix.patch" )
+PATCHES=(
+ "${FILESDIR}/${P}-crashfix.patch"
+ "${FILESDIR}/${P}-gcc11.patch" # bug 766480
+)
src_configure() {
local mycmakeargs=(
diff --git a/kde-frameworks/kio/kio-5.78.0.ebuild b/kde-frameworks/kio/kio-5.78.0.ebuild
index 04866eaeffa4..4b22f628f1f7 100644
--- a/kde-frameworks/kio/kio-5.78.0.ebuild
+++ b/kde-frameworks/kio/kio-5.78.0.ebuild
@@ -16,6 +16,9 @@ LICENSE="LGPL-2+"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
IUSE="acl +handbook kerberos +kwallet X"
+# tests hang
+RESTRICT+=" test"
+
RDEPEND="
dev-libs/libxml2
dev-libs/libxslt
@@ -68,8 +71,7 @@ PDEPEND="
>=kde-frameworks/kded-${PVCUT}:5
"
-# tests hang
-RESTRICT+=" test"
+PATCHES=( "${FILESDIR}/${PN}-5.77.0-gcc11.patch" ) # bug 766480
src_configure() {
local mycmakeargs=(