summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-08-11 00:21:01 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-08-11 10:19:23 +0200
commit832934f31e45d450d2eaee2a9ebd501303303c43 (patch)
tree26ddfbcde55dc86490c71053a6813be8c3a8c212 /kde-frameworks/sonnet
parentmedia-gfx/digikam: Drop 6.1.0 (diff)
downloadgentoo-832934f31e45d450d2eaee2a9ebd501303303c43.tar.gz
gentoo-832934f31e45d450d2eaee2a9ebd501303303c43.tar.bz2
gentoo-832934f31e45d450d2eaee2a9ebd501303303c43.zip
kde-frameworks: Add KDE Frameworks 5.61.0
Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/sonnet')
-rw-r--r--kde-frameworks/sonnet/Manifest1
-rw-r--r--kde-frameworks/sonnet/sonnet-5.61.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/kde-frameworks/sonnet/Manifest b/kde-frameworks/sonnet/Manifest
index 78d1829c348a..7046253ad313 100644
--- a/kde-frameworks/sonnet/Manifest
+++ b/kde-frameworks/sonnet/Manifest
@@ -1 +1,2 @@
DIST sonnet-5.60.0.tar.xz 287516 BLAKE2B 1500c4e978205a70b68a0f59a4767980544c9f380a3286f2c6072d98cd61f0e986a996df602680e782b46b791e3e2feaf3b6076b56219a3f15ee0d137124a674 SHA512 2dbb3bec5f0999b82a09c9ff9a826cb390dfae55d91f4ae91ed494a41d498ec18a5bfb53ecd95f6b086bd2f0b72f6ffbcc690aefe8de1e2e6694ec8750230441
+DIST sonnet-5.61.0.tar.xz 286520 BLAKE2B 4fecfc69603c8d63942e7b92bc92691d82e5eca2d093812ad3c86015eee0e0e29746bbc6561b81339acbe42d9e38f737800bc665819945636fd3277dc93fa550 SHA512 8917ca9207715e308080c9f68107a97d234a1aa95fffa85712c413a51493010fc52e0e39c618c3d8290a9731d07b343d8349f383428cce8358a662ddc8698b97
diff --git a/kde-frameworks/sonnet/sonnet-5.61.0.ebuild b/kde-frameworks/sonnet/sonnet-5.61.0.ebuild
new file mode 100644
index 000000000000..84fcfa644e78
--- /dev/null
+++ b/kde-frameworks/sonnet/sonnet-5.61.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Framework for providing spell-checking through abstraction of popular backends"
+LICENSE="LGPL-2+ LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="aspell +hunspell nls"
+
+BDEPEND="
+ nls? ( $(add_qt_dep linguist-tools) )
+"
+DEPEND="
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ aspell? ( app-text/aspell )
+ hunspell? ( app-text/hunspell:= )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package aspell ASPELL)
+ $(cmake-utils_use_find_package hunspell HUNSPELL)
+ )
+
+ kde5_src_configure
+}
+
+src_test() {
+ # bugs: 680032
+ local myctestargs=(
+ -E "(sonnet-test_settings|sonnet-test_highlighter)"
+ )
+
+ kde5_src_test
+}