summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-09-29 00:26:16 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-09-29 14:46:08 +0200
commitfb205328f7ecd5b4dea6b635eba82a07f1736399 (patch)
treeb47af127b11fcde91c9ed647fb29d577d7b40872 /kde-frameworks/plasma
parentkde-frameworks/kirigami: Drop 5.74.0 (r0) (diff)
downloadgentoo-fb205328f7ecd5b4dea6b635eba82a07f1736399.tar.gz
gentoo-fb205328f7ecd5b4dea6b635eba82a07f1736399.tar.bz2
gentoo-fb205328f7ecd5b4dea6b635eba82a07f1736399.zip
kde-frameworks/plasma: Fix PC3/ToolButton icons color set
Upstream commit 3167717797d07a8645391e093fa91526c4645f4 KDE-Bug: https://bugs.kde.org/show_bug.cgi?id=426556 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/plasma')
-rw-r--r--kde-frameworks/plasma/files/plasma-5.74.0-fix-pc3-button-icons-color-set.patch28
-rw-r--r--kde-frameworks/plasma/plasma-5.74.0-r1.ebuild76
2 files changed, 104 insertions, 0 deletions
diff --git a/kde-frameworks/plasma/files/plasma-5.74.0-fix-pc3-button-icons-color-set.patch b/kde-frameworks/plasma/files/plasma-5.74.0-fix-pc3-button-icons-color-set.patch
new file mode 100644
index 000000000000..8f938b00b89b
--- /dev/null
+++ b/kde-frameworks/plasma/files/plasma-5.74.0-fix-pc3-button-icons-color-set.patch
@@ -0,0 +1,28 @@
+From 3167717797d07a8645391e093fa91526c4645f4f Mon Sep 17 00:00:00 2001
+From: Noah Davis <noahadvs@gmail.com>
+Date: Wed, 23 Sep 2020 20:23:08 -0400
+Subject: [PATCH] Fix PC3 Button/ToolButton icons not always having the right
+ color set
+
+BUG: 426556
+FIXED-IN: 5.75
+---
+ .../plasmacomponents3/private/ButtonContent.qml | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/declarativeimports/plasmacomponents3/private/ButtonContent.qml b/src/declarativeimports/plasmacomponents3/private/ButtonContent.qml
+index 6dc2ce085..91428bdb3 100644
+--- a/src/declarativeimports/plasmacomponents3/private/ButtonContent.qml
++++ b/src/declarativeimports/plasmacomponents3/private/ButtonContent.qml
+@@ -42,7 +42,7 @@ GridLayout {
+
+ implicitWidth: root.parent.icon.width > 0 ? root.parent.icon.width : defaultIconSize
+ implicitHeight: root.parent.icon.height > 0 ? root.parent.icon.height : defaultIconSize
+-
++ colorGroup: parent.PlasmaCore.ColorScope.colorGroup
+ visible: source.length > 0 && root.parent.display !== T.Button.TextOnly
+ source: root.parent.icon ? (root.parent.icon.name || root.parent.icon.source) : ""
+ status: usingFocusBackground ? PlasmaCore.Svg.Selected : PlasmaCore.Svg.Normal
+--
+GitLab
+
diff --git a/kde-frameworks/plasma/plasma-5.74.0-r1.ebuild b/kde-frameworks/plasma/plasma-5.74.0-r1.ebuild
new file mode 100644
index 000000000000..445cbc96d858
--- /dev/null
+++ b/kde-frameworks/plasma/plasma-5.74.0-r1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_ORG_NAME="${PN}-framework"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.14.2
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="Plasma framework"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="gles2-only wayland X"
+
+BDEPEND="
+ >=kde-frameworks/kdoctools-${PVCUT}:5
+"
+RDEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5[gles2-only=]
+ >=dev-qt/qtquickcontrols-${QTMIN}:5
+ >=dev-qt/qtsql-${QTMIN}:5
+ >=dev-qt/qtsvg-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kactivities-${PVCUT}*:5
+ =kde-frameworks/karchive-${PVCUT}*:5
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/kconfigwidgets-${PVCUT}*:5
+ =kde-frameworks/kcoreaddons-${PVCUT}*:5
+ =kde-frameworks/kdeclarative-${PVCUT}*:5
+ =kde-frameworks/kglobalaccel-${PVCUT}*:5
+ =kde-frameworks/kguiaddons-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/kiconthemes-${PVCUT}*:5
+ =kde-frameworks/kio-${PVCUT}*:5
+ =kde-frameworks/kirigami-${PVCUT}*:5
+ =kde-frameworks/knotifications-${PVCUT}*:5
+ =kde-frameworks/kpackage-${PVCUT}*:5
+ =kde-frameworks/kservice-${PVCUT}*:5
+ =kde-frameworks/kwidgetsaddons-${PVCUT}*:5
+ =kde-frameworks/kwindowsystem-${PVCUT}*:5
+ =kde-frameworks/kxmlgui-${PVCUT}*:5
+ !gles2-only? ( virtual/opengl )
+ wayland? (
+ =kde-frameworks/kwayland-${PVCUT}*:5
+ media-libs/mesa[egl]
+ )
+ X? (
+ >=dev-qt/qtx11extras-${QTMIN}:5
+ x11-libs/libX11
+ x11-libs/libxcb
+ )
+"
+DEPEND="${RDEPEND}
+ X? ( x11-base/xorg-proto )
+"
+
+RESTRICT+=" test"
+
+PATCHES=( "${FILESDIR}"/${P}-fix-pc3-button-icons-color-set.patch )
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package !gles2-only OpenGL)
+ $(cmake_use_find_package wayland EGL)
+ $(cmake_use_find_package wayland KF5Wayland)
+ $(cmake_use_find_package X X11)
+ $(cmake_use_find_package X XCB)
+ )
+
+ ecm_src_configure
+}