summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-09-01 15:19:39 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2024-09-01 15:20:18 +0200
commite97885fc34de2627c8aaa5476122a611342e438a (patch)
tree02edde4bb379dddc5f57de4778d73fdeec1687f7 /kde-frameworks/kquickcharts
parentdev-util/maturin: force shared build & fix tests for musl (diff)
downloadgentoo-e97885fc34de2627c8aaa5476122a611342e438a.tar.gz
gentoo-e97885fc34de2627c8aaa5476122a611342e438a.tar.bz2
gentoo-e97885fc34de2627c8aaa5476122a611342e438a.zip
kde-frameworks/kquickcharts: Drop IUSE examples for 5.116.0
Now that KF6 was stabilised, let's take care of those users enabling USE=examples globally. In this case, simply KF6 based examples trump older KF5 based ones, no special handling worth putting effort into. Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/kquickcharts')
-rw-r--r--kde-frameworks/kquickcharts/kquickcharts-5.116.0-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/kde-frameworks/kquickcharts/kquickcharts-5.116.0-r1.ebuild b/kde-frameworks/kquickcharts/kquickcharts-5.116.0-r1.ebuild
new file mode 100644
index 000000000000..35cb4b987c81
--- /dev/null
+++ b/kde-frameworks/kquickcharts/kquickcharts-5.116.0-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_EXAMPLES="false"
+ECM_QTHELP="false"
+ECM_TEST="true"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.9
+VIRTUALX_REQUIRED="test" # bug 910062 (tests fail)
+inherit ecm frameworks.kde.org
+
+DESCRIPTION="QtQuick plugin providing high-performance charts"
+HOMEPAGE="https://invent.kde.org/frameworks/kquickcharts"
+
+LICENSE="LGPL-2+"
+KEYWORDS="amd64 ~arm arm64 ~loong ~ppc64 ~riscv x86"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_EXAMPLES=OFF
+ )
+
+ ecm_src_configure
+}