summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-03-23 09:10:02 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-03-23 09:11:15 +0100
commite5a1d3770a9f296ecc8069dd42a9f5574ba7731c (patch)
tree98b4afa78258877a2c99fffe6a51f89fe414b4d1 /kde-frameworks/kio
parentsys-firmware/broadcom-bt-firmware: drop myself as a maintainer (diff)
downloadgentoo-e5a1d3770a9f296ecc8069dd42a9f5574ba7731c.tar.gz
gentoo-e5a1d3770a9f296ecc8069dd42a9f5574ba7731c.tar.bz2
gentoo-e5a1d3770a9f296ecc8069dd42a9f5574ba7731c.zip
kde-frameworks/kio: widgets/renamefiledialog: set number limit again
Upstream commit d8e4f575e4967a2303812529a866b89ad2fe26f5 KDE-bug: https://bugs.kde.org/show_bug.cgi?id=466636 Bug: https://bugs.gentoo.org/899706 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/kio')
-rw-r--r--kde-frameworks/kio/files/kio-5.104.0-renamefiledialog-fix-number-limit.patch31
-rw-r--r--kde-frameworks/kio/kio-5.104.0-r1.ebuild91
2 files changed, 122 insertions, 0 deletions
diff --git a/kde-frameworks/kio/files/kio-5.104.0-renamefiledialog-fix-number-limit.patch b/kde-frameworks/kio/files/kio-5.104.0-renamefiledialog-fix-number-limit.patch
new file mode 100644
index 000000000000..dfdf851e065e
--- /dev/null
+++ b/kde-frameworks/kio/files/kio-5.104.0-renamefiledialog-fix-number-limit.patch
@@ -0,0 +1,31 @@
+From d8e4f575e4967a2303812529a866b89ad2fe26f5 Mon Sep 17 00:00:00 2001
+From: Xaver Hugl <xaver.hugl@gmail.com>
+Date: Tue, 7 Mar 2023 23:43:21 +0100
+Subject: [PATCH] widgets/renamefiledialog: set number limit again
+
+Not setting a maximum makes it default to 99, which is not what we want.
+Instead, set it to a billion, which should be enough for everyone
+
+BUG: 466636
+
+
+(cherry picked from commit 04e31155574939dc0be2078b5f17c36791ef57e5)
+---
+ src/widgets/renamefiledialog.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/widgets/renamefiledialog.cpp b/src/widgets/renamefiledialog.cpp
+index ad6eafbaa0..ceb0748755 100644
+--- a/src/widgets/renamefiledialog.cpp
++++ b/src/widgets/renamefiledialog.cpp
+@@ -132,6 +132,7 @@ RenameFileDialog::RenameFileDialog(const KFileItemList &items, QWidget *parent)
+ mainLayout->addWidget(infoLabel);
+ d->spinBox = new QSpinBox(page);
+ d->spinBox->setMinimum(0);
++ d->spinBox->setMaximum(1'000'000'000);
+ d->spinBox->setSingleStep(1);
+ d->spinBox->setValue(1);
+ d->spinBox->setDisplayIntegerBase(10);
+--
+GitLab
+
diff --git a/kde-frameworks/kio/kio-5.104.0-r1.ebuild b/kde-frameworks/kio/kio-5.104.0-r1.ebuild
new file mode 100644
index 000000000000..0a8a61024856
--- /dev/null
+++ b/kde-frameworks/kio/kio-5.104.0-r1.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_DESIGNERPLUGIN="true"
+ECM_TEST="forceoptional"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.5
+VIRTUALX_REQUIRED="test"
+inherit ecm frameworks.kde.org xdg-utils
+
+DESCRIPTION="Framework providing transparent file and data management"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="acl +handbook kerberos +kwallet X"
+
+# tests hang
+RESTRICT="test"
+
+RDEPEND="
+ dev-libs/libxml2
+ dev-libs/libxslt
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5[ssl]
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtxml-${QTMIN}:5
+ =kde-frameworks/kauth-${PVCUT}*:5
+ =kde-frameworks/karchive-${PVCUT}*:5
+ =kde-frameworks/kbookmarks-${PVCUT}*:5
+ =kde-frameworks/kcodecs-${PVCUT}*:5
+ =kde-frameworks/kcompletion-${PVCUT}*:5
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/kconfigwidgets-${PVCUT}*:5
+ =kde-frameworks/kcoreaddons-${PVCUT}*:5
+ =kde-frameworks/kcrash-${PVCUT}*:5
+ =kde-frameworks/kdbusaddons-${PVCUT}*:5
+ =kde-frameworks/kguiaddons-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/kiconthemes-${PVCUT}*:5
+ =kde-frameworks/kitemviews-${PVCUT}*:5
+ =kde-frameworks/kjobwidgets-${PVCUT}*:5
+ =kde-frameworks/knotifications-${PVCUT}*:5
+ =kde-frameworks/kservice-${PVCUT}*:5
+ =kde-frameworks/ktextwidgets-${PVCUT}*:5
+ =kde-frameworks/kwidgetsaddons-${PVCUT}*:5
+ =kde-frameworks/kwindowsystem-${PVCUT}*:5[X?]
+ =kde-frameworks/kxmlgui-${PVCUT}*:5
+ =kde-frameworks/solid-${PVCUT}*:5
+ acl? (
+ sys-apps/attr
+ virtual/acl
+ )
+ handbook? ( =kde-frameworks/kdoctools-${PVCUT}*:5 )
+ kerberos? ( virtual/krb5 )
+ kwallet? ( =kde-frameworks/kwallet-${PVCUT}*:5 )
+ X? ( >=dev-qt/qtx11extras-${QTMIN}:5 )
+"
+DEPEND="${RDEPEND}
+ >=dev-qt/qtconcurrent-${QTMIN}:5
+ test? ( sys-libs/zlib )
+"
+PDEPEND=">=kde-frameworks/kded-${PVCUT}:5"
+
+PATCHES=( "${FILESDIR}/${P}-renamefiledialog-fix-number-limit.patch" ) # KDE-bug 466636
+
+src_configure() {
+ local mycmakeargs=(
+ -DKIO_NO_PUBLIC_QTCONCURRENT=ON
+ $(cmake_use_find_package acl ACL)
+ $(cmake_use_find_package handbook KF5DocTools)
+ $(cmake_use_find_package kerberos GSSAPI)
+ $(cmake_use_find_package kwallet KF5Wallet)
+ -DWITH_X11=$(usex X)
+ )
+
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ ecm_pkg_postinst
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ ecm_pkg_postrm
+ xdg_desktop_database_update
+}