summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-01-31 20:46:18 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2024-02-01 22:17:09 +0100
commitf8da25afef209060258bfc76b2891519c8c79d16 (patch)
tree7b1cb21c49b47507704e08f99ea6f8010bc88a07 /kde-frameworks/ki18n
parentkde-frameworks/kholidays: 5.249.0 version bump (diff)
downloadgentoo-f8da25afef209060258bfc76b2891519c8c79d16.tar.gz
gentoo-f8da25afef209060258bfc76b2891519c8c79d16.tar.bz2
gentoo-f8da25afef209060258bfc76b2891519c8c79d16.zip
kde-frameworks/ki18n: 5.249.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/ki18n')
-rw-r--r--kde-frameworks/ki18n/Manifest1
-rw-r--r--kde-frameworks/ki18n/ki18n-5.249.0.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/kde-frameworks/ki18n/Manifest b/kde-frameworks/ki18n/Manifest
index 69a658ae06ad..12fd55c9a9ea 100644
--- a/kde-frameworks/ki18n/Manifest
+++ b/kde-frameworks/ki18n/Manifest
@@ -1,3 +1,4 @@
DIST ki18n-5.113.0.tar.xz 3128876 BLAKE2B 256f44968501da24cbe2d32d6c7ad68af15ac4592dd926b1ccbb898926994551c0c91b47b3a46b3207c3fe3832bf9baee19f97a1b32bef5bb2d913816d649cee SHA512 91d2f2173a24334d15789ec5b2a80bff627453e4135a9920ddb5e54d4c345cbae386bdad374c651295bc7cfae265bc8d785f1a62ecdbdc8934484fb2573d809f
DIST ki18n-5.114.0.tar.xz 3129684 BLAKE2B 6e71ff4635403f2cea406d4a3af88b3f3838cddcce25818372825c875a38ae0ab3463a91a703155873e8f6bdd4dcb7f1e064bc6abdeb98ee1e516091b1e15fac SHA512 7b6e4a8ce5355bd268815e037f6d8e91fc320edee9b1336010c9c2db5ad7c366ff559389d18aa64fd2b7dcbee5fdc88bf99d3aae35e654d05c9065cabfe52827
DIST ki18n-5.248.0.tar.xz 3124344 BLAKE2B 83d6cd8a03b8f32508f26516f578e42d40b04ac4786df3775840fa8d91298a9f30d5dac6d97d679b7f275813afcbeee85969068cd2a273a24bf3d1d22ce8b734 SHA512 0234d2e36b365a152f4b3f41ec7f355756635ee1e7c62db661ed7760d79911ef23eaaab8b81dff2bd77eb0e398bb82d824dc500354feb9a0d44e973b91e154ab
+DIST ki18n-5.249.0.tar.xz 3125076 BLAKE2B 0aaffc235b21162fbdb98f6c4fbf6f01327d3eaf04b4c24e013a9b060371ab3fc21ffe0f0aae4bcc47b6bcb4a2ccc6d09bb4733b078d1870479611edd1833c1e SHA512 cee7c081f3c9d3a24606e0618ca2a077b1b829353447623778120396e2990167de28fa12a998de9203c473e3350c8e1d37c8a45fabf23a8c147c5119d446b1c6
diff --git a/kde-frameworks/ki18n/ki18n-5.249.0.ebuild b/kde-frameworks/ki18n/ki18n-5.249.0.ebuild
new file mode 100644
index 000000000000..1a6a98ed0357
--- /dev/null
+++ b/kde-frameworks/ki18n/ki18n-5.249.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+QTMIN=6.6.0
+inherit ecm frameworks.kde.org python-single-r1
+
+DESCRIPTION="Framework based on Gettext for internationalizing user interface text"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+COMMON_DEPEND="${PYTHON_DEPS}
+ >=dev-qt/qtdeclarative-${QTMIN}:6
+ sys-devel/gettext
+ virtual/libintl
+"
+DEPEND="${COMMON_DEPEND}
+ test? ( >=dev-qt/qtbase-${QTMIN}:6[concurrent] )
+"
+RDEPEND="${COMMON_DEPEND}
+ app-text/iso-codes
+"
+
+CMAKE_SKIP_TESTS=(
+ # bug 876496
+ kcatalogtest
+ # requires LANG fr_CH. bugs 823816
+ kcountrytest
+ kcountrysubdivisiontest
+)
+
+pkg_setup() {
+ ecm_pkg_setup
+ python-single-r1_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DPython3_EXECUTABLE="${PYTHON}"
+ )
+ ecm_src_configure
+}