summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-07-13 22:46:45 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-07-13 22:50:01 +0200
commitea01d07c76b705e48d8d3a4600856746ce596e95 (patch)
tree11abb713ee2d1cf09ef62389e18dd03cbac691e0 /kde-apps/ktp-text-ui
parentdev-java/hawtjni-runtime: keyword ~arm64 (diff)
downloadgentoo-ea01d07c76b705e48d8d3a4600856746ce596e95.tar.gz
gentoo-ea01d07c76b705e48d8d3a4600856746ce596e95.tar.bz2
gentoo-ea01d07c76b705e48d8d3a4600856746ce596e95.zip
kde-apps: Add KDE Applications 17.04.3
Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'kde-apps/ktp-text-ui')
-rw-r--r--kde-apps/ktp-text-ui/Manifest1
-rw-r--r--kde-apps/ktp-text-ui/ktp-text-ui-17.04.3.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/kde-apps/ktp-text-ui/Manifest b/kde-apps/ktp-text-ui/Manifest
index dbc9486fea29..7db60aaa067a 100644
--- a/kde-apps/ktp-text-ui/Manifest
+++ b/kde-apps/ktp-text-ui/Manifest
@@ -1,2 +1,3 @@
DIST ktp-text-ui-16.12.3.tar.xz 295608 SHA256 33c02e1cb5b9b49ab6fe6bdbeb0ae9baacfd67febc4b7fafbd5762b6cbc85d6b SHA512 a416e70876f1f437fda695f6d66f69264ecd255699e73127b403cdf4294dee09bc1708178b15e988331fdbc555cf9e5bf484b18cf206a3555362eda3148862d9 WHIRLPOOL 1e69279e91181123dddde1f4a2166f17ddc5583b1859e54b1adafb84364646dcff631e622d01dc9363ce1555fa96b69dcd110e41dabedbc68cdf49b9f598970e
DIST ktp-text-ui-17.04.2.tar.xz 466524 SHA256 0a377d89a100d398d401b6ea53c29aa27e33eba78a6fa110f8d4c2181884ade8 SHA512 e794225cd65331ef7bdc177df362269bc20567c4bcc6fd68ab5211e03df15c3b8ada2287868dbf03ecf1ad2c283dd5528227470b730fe0748904f2bd878906ef WHIRLPOOL ba35a21c5799e0988f422618ebd81c2c720db635051a8c5f4fb2ca74270731b7fb98b4c156b8cc7c9e75ba1913f3f9055f88d75971ac4d7f20b231d2ff253e01
+DIST ktp-text-ui-17.04.3.tar.xz 466952 SHA256 c11b69061a2a8ac5d18eb3cd08bd88749e0b0474ada56b61c40d479e3661eabd SHA512 df303292ef51c5749d567a468676721d3dcc147c50f321a1d83a6f1a84df91c617ff07aaf918e81177f7e1fac9cda6ff199dbde46e8d2d92ea3f72e2839e7a9a WHIRLPOOL 06a8b6d7060209595a0d50e96d19f8ebd2ff2aa33ff20e7d8276a6d174612c9fb30a9882284514ca7657b7d2e7079ec2891a816af10135aa1d0d58ee6b926dfb
diff --git a/kde-apps/ktp-text-ui/ktp-text-ui-17.04.3.ebuild b/kde-apps/ktp-text-ui/ktp-text-ui-17.04.3.ebuild
new file mode 100644
index 000000000000..0e5783fbd0c2
--- /dev/null
+++ b/kde-apps/ktp-text-ui/ktp-text-ui-17.04.3.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+QT_MINIMAL="5.7.1"
+inherit kde5
+
+DESCRIPTION="KDE Telepathy text chat window"
+HOMEPAGE="https://community.kde.org/Real-Time_Communication_and_Collaboration"
+
+LICENSE="Apache-2.0 || ( AFL-2.1 BSD ) GPL-2+ LGPL-2.1+ MIT"
+KEYWORDS="~amd64 ~x86"
+IUSE="speech"
+
+DEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep kdewebkit)
+ $(add_frameworks_dep kemoticons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep knotifyconfig)
+ $(add_frameworks_dep kpeople)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep sonnet)
+ $(add_kdeapps_dep ktp-common-internals otr)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwebengine 'widgets')
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ net-libs/telepathy-qt[qt5]
+ speech? ( $(add_qt_dep qtspeech) )
+"
+RDEPEND="${DEPEND}
+ $(add_kdeapps_dep ktp-contact-list)
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package speech Qt5TextToSpeech)
+ )
+
+ kde5_src_configure
+}