summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-06-06 16:04:23 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-06-06 17:06:07 +0200
commit8ea97068f86f7c38eb7eba7b4834d24395ea63c8 (patch)
tree1a99302b57a044d70ab6ffc235920f12cd030996 /kde-apps/kolourpaint
parentdev-texlive/texlive-luatex: Add more blockers (diff)
downloadgentoo-8ea97068f86f7c38eb7eba7b4834d24395ea63c8.tar.gz
gentoo-8ea97068f86f7c38eb7eba7b4834d24395ea63c8.tar.bz2
gentoo-8ea97068f86f7c38eb7eba7b4834d24395ea63c8.zip
kde-apps: Add KDE Applications 19.04.2
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org> Package-Manager: Portage-2.3.66, Repoman-2.3.11
Diffstat (limited to 'kde-apps/kolourpaint')
-rw-r--r--kde-apps/kolourpaint/Manifest1
-rw-r--r--kde-apps/kolourpaint/kolourpaint-19.04.2.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/kde-apps/kolourpaint/Manifest b/kde-apps/kolourpaint/Manifest
index 6618aa38719e..8927bd69c17b 100644
--- a/kde-apps/kolourpaint/Manifest
+++ b/kde-apps/kolourpaint/Manifest
@@ -1,2 +1,3 @@
DIST kolourpaint-18.12.3.tar.xz 5651092 BLAKE2B 11a7dc906d0240524944d4aa4d61087f2b0689658dc8903eaddf38a3a1a052d19949cf550ed7f117f60892bc382b5cb251107db5d3acdda7bf019b912c71db13 SHA512 ac294aa80ffebdc6440474c15c5450fdcf15d735e6d920e2af99c92cbaa5f8930330a268faea5fb7859d1128c7479049ceb672715d7a4dbfdfb7e3b72157af13
DIST kolourpaint-19.04.1.tar.xz 5653060 BLAKE2B f41f7aae13b818d7d802943c6e50e9cf7fd618831a1ecac3833a8ab4e18a4c3bccf0094a2c09381607fc870fe03c1f5ecfae455a86547b98005da321e5d145f9 SHA512 2154a250683744cd566b3835b68d5f4d16c6b2b7ac747d1bd8fd1de41ebee64c5c972a799d06e1b88768d789393d7f7509428584b29d78923e2275a92de56b9f
+DIST kolourpaint-19.04.2.tar.xz 5652400 BLAKE2B 2248ff0491560aa1028e6626896483f77faa63eb4f2e5081b836329f9b6ce24bba4c4bb1c8f6724d43c9db49f87222e7d1126270fa858847c7d545079cfe30fd SHA512 3a0b497003de467c19898682e1f0d76014ec9e68506271492fc8f30e9b9f08fa8639267c1fa84b18dde3d807d81e3db791764a6a43ac8cd7ca7d53b871410baa
diff --git a/kde-apps/kolourpaint/kolourpaint-19.04.2.ebuild b/kde-apps/kolourpaint/kolourpaint-19.04.2.ebuild
new file mode 100644
index 000000000000..d36c8c7865a0
--- /dev/null
+++ b/kde-apps/kolourpaint/kolourpaint-19.04.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_HANDBOOK="forceoptional"
+inherit kde5
+
+DESCRIPTION="Paint Program by KDE"
+HOMEPAGE="https://kde.org/applications/graphics/kolourpaint/"
+LICENSE="BSD-2 LGPL-2 LGPL-2+ || ( LGPL-2.1 LGPL-3 ) GPL-2 handbook? ( FDL-1.2 )"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="scanner"
+
+DEPEND="
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdelibs4support)
+ $(add_frameworks_dep kguiaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtprintsupport)
+ $(add_qt_dep qtwidgets)
+ scanner? ( $(add_kdeapps_dep libksane) )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package scanner KF5Sane)
+ )
+
+ kde5_src_configure
+}