summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-08-17 20:21:16 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-08-17 20:58:09 +0200
commitc1063afea17a29bb75dbbbf0121fa5c8ad948574 (patch)
treec62ccf9ec787742c39c2afd14ac1198894802629 /kde-apps/kig
parentmedia-libs/libqaccessibilityclient: New package (diff)
downloadgentoo-c1063afea17a29bb75dbbbf0121fa5c8ad948574.tar.gz
gentoo-c1063afea17a29bb75dbbbf0121fa5c8ad948574.tar.bz2
gentoo-c1063afea17a29bb75dbbbf0121fa5c8ad948574.zip
kde-apps: Add KDE Applications 17.08.0
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'kde-apps/kig')
-rw-r--r--kde-apps/kig/Manifest1
-rw-r--r--kde-apps/kig/kig-17.08.0.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/kde-apps/kig/Manifest b/kde-apps/kig/Manifest
index cd710050deb3..c175b3ed9ea2 100644
--- a/kde-apps/kig/Manifest
+++ b/kde-apps/kig/Manifest
@@ -1 +1,2 @@
DIST kig-17.04.3.tar.xz 3588428 SHA256 8dae8af9d49c491efedb32e74d1a1123ac91fefdaf6b011592124497d2021ce5 SHA512 0f38450c5f48a60cd47862dd020ee753fca3f3c0ba4758e5973656dac14e96283943c644cd639df36f2f35bf3ed46c49952e14f337991a59e394479ea44c9e22 WHIRLPOOL b3a35360c05e0c46eb52fea0a2e72978c3464a2d53d5076cce51f5b2adafa7efdfa4bebb49cfd33f2039488e9a82a07d5f9db2652ab1c55fcd975dfc2d578bc7
+DIST kig-17.08.0.tar.xz 3588056 SHA256 ab3a3abcc399ee38b210bc2d3eb0e1faf4ab367a5a5faac6d8f82e4e1f20fcb8 SHA512 5421bcd2171999db8eecec33bd72b131300e79c05412b1aa459d82fd349f9fa636252d33e14051f52504e7acbccb5de996e7adb68df1ec88f4cffa9e32828980 WHIRLPOOL fcc8ba79fbc5e1431efdcfff820aaaffe46f6c29b98d2441da5e114e8d1ce33768c151a1c9aaba7ca68bbb8cf9af6a118388687fc8ad2721e0f49ca004059fe8
diff --git a/kde-apps/kig/kig-17.08.0.ebuild b/kde-apps/kig/kig-17.08.0.ebuild
new file mode 100644
index 000000000000..c28dbdb68ab7
--- /dev/null
+++ b/kde-apps/kig/kig-17.08.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="forceoptional"
+KDE_TEST="optional"
+PYTHON_COMPAT=( python2_7 )
+inherit python-single-r1 kde5
+
+DESCRIPTION="KDE Interactive Geometry tool"
+HOMEPAGE="https://www.kde.org/applications/education/kig https://edu.kde.org/kig"
+KEYWORDS="~amd64 ~x86"
+IUSE="geogebra scripting"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtprintsupport)
+ $(add_qt_dep qtsvg)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ geogebra? ( $(add_qt_dep qtxmlpatterns) )
+ scripting? ( >=dev-libs/boost-1.48:=[python,${PYTHON_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ $(add_frameworks_dep ktexteditor)
+"
+
+PATCHES=( "${FILESDIR}/${PN}-4.12.0-boostpython.patch" )
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+ kde5_pkg_setup
+}
+
+src_prepare() {
+ kde5_src_prepare
+ python_fix_shebang .
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package geogebra Qt5XmlPatterns)
+ $(cmake-utils_use_find_package scripting BoostPython)
+ )
+
+ kde5_src_configure
+}