summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2016-12-16 19:38:26 +0100
committerJohannes Huber <johu@gentoo.org>2016-12-16 19:38:38 +0100
commit31645664f42a588800ba68febd89a9c9e6afc76f (patch)
treeccc391e5d2b2b2255adcafe060246a5ddf9a3396 /kde-apps/kajongg/kajongg-16.12.0.ebuild
parentprofiles: Update masks for KDE Applications 16.12 (diff)
downloadgentoo-31645664f42a588800ba68febd89a9c9e6afc76f.tar.gz
gentoo-31645664f42a588800ba68febd89a9c9e6afc76f.tar.bz2
gentoo-31645664f42a588800ba68febd89a9c9e6afc76f.zip
kde-apps: Version bump KDE Applications 16.12.0
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'kde-apps/kajongg/kajongg-16.12.0.ebuild')
-rw-r--r--kde-apps/kajongg/kajongg-16.12.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/kde-apps/kajongg/kajongg-16.12.0.ebuild b/kde-apps/kajongg/kajongg-16.12.0.ebuild
new file mode 100644
index 000000000000..0d77cad41f0e
--- /dev/null
+++ b/kde-apps/kajongg/kajongg-16.12.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+KDE_HANDBOOK="optional"
+PYTHON_COMPAT=( python2_7 )
+inherit python-single-r1 kde4-base
+
+DESCRIPTION="The classical Mah Jongg for four players"
+HOMEPAGE="https://www.kde.org/applications/games/kajongg/"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="debug"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ $(add_kdeapps_dep libkdegames)
+ $(add_kdebase_dep pykde4 "${PYTHON_USEDEP}")
+ dev-db/sqlite:3
+"
+RDEPEND="${DEPEND}
+ $(add_kdeapps_dep libkmahjongg)
+ >=dev-python/twisted-core-8.2.0
+"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+ kde4-base_pkg_setup
+}
+
+src_prepare() {
+ python_fix_shebang src
+ kde4-base_src_prepare
+}