summaryrefslogtreecommitdiff
path: root/gui-wm
diff options
context:
space:
mode:
authorLeonardo Hernández Hernández <leohdz172@proton.me>2024-07-12 16:02:36 -0600
committerArthur Zamarin <arthurzam@gentoo.org>2024-07-13 09:01:07 +0300
commite1c1cb8e80e977965fa114253eb658cf991e2335 (patch)
tree81f836940f07078aa22b2fbda69fa9cbfd72d7cd /gui-wm
parentgui-libs/wlroots: update SLOT in live ebuild (diff)
downloadgentoo-e1c1cb8e80e977965fa114253eb658cf991e2335.tar.gz
gentoo-e1c1cb8e80e977965fa114253eb658cf991e2335.tar.bz2
gentoo-e1c1cb8e80e977965fa114253eb658cf991e2335.zip
gui-wm/tinywl: add 0.18.0
Signed-off-by: Leonardo Hernández Hernández <leohdz172@proton.me> Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'gui-wm')
-rw-r--r--gui-wm/tinywl/Manifest1
-rw-r--r--gui-wm/tinywl/tinywl-0.18.0.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/gui-wm/tinywl/Manifest b/gui-wm/tinywl/Manifest
index daac1f27af5b..c32ee2b42159 100644
--- a/gui-wm/tinywl/Manifest
+++ b/gui-wm/tinywl/Manifest
@@ -1,2 +1,3 @@
DIST wlroots-0.17.3.tar.gz 608292 BLAKE2B 7caab3c3a58595d3a745c0b20a5db2193c54931cdd7bc1b9de11c151af82503a03a6a3166a86f42486cc69c6ac18ca2a5596809a5c5e6d7b44c9845f509c1093 SHA512 b88747daba304db6dc302acdebb8764e719d84134118963c019d5f0d0d38552e0ffd2a50bf560b3b84549c5a0f2d11a6187ac8ddcd9faa28c5b42f86c585b555
DIST wlroots-0.17.4.tar.gz 609179 BLAKE2B dc5a7749533ab54631d4a26be554b86e5b08b2472cf8f22ccebddb319d571cbd98a5c56e64e7bc762a5918d4272eb6b4261050288f3053c18c824c6a9c32b96b SHA512 35803df9fe68cadb0b9b5e522863535407ba2354ed1ca8f824a9c40b64698a97c579fec0afeb444b05d429adc1e3dfc45b20c3a1b7a2004e4f5a10d2305c9116
+DIST wlroots-0.18.0.tar.gz 628190 BLAKE2B b1d725e0397365b69afce24baf5376057a40d225f7cb06ccd5abde3b3da8d5401a6eb5d57ab65154a6faf7961473039833e558e3b25da1210891d34667da5bf9 SHA512 2cf848aa67f41089b60cc7d01c3a344ebaf7f5bbced459675fef885cd4b3e6b99d9a49d6b127518314d0ae38e52e9aff7991611592b2add4cba96f15aa0bf1c6
diff --git a/gui-wm/tinywl/tinywl-0.18.0.ebuild b/gui-wm/tinywl/tinywl-0.18.0.ebuild
new file mode 100644
index 000000000000..4a3e6ee077c2
--- /dev/null
+++ b/gui-wm/tinywl/tinywl-0.18.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="\"minimum viable product\" Wayland compositor based on wlroots"
+HOMEPAGE="https://gitlab.freedesktop.org/wlroots/wlroots"
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/wlroots/wlroots.git"
+ inherit git-r3
+else
+ SRC_URI="https://gitlab.freedesktop.org/wlroots/wlroots/-/releases/${PV}/downloads/wlroots-${PV}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~loong ~ppc64 ~riscv ~x86"
+ S="${WORKDIR}/wlroots-${PV}"
+fi
+
+LICENSE="CC0-1.0"
+SLOT="0"
+DEPEND="
+ dev-libs/wayland
+ x11-libs/libxkbcommon
+ =gui-libs/wlroots-$(ver_cut 1-2)*:=
+"
+RDEPEND="
+ ${DEPEND}
+ !gui-libs/wlroots[tinywl(-)]
+"
+BDEPEND="
+ dev-libs/wayland-protocols
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ sed -i -e "s/-Werror //" tinywl/Makefile || die
+ default
+}
+
+src_compile() {
+ emake -C tinywl
+}
+
+src_install() {
+ dodoc tinywl/README.md
+ dobin tinywl/tinywl
+}