summaryrefslogtreecommitdiff
path: root/gui-wm
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-12-11 12:23:19 +0100
committerMichał Górny <mgorny@gentoo.org>2024-12-11 12:53:18 +0100
commit3ee411f1324ad2b881555d1bec5f943f1a7f28a1 (patch)
tree6f41e60778fca61521342418fc05d60e95f9ae44 /gui-wm
parentRename {sys-devel → llvm-core}/clang-common (diff)
downloadgentoo-3ee411f1324ad2b881555d1bec5f943f1a7f28a1.tar.gz
gentoo-3ee411f1324ad2b881555d1bec5f943f1a7f28a1.tar.bz2
gentoo-3ee411f1324ad2b881555d1bec5f943f1a7f28a1.zip
Move {sys-devel → llvm-core}/clang
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'gui-wm')
-rw-r--r--gui-wm/hyprland/hyprland-0.42.0-r1.ebuild6
-rw-r--r--gui-wm/hyprland/hyprland-0.42.0-r2.ebuild6
-rw-r--r--gui-wm/hyprland/hyprland-0.44.1.ebuild6
-rw-r--r--gui-wm/hyprland/hyprland-0.45.0.ebuild6
-rw-r--r--gui-wm/hyprland/hyprland-0.45.1.ebuild6
-rw-r--r--gui-wm/hyprland/hyprland-0.45.2.ebuild6
-rw-r--r--gui-wm/hyprland/hyprland-9999.ebuild6
7 files changed, 21 insertions, 21 deletions
diff --git a/gui-wm/hyprland/hyprland-0.42.0-r1.ebuild b/gui-wm/hyprland/hyprland-0.42.0-r1.ebuild
index 5d99847819ad..4872d19c8966 100644
--- a/gui-wm/hyprland/hyprland-0.42.0-r1.ebuild
+++ b/gui-wm/hyprland/hyprland-0.42.0-r1.ebuild
@@ -62,7 +62,7 @@ DEPEND="
>=gui-libs/hyprutils-0.2.1
"
BDEPEND="
- || ( >=sys-devel/gcc-13:* >=sys-devel/clang-16:* )
+ || ( >=sys-devel/gcc-13:* >=llvm-core/clang-16:* )
app-misc/jq
dev-build/cmake
>=dev-util/hyprwayland-scanner-0.3.8
@@ -77,8 +77,8 @@ pkg_setup() {
eerror "Please upgrade GCC: emerge -v1 sys-devel/gcc"
die "GCC version is too old to compile Hyprland!"
elif tc-is-clang && ver_test $(clang-version) -lt 16 ; then
- eerror "Hyprland requires >=sys-devel/clang-16 to build"
- eerror "Please upgrade Clang: emerge -v1 sys-devel/clang"
+ eerror "Hyprland requires >=llvm-core/clang-16 to build"
+ eerror "Please upgrade Clang: emerge -v1 llvm-core/clang"
die "Clang version is too old to compile Hyprland!"
fi
}
diff --git a/gui-wm/hyprland/hyprland-0.42.0-r2.ebuild b/gui-wm/hyprland/hyprland-0.42.0-r2.ebuild
index 80b20b8987e8..d5bca569354e 100644
--- a/gui-wm/hyprland/hyprland-0.42.0-r2.ebuild
+++ b/gui-wm/hyprland/hyprland-0.42.0-r2.ebuild
@@ -62,7 +62,7 @@ DEPEND="
>=gui-libs/hyprutils-0.2.1
"
BDEPEND="
- || ( >=sys-devel/gcc-13:* >=sys-devel/clang-16:* )
+ || ( >=sys-devel/gcc-13:* >=llvm-core/clang-16:* )
app-misc/jq
dev-build/cmake
>=dev-util/hyprwayland-scanner-0.3.8
@@ -81,8 +81,8 @@ pkg_setup() {
eerror "Please upgrade GCC: emerge -v1 sys-devel/gcc"
die "GCC version is too old to compile Hyprland!"
elif tc-is-clang && ver_test $(clang-version) -lt 16 ; then
- eerror "Hyprland requires >=sys-devel/clang-16 to build"
- eerror "Please upgrade Clang: emerge -v1 sys-devel/clang"
+ eerror "Hyprland requires >=llvm-core/clang-16 to build"
+ eerror "Please upgrade Clang: emerge -v1 llvm-core/clang"
die "Clang version is too old to compile Hyprland!"
fi
}
diff --git a/gui-wm/hyprland/hyprland-0.44.1.ebuild b/gui-wm/hyprland/hyprland-0.44.1.ebuild
index cab0caee888f..43fde5978f27 100644
--- a/gui-wm/hyprland/hyprland-0.44.1.ebuild
+++ b/gui-wm/hyprland/hyprland-0.44.1.ebuild
@@ -62,7 +62,7 @@ DEPEND="
>=gui-libs/hyprutils-0.2.3
"
BDEPEND="
- || ( >=sys-devel/gcc-14:* >=sys-devel/clang-18:* )
+ || ( >=sys-devel/gcc-14:* >=llvm-core/clang-18:* )
app-misc/jq
dev-build/cmake
>=dev-util/hyprwayland-scanner-0.3.10
@@ -77,8 +77,8 @@ pkg_setup() {
eerror "Please upgrade GCC: emerge -v1 sys-devel/gcc"
die "GCC version is too old to compile Hyprland!"
elif tc-is-clang && ver_test $(clang-version) -lt 18 ; then
- eerror "Hyprland requires >=sys-devel/clang-18 to build"
- eerror "Please upgrade Clang: emerge -v1 sys-devel/clang"
+ eerror "Hyprland requires >=llvm-core/clang-18 to build"
+ eerror "Please upgrade Clang: emerge -v1 llvm-core/clang"
die "Clang version is too old to compile Hyprland!"
fi
}
diff --git a/gui-wm/hyprland/hyprland-0.45.0.ebuild b/gui-wm/hyprland/hyprland-0.45.0.ebuild
index cab0caee888f..43fde5978f27 100644
--- a/gui-wm/hyprland/hyprland-0.45.0.ebuild
+++ b/gui-wm/hyprland/hyprland-0.45.0.ebuild
@@ -62,7 +62,7 @@ DEPEND="
>=gui-libs/hyprutils-0.2.3
"
BDEPEND="
- || ( >=sys-devel/gcc-14:* >=sys-devel/clang-18:* )
+ || ( >=sys-devel/gcc-14:* >=llvm-core/clang-18:* )
app-misc/jq
dev-build/cmake
>=dev-util/hyprwayland-scanner-0.3.10
@@ -77,8 +77,8 @@ pkg_setup() {
eerror "Please upgrade GCC: emerge -v1 sys-devel/gcc"
die "GCC version is too old to compile Hyprland!"
elif tc-is-clang && ver_test $(clang-version) -lt 18 ; then
- eerror "Hyprland requires >=sys-devel/clang-18 to build"
- eerror "Please upgrade Clang: emerge -v1 sys-devel/clang"
+ eerror "Hyprland requires >=llvm-core/clang-18 to build"
+ eerror "Please upgrade Clang: emerge -v1 llvm-core/clang"
die "Clang version is too old to compile Hyprland!"
fi
}
diff --git a/gui-wm/hyprland/hyprland-0.45.1.ebuild b/gui-wm/hyprland/hyprland-0.45.1.ebuild
index cab0caee888f..43fde5978f27 100644
--- a/gui-wm/hyprland/hyprland-0.45.1.ebuild
+++ b/gui-wm/hyprland/hyprland-0.45.1.ebuild
@@ -62,7 +62,7 @@ DEPEND="
>=gui-libs/hyprutils-0.2.3
"
BDEPEND="
- || ( >=sys-devel/gcc-14:* >=sys-devel/clang-18:* )
+ || ( >=sys-devel/gcc-14:* >=llvm-core/clang-18:* )
app-misc/jq
dev-build/cmake
>=dev-util/hyprwayland-scanner-0.3.10
@@ -77,8 +77,8 @@ pkg_setup() {
eerror "Please upgrade GCC: emerge -v1 sys-devel/gcc"
die "GCC version is too old to compile Hyprland!"
elif tc-is-clang && ver_test $(clang-version) -lt 18 ; then
- eerror "Hyprland requires >=sys-devel/clang-18 to build"
- eerror "Please upgrade Clang: emerge -v1 sys-devel/clang"
+ eerror "Hyprland requires >=llvm-core/clang-18 to build"
+ eerror "Please upgrade Clang: emerge -v1 llvm-core/clang"
die "Clang version is too old to compile Hyprland!"
fi
}
diff --git a/gui-wm/hyprland/hyprland-0.45.2.ebuild b/gui-wm/hyprland/hyprland-0.45.2.ebuild
index cab0caee888f..43fde5978f27 100644
--- a/gui-wm/hyprland/hyprland-0.45.2.ebuild
+++ b/gui-wm/hyprland/hyprland-0.45.2.ebuild
@@ -62,7 +62,7 @@ DEPEND="
>=gui-libs/hyprutils-0.2.3
"
BDEPEND="
- || ( >=sys-devel/gcc-14:* >=sys-devel/clang-18:* )
+ || ( >=sys-devel/gcc-14:* >=llvm-core/clang-18:* )
app-misc/jq
dev-build/cmake
>=dev-util/hyprwayland-scanner-0.3.10
@@ -77,8 +77,8 @@ pkg_setup() {
eerror "Please upgrade GCC: emerge -v1 sys-devel/gcc"
die "GCC version is too old to compile Hyprland!"
elif tc-is-clang && ver_test $(clang-version) -lt 18 ; then
- eerror "Hyprland requires >=sys-devel/clang-18 to build"
- eerror "Please upgrade Clang: emerge -v1 sys-devel/clang"
+ eerror "Hyprland requires >=llvm-core/clang-18 to build"
+ eerror "Please upgrade Clang: emerge -v1 llvm-core/clang"
die "Clang version is too old to compile Hyprland!"
fi
}
diff --git a/gui-wm/hyprland/hyprland-9999.ebuild b/gui-wm/hyprland/hyprland-9999.ebuild
index 81ad1724da92..5bef96e81cf9 100644
--- a/gui-wm/hyprland/hyprland-9999.ebuild
+++ b/gui-wm/hyprland/hyprland-9999.ebuild
@@ -62,7 +62,7 @@ DEPEND="
>=gui-libs/hyprutils-0.2.3
"
BDEPEND="
- || ( >=sys-devel/gcc-14:* >=sys-devel/clang-18:* )
+ || ( >=sys-devel/gcc-14:* >=llvm-core/clang-18:* )
app-misc/jq
dev-build/cmake
>=dev-util/hyprwayland-scanner-0.3.10
@@ -77,8 +77,8 @@ pkg_setup() {
eerror "Please upgrade GCC: emerge -v1 sys-devel/gcc"
die "GCC version is too old to compile Hyprland!"
elif tc-is-clang && ver_test $(clang-version) -lt 18 ; then
- eerror "Hyprland requires >=sys-devel/clang-18 to build"
- eerror "Please upgrade Clang: emerge -v1 sys-devel/clang"
+ eerror "Hyprland requires >=llvm-core/clang-18 to build"
+ eerror "Please upgrade Clang: emerge -v1 llvm-core/clang"
die "Clang version is too old to compile Hyprland!"
fi
}