summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2023-05-30 09:18:19 -0300
committerMatt Turner <mattst88@gentoo.org>2023-05-30 11:51:32 -0400
commit5ac93ce884220f237d47f5fb40c7148bd44f96be (patch)
tree88c6b0198cc8573e892eac4ca48a25b3381c5abd /gnome-extra
parentsys-kernel/gentoo-kernel-bin: Bump to 5.10.181 (diff)
downloadgentoo-5ac93ce884220f237d47f5fb40c7148bd44f96be.tar.gz
gentoo-5ac93ce884220f237d47f5fb40c7148bd44f96be.tar.bz2
gentoo-5ac93ce884220f237d47f5fb40c7148bd44f96be.zip
gnome-extra/sushi: Version bump to 44.2
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/31228 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/sushi/Manifest1
-rw-r--r--gnome-extra/sushi/sushi-44.2.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/gnome-extra/sushi/Manifest b/gnome-extra/sushi/Manifest
index 80db1195e0a1..9fc23c622888 100644
--- a/gnome-extra/sushi/Manifest
+++ b/gnome-extra/sushi/Manifest
@@ -1 +1,2 @@
DIST sushi-43.0.tar.xz 81552 BLAKE2B 13ca7ec446aeaae454bb0a8c874a786914211a9b27d423189846aba9adb844b224a7f0cb6d95b2e6c4d71043a2b592d14ce9998a9732150517aa18b14b4f2c25 SHA512 0a909f685e49bbddb7fc2cf17338eba08723a796e1e42f09ed404487620437b36c2bdaede3efbb6bd49cd7efde0141e971ac9869f73c0c30bea9b6658978b19e
+DIST sushi-44.2.tar.xz 82236 BLAKE2B 144b2a068c0ed81e49236ed2f43125ec9df8eb853dac6d49e55c56d489f6dd41e1704b3e22996bd80bcbda07f0843a831bdbd8296606a9688376bf7fc6140406 SHA512 0e2cd6e619872e7ebd29b01bf6038b3db7f8202f20a77034451e69b722e46ee9f8e20378253f49ccb12b6060490c25555581f10823c778c42ab9edf41016a1da
diff --git a/gnome-extra/sushi/sushi-44.2.ebuild b/gnome-extra/sushi/sushi-44.2.ebuild
new file mode 100644
index 000000000000..1727de732e1c
--- /dev/null
+++ b/gnome-extra/sushi/sushi-44.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit gnome.org meson optfeature xdg
+
+DESCRIPTION="A quick previewer for Nautilus, the GNOME file manager"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/sushi"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~sparc ~x86"
+IUSE="wayland +X"
+REQUIRED_USE="|| ( wayland X )"
+
+DEPEND="
+ media-libs/libepoxy
+ >=app-text/evince-3.0[introspection]
+ media-libs/freetype:2
+ >=x11-libs/gdk-pixbuf-2.23.0[introspection]
+ >=dev-libs/glib-2.29.14:2
+ media-libs/gstreamer:1.0[introspection]
+ media-libs/gst-plugins-base:1.0[introspection]
+ >=x11-libs/gtk+-3.13.2:3[introspection,wayland?,X?]
+ >=x11-libs/gtksourceview-4.0.3:4[introspection]
+ >=media-libs/harfbuzz-0.9.9:=
+ >=dev-libs/gobject-introspection-1.54:=
+ net-libs/webkit-gtk:4.1[introspection]
+ >=dev-libs/gjs-1.40
+"
+RDEPEND="${DEPEND}
+ >=gnome-base/nautilus-3.1.90
+ media-plugins/gst-plugins-gtk:1.0[wayland?,X?]
+"
+BDEPEND="
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature wayland)
+ $(meson_feature X X11)
+ )
+ meson_src_configure
+}
+
+src_compile() {
+ local -x GST_PLUGIN_SYSTEM_PATH_1_0=
+ meson_src_compile
+}
+
+pkg_postinst() {
+ optfeature "Support viewing file formats such as generated by LibreOffice" app-office/libreoffice app-office/libreoffice-bin
+}