summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-03-24 20:43:13 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-03-24 20:45:36 -0400
commit7ac919e7c9d468ae5c32ab4ba259e5da86da4335 (patch)
tree66f70392e65dd9731159721bcb2f29b4d4122151 /games-util
parentapp-i18n/ibus: add 1.5.28 (diff)
downloadgentoo-7ac919e7c9d468ae5c32ab4ba259e5da86da4335.tar.gz
gentoo-7ac919e7c9d468ae5c32ab4ba259e5da86da4335.tar.bz2
gentoo-7ac919e7c9d468ae5c32ab4ba259e5da86da4335.zip
games-util/libstrangle: fix build with gcc13
Just a quick downstream fix, upstream hasn't shown activity in a year. Closes: https://bugs.gentoo.org/899038 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-util')
-rw-r--r--games-util/libstrangle/files/libstrangle-0.1.1_p20220222-gcc13.patch7
-rw-r--r--games-util/libstrangle/libstrangle-0.1.1_p20220222-r1.ebuild6
2 files changed, 12 insertions, 1 deletions
diff --git a/games-util/libstrangle/files/libstrangle-0.1.1_p20220222-gcc13.patch b/games-util/libstrangle/files/libstrangle-0.1.1_p20220222-gcc13.patch
new file mode 100644
index 000000000000..03fc215b2e46
--- /dev/null
+++ b/games-util/libstrangle/files/libstrangle-0.1.1_p20220222-gcc13.patch
@@ -0,0 +1,7 @@
+https://bugs.gentoo.org/899038
+--- a/src/vulkan/overlay.cpp
++++ b/src/vulkan/overlay.cpp
+@@ -28,2 +28,3 @@
+
++#include <cstdio>
+ #include <mutex>
diff --git a/games-util/libstrangle/libstrangle-0.1.1_p20220222-r1.ebuild b/games-util/libstrangle/libstrangle-0.1.1_p20220222-r1.ebuild
index 7424fd24e64a..6c2922519587 100644
--- a/games-util/libstrangle/libstrangle-0.1.1_p20220222-r1.ebuild
+++ b/games-util/libstrangle/libstrangle-0.1.1_p20220222-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2022 Gentoo Authors
+# Copyright 2022-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -33,6 +33,10 @@ DEPEND="
QA_SONAME="usr/lib.*/libstrangle.*" # intended for dlopen()
+PATCHES=(
+ "${FILESDIR}"/${P}-gcc13.patch
+)
+
src_prepare() {
default