summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-10-27 07:44:50 -0400
committerIonen Wolkens <ionen@gentoo.org>2021-10-27 09:25:39 -0400
commit33c9ee82b146a03aeb5d1a14addc6a28ef8fa2cc (patch)
treec67df844cf2ddbfbc50b720fab9373701cd34a67 /games-strategy
parentsys-kernel/gentoo-sources: Linux bumps and genpatches (diff)
downloadgentoo-33c9ee82b146a03aeb5d1a14addc6a28ef8fa2cc.tar.gz
gentoo-33c9ee82b146a03aeb5d1a14addc6a28ef8fa2cc.tar.bz2
gentoo-33c9ee82b146a03aeb5d1a14addc6a28ef8fa2cc.zip
games-strategy/wesnoth: add missing dep on boost[bzip2,context]
[context] wrt bug #820470 is newly needed for server. However, it still failed due to the coroutine removal seds. It's /possible/ to skip these with non-server but feels messy. Remove them and unconditionally depend on [context] as upstream is expecting and possibly avoid future issues. May be older, but lacking [bzip2] also happened to cause failure. Side-adjusted /run rmdir to avoid a QA warning. Likely other small issues, did not do a thorough revision. Closes: https://bugs.gentoo.org/820470 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/wesnoth/wesnoth-1.16.0-r1.ebuild (renamed from games-strategy/wesnoth/wesnoth-1.16.0.ebuild)6
1 files changed, 2 insertions, 4 deletions
diff --git a/games-strategy/wesnoth/wesnoth-1.16.0.ebuild b/games-strategy/wesnoth/wesnoth-1.16.0-r1.ebuild
index c9a69554f398..0d53e174d56e 100644
--- a/games-strategy/wesnoth/wesnoth-1.16.0.ebuild
+++ b/games-strategy/wesnoth/wesnoth-1.16.0-r1.ebuild
@@ -21,7 +21,7 @@ IUSE="dbus dedicated doc nls server"
RDEPEND="
acct-group/wesnoth
acct-user/wesnoth
- >=dev-libs/boost-1.50:=[nls,threads(+),icu]
+ dev-libs/boost:=[bzip2,context,icu,nls,threads(+)]
>=media-libs/libsdl2-2.0.4:0[joystick,video,X]
!dedicated? (
dev-libs/glib:2
@@ -46,8 +46,6 @@ BDEPEND="
src_prepare() {
cmake_src_prepare
- sed 's@ coroutine@@' -i CMakeLists.txt || die
- sed '/Boost::coroutine/d' -i src/CMakeLists.txt || die
if ! use doc ; then
sed -i \
-e '/manual/d' \
@@ -100,7 +98,7 @@ src_install() {
local DOCS=( README.md changelog.md )
cmake_src_install
if use dedicated || use server; then
- rmdir "${ED}/run/wesnothd" || die
+ rmdir "${ED}"/run{/wesnothd,} || die
newinitd "${FILESDIR}"/wesnothd.rc-r1 wesnothd
fi
}