summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-09-29 11:28:45 +0100
committerSam James <sam@gentoo.org>2023-09-29 11:32:12 +0100
commit00d2214015bff5efde48539aafe99955c4a0cc2e (patch)
tree60939ccc47bfd9e265f2ad6cd36fa1801b231f0e /games-rpg
parentmedia-video/gpac: drop patch for newer zlib (diff)
downloadgentoo-00d2214015bff5efde48539aafe99955c4a0cc2e.tar.gz
gentoo-00d2214015bff5efde48539aafe99955c4a0cc2e.tar.bz2
gentoo-00d2214015bff5efde48539aafe99955c4a0cc2e.zip
games-rpg/xu4: drop patch for newer zlib
See 491bf8bd3ef621da49b168736a04f23aa4c7719c. Could do ifndef in patch but I'd like to remove all of these eventually and there's only a handful. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-rpg')
-rw-r--r--games-rpg/xu4/xu4-0.9-r1.ebuild16
1 files changed, 9 insertions, 7 deletions
diff --git a/games-rpg/xu4/xu4-0.9-r1.ebuild b/games-rpg/xu4/xu4-0.9-r1.ebuild
index 744dd0e7d8cd..c0e6e3552f38 100644
--- a/games-rpg/xu4/xu4-0.9-r1.ebuild
+++ b/games-rpg/xu4/xu4-0.9-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -22,6 +22,12 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/u4
+PATCHES=(
+ "${FILESDIR}/${P}-ldflags.patch"
+ "${FILESDIR}/${PV}-savegame.patch"
+ "${FILESDIR}/${P}-warnings.patch"
+)
+
src_unpack() {
# xu4 will read the data files right out of the zip files
# but we want the docs from the original.
@@ -34,12 +40,6 @@ src_unpack() {
unzip -q ../ultima4.zip || die
}
-PATCHES=(
- "${FILESDIR}/${P}-ldflags.patch"
- "${FILESDIR}/${PV}-savegame.patch"
- "${FILESDIR}/${P}-warnings.patch"
- "${FILESDIR}/${P}-zip.patch"
-)
src_prepare() {
default
@@ -49,6 +49,8 @@ src_prepare() {
sed -i \
-e 's:-Wall:$(E_CFLAGS):' src/Makefile \
|| die
+
+ has_version "<sys-libs/zlib-1.3" && eapply "${FILESDIR}/${P}-zip.patch"
}
src_compile() {