summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-puzzle/ksokoban
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-puzzle/ksokoban')
-rw-r--r--games-puzzle/ksokoban/Manifest1
-rw-r--r--games-puzzle/ksokoban/ksokoban-0.5.0_pre20120725.ebuild40
-rw-r--r--games-puzzle/ksokoban/ksokoban-9999.ebuild40
-rw-r--r--games-puzzle/ksokoban/metadata.xml7
4 files changed, 88 insertions, 0 deletions
diff --git a/games-puzzle/ksokoban/Manifest b/games-puzzle/ksokoban/Manifest
new file mode 100644
index 000000000000..d5785c0c6cef
--- /dev/null
+++ b/games-puzzle/ksokoban/Manifest
@@ -0,0 +1 @@
+DIST ksokoban-0.5.0_pre20120725.tar.xz 345344 SHA256 fb1c47e37b7d6297960f67377f9bac0deb9c4b132c251c02cdd75d1935bc2b5c SHA512 b7a962a5915bb6f10ecb85dfaae20b009a6c40ba0312e02d12b654e196bdef82159e7f0d6fca17b1befaa1cb17db1a9268822904cdf9bdc8bd1bacf2202b460c WHIRLPOOL 3026b04a4a50da8097a926949ab80e736d0f77f814f437aa87a39c6b5805ab0636cb6dde5a1ab74a76b56ce17b44176bf393c5ffe66e86314b30b77ae9921b4c
diff --git a/games-puzzle/ksokoban/ksokoban-0.5.0_pre20120725.ebuild b/games-puzzle/ksokoban/ksokoban-0.5.0_pre20120725.ebuild
new file mode 100644
index 000000000000..102fe69d4202
--- /dev/null
+++ b/games-puzzle/ksokoban/ksokoban-0.5.0_pre20120725.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+if [[ ${PV} == "9999" ]]; then
+ inherit mercurial
+ EHG_REPO_URI="http://hg.code.sf.net/p/ksokoban/code"
+else
+ SRC_URI="http://dev.gentoo.org/~bircoph/distfiles/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+inherit cmake-utils
+DESCRIPTION="The japanese warehouse keeper game"
+HOMEPAGE="https://sourceforge.net/projects/ksokoban/"
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND="kde-base/kdelibs:4"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+CMAKE_IN_SOURCE_BUILD="yes"
+
+src_prepare() {
+ sed -i 's/%m//' "data/${PN}.desktop" || die "sed for desktop file failed"
+}
+
+# source lacks install target
+src_install() {
+ dobin ksokoban
+ dodoc AUTHORS NEWS TODO
+ domenu "data/${PN}.desktop"
+ for i in 16 22 32 48 64 128; do
+ doicon -s "${i}" "data/hi${i}-app-${PN}.png"
+ done
+}
diff --git a/games-puzzle/ksokoban/ksokoban-9999.ebuild b/games-puzzle/ksokoban/ksokoban-9999.ebuild
new file mode 100644
index 000000000000..102fe69d4202
--- /dev/null
+++ b/games-puzzle/ksokoban/ksokoban-9999.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+if [[ ${PV} == "9999" ]]; then
+ inherit mercurial
+ EHG_REPO_URI="http://hg.code.sf.net/p/ksokoban/code"
+else
+ SRC_URI="http://dev.gentoo.org/~bircoph/distfiles/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+inherit cmake-utils
+DESCRIPTION="The japanese warehouse keeper game"
+HOMEPAGE="https://sourceforge.net/projects/ksokoban/"
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND="kde-base/kdelibs:4"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+CMAKE_IN_SOURCE_BUILD="yes"
+
+src_prepare() {
+ sed -i 's/%m//' "data/${PN}.desktop" || die "sed for desktop file failed"
+}
+
+# source lacks install target
+src_install() {
+ dobin ksokoban
+ dodoc AUTHORS NEWS TODO
+ domenu "data/${PN}.desktop"
+ for i in 16 22 32 48 64 128; do
+ doicon -s "${i}" "data/hi${i}-app-${PN}.png"
+ done
+}
diff --git a/games-puzzle/ksokoban/metadata.xml b/games-puzzle/ksokoban/metadata.xml
new file mode 100644
index 000000000000..2b2f1635f4e7
--- /dev/null
+++ b/games-puzzle/ksokoban/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>bircoph@gentoo.org</email>
+</maintainer>
+</pkgmetadata>